ShadowPlay and repeated frames... black magic ?!!

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by adolfotregosa, Feb 15, 2016.

  1. adolfotregosa

    adolfotregosa Member

    Messages:
    49
    Likes Received:
    0
    Is there some back magic sauce to actually make shadowplay work correctly ??

    Shadowplay output videos all have repeated frames and that makes playback useless. Please don't say obs / obs studio. It does work better but in game capture I can still catch repeated frames.

    For testing i'm using a simple unigine heave scene with the windwill. I just let it spin and record. Low settings. The 980M is sleeping...
    I have tried cru to make the monitor exactly 59.94 hz or 60hz I still get repeated frames.

    -> Video Example

    Any ideas would be great. I have nothing running. No steam overlay, msi afterburner, nothing that I can think of. Already tried a bunch of drivers..

    Going frame by frame (ctrl + left or right arrow) with mpc-hc is quite easy to find them.
     
  2. aufkrawall2

    aufkrawall2 Master Guru

    Messages:
    415
    Likes Received:
    3
    GPU:
    MSI RX 580 Armor
    I tried something similar some time ago:

    I capped BF4 framerate via in-game limiter to something below 60fps. in-game it was absolutely smooth (at least as smooth as it can be without vsync), I was spinning with the scout helicopter. Then I started the ShadowPlay capture with 60fps.
    According to the flags of the recorded video file, it was recorded with variable framerate. So far, so good.
    But: maximum reported framerate was stated with a value well above 60fps, while minimum fps were completely wrong. I don't remember the exact value anymore, but during capturing the fps were totally constant (I checked this with Frostbite frametime graph).
    When playing the video file with LAV filters and madVR smooth motion@75Hz (frame blending to prevent repreated frames when video fps doesn't match display refreshrate) in MPC HC, there was severe stutter, and I have the very strong feeling that it is in the recorded video itself and that it's not the fault of LAV/madVR.

    Of coursed captured videos by ShadowPlay aren't smooth either when you enable vsync during the capture with a framerate correctly matching monitor refreshrate, no matter with what video playback software you open it.

    To conclude: ShadowPlay videos are never stutter-free and thus it's quite a piece of crap imho.
     
    Last edited: Feb 17, 2016
  3. BeeJAyP

    BeeJAyP Active Member

    Messages:
    62
    Likes Received:
    0
    GPU:
    EVGA GTX 980Ti Hybrid
    I've also had trouble in the past with stuttery screen capture, strangely enough shadowplay is actually the one I have been able to use without stutters.

    I don't have too much to add unfortunately but here's one I recorded earlier today, as far as I can tell it's smooth, there's also a 4k version at 130mbps that doesn't appear to have stutters as well, but is of course much larger so I decided not to upload.

    https://drive.google.com/file/d/0B5KjOK5EyL_sTk9EUVNncVgxQnM/view

    Here is one with vsync off which usually causes me issues but in this case seems fine.

    https://drive.google.com/file/d/0B5KjOK5EyL_sWTdYcUpKc1VycjA/view

    I don't recommend using the Google viewer in those links though, for some reason that shows stutters in any video uploaded for me in Google Chrome.
     
  4. Margusx

    Margusx Active Member

    Messages:
    52
    Likes Received:
    0
    GPU:
    Msi GTX970 gaming 4g
    you guys have to make 60fps video at 60Hz with vsync on shadowplay anyway not record higher then 60fps with bandicam you can go to 120fps but how i try to make video always is best 60Hz with vsync on.


    If you make youtube videos 60fps is best with some apps you can make 120fps videos but due timing issues its look ugly if you try reconvert it to 60fps

    Ok example there is huge difference in timing between 60Hz and 120Hz
    its just not 50% more frames there is also big difference in timing
    So thats wahy vsync off videos jumpy with shadowplay.
    If you want make smooth video put 60Hz and vsync on and voila no issues at all.

    but anyway 60 not enough soon for games all games and newer hardware like 100Hz+ to maintain eyecandy.
     
    Last edited: Feb 19, 2016

  5. adolfotregosa

    adolfotregosa Member

    Messages:
    49
    Likes Received:
    0
    I'm doing that. V-sync on, 60hz with 60fps ( also tried 59.94 ) . I get stutters.. dammit
     
    Last edited: Feb 19, 2016
  6. adolfotregosa

    adolfotregosa Member

    Messages:
    49
    Likes Received:
    0
    Can you make a 2 min test file ? If I put my monitor at 59.94hz like your video I did not see any stutter.

    Also, which driver version are you using ?
     
    Last edited: Feb 19, 2016
  7. BeeJAyP

    BeeJAyP Active Member

    Messages:
    62
    Likes Received:
    0
    GPU:
    EVGA GTX 980Ti Hybrid
    Here's the 2 minute video, same settings etc as the earlier one.
    https://drive.google.com/file/d/0B5KjOK5EyL_sSVRoZlk4dXJMcHM/view

    Nvidia driver is 361.91 and GFE was 2.9.1, now it's 2.10.2.40 but nothing appears to have changed. Shadowplay is set to manual only, it's set to 130mbps (for 4k) but it will do 40mbps when recording to 1080p like in that video.
     
  8. MrBonk

    MrBonk Ancient Guru

    Messages:
    3,004
    Likes Received:
    88
    GPU:
    MSI RTX 2080
  9. adolfotregosa

    adolfotregosa Member

    Messages:
    49
    Likes Received:
    0
    Thank you.

    Repeated frame at :
    28s, 39s, 1m0s. Above 1m seams ok
     
  10. adolfotregosa

    adolfotregosa Member

    Messages:
    49
    Likes Received:
    0

Share This Page