1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Shadow Corruption when using MAX Shadow option -WOW

Discussion in 'Videocards - AMD Radeon Drivers Section' started by X7007, Oct 20, 2008.

  1. X7007

    X7007 Maha Guru

    Messages:
    1,419
    Likes Received:
    9
    GPU:
    Inno3D 1080GTX
    In WorldOfWarcraft there is bug since new patch 3.0.2 gives extra details with shadows and better graphics when moving the shadow quality slider to max it shows all over the screen shadows which doesn't look as shadows at all, just some black stuff randomly moving. but when you move it to default step 2 from left it works perfect.

    and when using windows mode there is no problem even when shadows quality to max - but something is wrong with it when trying to play it alot of times the game sometimes freeze and when trying to right click on anything at all the computer freeze and the music still going on the background but nothing moves.

    so its like nothing work, cant use that because it cause that and when trying to fix it using that it causing that, pffff

    Do you have this thing too ? i saw on WorldofWarcraft europ and usa forums people have this freeze with ATI 4870x2 too when using Window mode and they fixed the shadows using Window mode too, but it bloody freeze no matter what quality shadows you put it or whatever you try to change. ati :banana: fix this

    PS: and i hate those customer services that try to tell its my freaking computer problem ^^ because everything else like 30 more games works fine.
    and if they looked on any forum they would see that many people has this and not to try to change ram or stupid answer to try doing :biggun:
     
  2. Trasher

    Trasher Member Guru

    Messages:
    154
    Likes Received:
    0
    GPU:
    GTX 1080
    I have a similar problem - screen flickering, shadows looked weird, occasional freezes.. fixed it by disabling crossfire.
    So I have to wait for a new wow-patch or new drivers.
     
  3. Chris Chiu

    Chris Chiu Active Member

    Messages:
    85
    Likes Received:
    0
    GPU:
    ATI 5970
  4. vurt

    vurt Master Guru

    Messages:
    257
    Likes Received:
    0
    GPU:
    1080ti Strix OC
    disable catalyst ai, works for me (shadows on highest).
     

  5. X7007

    X7007 Maha Guru

    Messages:
    1,419
    Likes Received:
    9
    GPU:
    Inno3D 1080GTX
    Yes thats fix that, i did tried it before, dunno what happend now that now it works. ( What's the tradeoff of it being disabled) ?

    anyway, do you have any idea to fix the Band in arms bug on the specific map, what was its name ? so i will send to the catalyst driver crew about it.
     
  6. Djoums

    Djoums Active Member

    Messages:
    66
    Likes Received:
    0
    GPU:
    7850
    Disabling catalyst ai will not use both of your x2 gpu, only one. It shouldn't do any wrong with WoW though. Same with CF I think but not sure.
    Band in arms you mean Brothers in arms ? :) Gearbox said they would fix the ati bug with a patch.

    Edit : on a sidenote, I find the WoW 3D engine to be awfully optimized. During the WotLK beta I sometimes got around 30fps with shadows enabled and maxed out. That's what I got in Warhead with custom gamer/enthousiast config...
     
    Last edited: Oct 21, 2008
  7. Snooba the Wookie

    Snooba the Wookie Active Member

    Messages:
    61
    Likes Received:
    0
    Disabling Catalyst AI doesn't kill Crossfire (which is an age old misconception), but it resorts to Scissor render mode, which isn't the best for all games. When set to advanced, it tried to use alternate frame render on some games, etc.

    You can try this by benchmarking with and without AI (in mine, I take a small fps drop, but both my 4850 are working together, without a doubt, or most of my games would CRAWL).

    For wow,m disable Ai and disable Adaptive Antialias. Then you can set your shadows to max and enjoy.
     
  8. Iarwain

    Iarwain Banned

    Messages:
    3,048
    Likes Received:
    0
    GPU:
    4890 990//1120
    No, it does kill crossfire. I have a G15 LCD, as well as Everest, so I can see everything real-time, in-game, and if Catalyst AI is off, the second GPU's usage goes to 0 and stays at 0.
     
  9. Snooba the Wookie

    Snooba the Wookie Active Member

    Messages:
    61
    Likes Received:
    0
    Well, mine does work. Which is very very odd. I remember benchmarking just to make sure of it, and the fps loss was minimal with AI off. But by actually disabling crossfire, the fps took a dive.

    Now you make me doubt, gonna have to benchmark again :)
     
  10. Snooba the Wookie

    Snooba the Wookie Active Member

    Messages:
    61
    Likes Received:
    0
    Yap, Iarwain, it does disable Xfire now...which is quite against the benchmarks I first got, but there is not doubt now, one of my cards is just sitting there doing nothing.
     

  11. MadGizmo

    MadGizmo Maha Guru

    Messages:
    1,396
    Likes Received:
    0
    GPU:
    MSI R9 290X 8GB 2560*1440
    Same is true for a 4870X2. Because both GPUs are on the same card, you'll notice some erratic load on the second GPU, but the driver doesn't feed it anymore. That activity is probably just noise and is near 0 most of the time.
     
  12. Chris Chiu

    Chris Chiu Active Member

    Messages:
    85
    Likes Received:
    0
    GPU:
    ATI 5970
    Disable CAT AI means disable 2nd Card for Crossfire user. You can use GPU Tools to record the GPU usage for 2nd GPU. I wish Blizzard will fix this CF/SLI flickering shadow bug but they knew this bug over a month and they did nothing about this bug.
     
  13. lenix

    lenix Master Guru

    Messages:
    304
    Likes Received:
    0
    GPU:
    EVGA GeForce GTX 780Ti SC
    Is there any fix for this ? Planned fix from blizz or ati maybe ? :eek:
     
  14. sykozis

    sykozis Ancient Guru

    Messages:
    20,869
    Likes Received:
    538
    GPU:
    MSI GTX1660Ti
    I keep reading about shadow corruption, screen tearing, etc with WoW 3.0.2 patch. I run with graphics settings maxed out (and yes, I do mean ALL settings) and I don't see any shadow corruption at all. Graphically, the only thing I see is a massive framerate spike. I seem to peak at 254fps, which seems a bit high...but it depends on where I'm at within the game map so it doesn't really mean anything. My framerate seems to stay between 58fps and 96fps depending on the crowd size and detail level for the scene. (SW, I hit around 58-62fps, in Booty Bay I hit around 80-130fps dependent on crowd). I'm using Cat8.11RC1 on an OC'd HD4850 (stock 625/993 oc'd to 650/1090). I start to see very minor graphical distortions when my GPU exceeds 100C. Once the GPU fan spins up, the distortions come and go with the fan speed (fan speed increases, distortions decrease and vise versa). This issue has nothing to due with the game directly, with the exception of GPU load increasing GPU temp. I even still have Catalyst AI enabled, but set to standard (that was default when I installed 8.11RC1).
     
  15. Trasher

    Trasher Member Guru

    Messages:
    154
    Likes Received:
    0
    GPU:
    GTX 1080
    The shadow corruption is when using crossfire, btw what resolution are you using?
     

  16. sykozis

    sykozis Ancient Guru

    Messages:
    20,869
    Likes Received:
    538
    GPU:
    MSI GTX1660Ti
    1440x900....but considering moving back up to 1680x1050, which I'm hoping will fix the FPS spikes...or at least lessen them a bit. I've recently pushed the GPU to 675 and mem to 1100...starting to rethink that as well, since the card actually performed better at 650/1090
     
  17. Grinvon

    Grinvon New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    HD4870x2
    I noticed this issue before. Crashing and freezes my computer when shadow running in high mode.

    8.11 ATI catalyst driver version works ok with this issue, without disabling AI?
     
  18. vurt

    vurt Master Guru

    Messages:
    257
    Likes Received:
    0
    GPU:
    1080ti Strix OC
    No. I also notiched that WoW got micro stutters all the time with AI disabled and shadows on highest.. after some time the game freeze for me, had to reset the computer.
     
  19. ManOwaRR

    ManOwaRR Member

    Messages:
    12
    Likes Received:
    0
    GPU:
    hd 4870x2
    Disabling Cat A.I will fix this

    it seems its a crossfire/sli issue

    most likely blizzard needs to hire some good programers as well a new balance team in that matter :)
     

Share This Page