Setting up dual Monitors but ports arent working..

Discussion in 'Computer Monitor Forum' started by Larrywade, Jul 31, 2016.

  1. Larrywade

    Larrywade New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    Nvidia GeForce GTX 960
    So basically for the last few hours ive been trying to set up dual monitors but have had no luck..

    After hours of research and trying out different methods ive come to the conclusion that only one of my ports (HDMI) on my computer is working/enabled.

    So the other HDMI, DVI and VGA ports are not working.. (Im not sure whethere to call them ports or drivers)

    If i try to use any other cable in any other ports it will just say "no signal detected" (and yes i had it on the correct input)

    And im here to ask how do i fix this problem because i really need to have two monitors connected to my computer and with only one HDMI port available its not really helping.

    I have a nvidia GeForce GTx 960 graphics card

    I hope someone can help me because im out of ideas and cant find any useful information on google..

    Thankyou
     
    Last edited: Jul 31, 2016
  2. nz3777

    nz3777 Ancient Guru

    Messages:
    2,468
    Likes Received:
    210
    GPU:
    Gtx 980 Strix
    What ports are available on your monitors? I for example run 3 monitors,I use the Dvi-D or I not sure the very top port then monitor 2 is running off the 2nd Dvi port which is underneath dvi-i? My 3rd monitor runs on Display port /Vga adaptor.

    Go to Nvidia control panel, Select (setup multiple displays) then mess around with diffrent adapter options ie try using a diffrent plug or cable.It schould detect the monitor as soon as you plug them in unless you have some issue with the monitor itself. Nz

    Also please list the type of Monitors you are using, I have 2 Dells and 1 Asus running on my system.:)Asus veh247 Model number.
     
  3. Larrywade

    Larrywade New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    Nvidia GeForce GTX 960
    Hey man thanks for the reply!

    On one of my monitors one VGA and two HDMI ports are available, and on the other, one VGA one DVI and two hdmi ports.

    When i go to the nvidia control panel this is all i see:
    (There was supposed to be a image here but apparently im not allowed to post those yet lol)

    Basically the image just shows only one monitor not even detecting the other one that is connected.

    (The 2nd monitor that isn't showing is connected via DVI Cable to my PC)

    And the two monitors i'm using are both BenQ Monitors

    BenQ rl2455hm
    BenQ EW2440ZH

    Another question is will i need a HDMI to DVI/VGA cable for it to work? or can it be DVI TO DVI for example.
     
  4. Larrywade

    Larrywade New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    Nvidia GeForce GTX 960
    Dont worry i figured out what was wrong XD

    I dont want to say what it was because its way too embarrassing because it took me hours upon hours to figure it out hahahahahah

    But thankyou so much for helping out!
     

  5. nhlkoho

    nhlkoho Ancient Guru

    Messages:
    7,752
    Likes Received:
    362
    GPU:
    RTX 2080ti FE
    Did you try hooking up both monitors 1 at a time with the VGA cable and then with the HDMI cable to verify the cables are good and both monitors work on their own?
    I guess its possible but hard to believe that only 1 port on your GPU is working. There most likely is a problem somewhere else.
     
  6. Larrywade

    Larrywade New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    Nvidia GeForce GTX 960
    i figured out what the problem was don't worry!

    I have to say it lmao

    I litterally missed a DVI port at the bottom of my computer i thought i only had one but apparently theres another and it worked as soon as i plugged it into it hahaha.
     
  7. Larrywade

    Larrywade New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    Nvidia GeForce GTX 960
    but one thing i do want to know is why dont all the ports at the top of the back of my computer not work? are they like connected to something else? because i would really like to use the other HDMI port.
     
  8. nhlkoho

    nhlkoho Ancient Guru

    Messages:
    7,752
    Likes Received:
    362
    GPU:
    RTX 2080ti FE
    Those are for the integrated GPU on your CPU.
    You can use them if you enable it in the BIOS and install the Intel GPU drivers
     
  9. Larrywade

    Larrywade New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    Nvidia GeForce GTX 960
    thankyou very much, sorry for wasting both of your time! haha

    Ill definitely be using this forum again, very quick replys and very helpful!
     
    Last edited: Jul 31, 2016
  10. nz3777

    nz3777 Ancient Guru

    Messages:
    2,468
    Likes Received:
    210
    GPU:
    Gtx 980 Strix
    Yeah we like to think we are (pros) lol/. Dont be embarrassed Dude we have all at one time dont something stupid with our pc.

    Glad you figured it out. Yeah those ports your talkin about are on back of your motherboard and as Nhlkoho said are Intergrated graphics you need to enable in bios which are MUCH MUCH weaker then your video card ie gtx 960.
     

Share This Page