Server vulnerability 14 July 2013 - Database restored and passwords reset

Discussion in 'Frontpage news' started by Hilbert Hagedoorn, Jul 14, 2013.

  1. Hilbert Hagedoorn

    Hilbert Hagedoorn Don Vito Corleone Staff Member

    Messages:
    29,838
    Likes Received:
    133
    GPU:
    AMD | NVIDIA
    Hey everybody.

    As some of you know yesterday we had a vulnerability exploit as one of the moderator accounts got hacked. The hacker got access that way towards the ModCP panel and injected a malicious code. The exploit lasted merely an hour but throughout the night more and more became clear about the significance of all this.

    Initially I wanted to leave the database as is, but moments ago I decided to re-install a backup of 4 weeks ago. That way I can be sure that nobody messed with the MySQL tables. It sucks as a couple of weeks content will be lost, but I want to be sure that in the future an exploit wasn't hidden in the Vbulletin templates and MySQL tables.

    Better safe then sorry is my motto here. You again will be prompted to change your password. And if you registered within the last 4 weeks, you'll have to do so again.

    Sorry about this all !
     
  2. dsbig

    dsbig Ancient Guru

    Messages:
    3,847
    Likes Received:
    3
    GPU:
    SAPPHIRE NITRO 390x
    khaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaan!!!!!!!!!!!!!!!!!!!!!:bang::bang::bang:
     
  3. Tat3

    Tat3 Ancient Guru

    Messages:
    11,486
    Likes Received:
    0
    GPU:
    HIS R9 380 4gb
    Better safe than sorry.
     
  4. dsbig

    dsbig Ancient Guru

    Messages:
    3,847
    Likes Received:
    3
    GPU:
    SAPPHIRE NITRO 390x
    I been changing my password to everything and then I cant remember what the passwords where. lucky I use roboform to remember them for me.
     

  5. cowie

    cowie Ancient Guru

    Messages:
    12,801
    Likes Received:
    3
    GPU:
    GTX
    Glad you are on top of it boss
     
  6. Ghosty

    Ghosty Ancient Guru

    Messages:
    4,881
    Likes Received:
    2
    GPU:
    GT 840M
    I had a problem a minute or two ago, and I though my password had been changed, but it looks like it was when you were changing the databases over. All ok now.
     
  7. Hilbert Hagedoorn

    Hilbert Hagedoorn Don Vito Corleone Staff Member

    Messages:
    29,838
    Likes Received:
    133
    GPU:
    AMD | NVIDIA
    I noticed your email ;)
    Please make sure you use new passwords guys, like I stated. Better save than sorry okay ?
     
  8. Ghosty

    Ghosty Ancient Guru

    Messages:
    4,881
    Likes Received:
    2
    GPU:
    GT 840M
    Yep, changed my password and email address. Thanks.
     
  9. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,399
    Likes Received:
    9
    GPU:
    MSI Geforce GTX 1080
    Not sure if your restore went well, there seem to be a lot of missing OLD thread.
    For example there was quite a huge and old one in NVIDIA Driver forums talking about HPET. It seems gone now.
    Maybe I misunderstood something?
     
  10. k1net1cs

    k1net1cs Ancient Guru

    Messages:
    3,783
    Likes Received:
    0
    GPU:
    Radeon HD 5650m (550/800)
    That.
    Emphasis is mine.

    Those old threads were probably only recently being active again in less than a month ago.
    Reverting to a backup that's older than the post that 'revived' the old thread will always make the thread buried again, but not completely lost.
     
    Last edited: Jul 14, 2013

  11. dsbig

    dsbig Ancient Guru

    Messages:
    3,847
    Likes Received:
    3
    GPU:
    SAPPHIRE NITRO 390x
    yeah... but that thread was over 4 weeks old.


    stuff was lost...........:(
     
  12. Hilbert Hagedoorn

    Hilbert Hagedoorn Don Vito Corleone Staff Member

    Messages:
    29,838
    Likes Received:
    133
    GPU:
    AMD | NVIDIA
  13. dsbig

    dsbig Ancient Guru

    Messages:
    3,847
    Likes Received:
    3
    GPU:
    SAPPHIRE NITRO 390x
  14. Hilbert Hagedoorn

    Hilbert Hagedoorn Don Vito Corleone Staff Member

    Messages:
    29,838
    Likes Received:
    133
    GPU:
    AMD | NVIDIA
    Just post some replies and the thread will be bumped up again.
     
  15. k1net1cs

    k1net1cs Ancient Guru

    Messages:
    3,783
    Likes Received:
    0
    GPU:
    Radeon HD 5650m (550/800)
    Well, damned if Hilbert did, damned if Hilbert didn't.
    If he decided to keep the database untouched and then something like this happened again because of it, you'd probably be the first (again) to complain about having to change your password.
     

  16. dsbig

    dsbig Ancient Guru

    Messages:
    3,847
    Likes Received:
    3
    GPU:
    SAPPHIRE NITRO 390x
    argg:bang:
     
  17. Hilbert Hagedoorn

    Hilbert Hagedoorn Don Vito Corleone Staff Member

    Messages:
    29,838
    Likes Received:
    133
    GPU:
    AMD | NVIDIA
    Please make a new one, we'll have to start over with some threads I'm afraid. I know this all sucks my friends, but once the threads are created again this will start rolling fast enough.
     
  18. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,399
    Likes Received:
    9
    GPU:
    MSI Geforce GTX 1080
    Ok things are fixed correctly now. It seem I was only able to see Max 9 threads. Now things seems ok here.
    Thanks Hilbert
     
  19. StewieTech

    StewieTech Chuck Norris

    Messages:
    2,004
    Likes Received:
    36
    GPU:
    MSI gtx 960 Gaming
    I understand, better to be safe. I just hope the little **** who did this get some kind of punishment through whatever means avaible!

    edit: it seams the forum has lost pretty much all its content, sections with only one page of threads, is this normal, is it this bad?
     
    Last edited: Jul 14, 2013
  20. Anarion

    Anarion Ancient Guru

    Messages:
    12,921
    Likes Received:
    2
    GPU:
    EVGA GeForce GTX 1070 ACX
    Shame, I was wondering why content was suddenly Lost.
     

Share This Page