1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Screen tearing while scrolling on desktop in Win 10?

Discussion in 'Operating Systems' started by flimbo, Aug 12, 2015.

  1. flimbo

    flimbo Master Guru

    Messages:
    757
    Likes Received:
    7
    GPU:
    MSI GTX 970
    Screen tearing while scrolling in Firefox in Win 10?

    Just noticed some odd screen tearing today in Windows 10 with both Firefox and Thunderbird.
    It's most noticeable if you get a page of images up, like a google image search and then scroll slowly down with the mouse wheel. The screen tears roughly a couple of cm down from the top. Weirdly if you keep on scrolling down a page then it goes away, and then comes back when you scroll back up again.
    Chrome with the smoothscroll extension works fine.
    Is anyone else getting this? I don't think it happened before todays Windows Updates?
     
    Last edited: Aug 12, 2015
  2. tsunami231

    tsunami231 Ancient Guru

    Messages:
    9,015
    Likes Received:
    235
    GPU:
    EVGA 1070Ti Black
    I have this issue too, it either Win 10 issue or Nvidia driver issue, I getting random tearing in Firefox/Cyberfox and many other Windowed (programs) it happens very frequently if more then 1 Windowed (program) is running, I also seen it happen with Just Firefox running, some times it fine other times it tearing

    It was happen before the last batch of windows updates though

    Seeing I noticed this on first day I updated to windows, I hade Swtor Open in windowed (fullscreen) also opened PCSX2 also Windowed and pcsx2 would tear if Swtor was open.

    It seem completely random some times it fine other times it tears, clean install of window 10 too

    I mostly Notice it Firefox thought, I usual have Swtor open and Firefox open at same time I rarely have 2 windowed programs running at once
     
    Last edited: Aug 12, 2015
  3. deets75

    deets75 Guest

    yep I see it now as well. not sure if it existed before but think I would have noticed it :(
     
  4. Corrupt^

    Corrupt^ Ancient Guru

    Messages:
    6,849
    Likes Received:
    221
    GPU:
    ASUS 1080GTX STRIX
    I kept getting a weird laggy feeling as well. Disabling GPU rendering in my browsers fixed it for me.
     

  5. flimbo

    flimbo Master Guru

    Messages:
    757
    Likes Received:
    7
    GPU:
    MSI GTX 970
    How do you disable GPU rendering in the browser? I've tried with hardware accelaration off/on. It doesn't make any difference. Window update introduced a flash player update today but it was still out of date. I've updated flash and still no difference.
    Wish I'd stayed with my rock stable Win 7. Loved the aero. Can't stand Win 10.
     
  6. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    15,655
    Likes Received:
    271
    GPU:
    EVGA GTX 1080 Ti SC2
    I worked around the annoying screen tearing in Firefox v40.0 by disabling "Smooth scrolling" under Options > Advanced > General settings. This then mimics the multi-line scrolling of Chrome and other browsers which makes the screen tearing less obvious (assuming it is still occurring as it is much harder to spot).
     
  7. Merlena

    Merlena Member

    Messages:
    47
    Likes Received:
    0
    GPU:
    EVGA GTX 980 Ti 6GB SC+
    Thanks Darren. While on it, any other browser you would highly recommend? :)
     
  8. -Tj-

    -Tj- Ancient Guru

    Messages:
    15,975
    Likes Received:
    1,221
    GPU:
    Zotac GTX980Ti OC
    Hm runs fine here, but Im using x64 version of FF40. -HW on, smoothing on, 2d on, etc.
     
  9. tsunami231

    tsunami231 Ancient Guru

    Messages:
    9,015
    Likes Received:
    235
    GPU:
    EVGA 1070Ti Black
    That dont stop the tearing

    IF you see this in Firefox Help>Troubleshooting - graphic section

    Direct2D Enabled Blocked for your graphics driver version.

    HWA is disabled even if you have checked, it also changes how the text looks.

    This explains why FF text looks wrong and it tears. It dont explain why some Windowed bordless programs tear at random and other times it dont
     
    Last edited: Aug 13, 2015
  10. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    15,655
    Likes Received:
    271
    GPU:
    EVGA GTX 1080 Ti SC2
    @tusanami231 - true, it does not fix the tearing but I find it much less noticeable. It is a workaround not a fix.
     

  11. tsunami231

    tsunami231 Ancient Guru

    Messages:
    9,015
    Likes Received:
    235
    GPU:
    EVGA 1070Ti Black
    oh it is les noticable cause screen isnt scrolling smoothly which is just as ugly as the tearing hah
     
  12. flimbo

    flimbo Master Guru

    Messages:
    757
    Likes Received:
    7
    GPU:
    MSI GTX 970
    Problem is fixed by installing the latest 355.60 drivers.
     
  13. deets75

    deets75 Guest

    ta :) I did think it odd that my laptop was nothing having the issue but the desktop was.

    sadly no driver update for me so far.

    edit: got it via the geforce experience thing and not the windows update :)
     
  14. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    15,655
    Likes Received:
    271
    GPU:
    EVGA GTX 1080 Ti SC2
    I think I have found what causes the screen tearing in Firefox v40.0 on my PC.

    I typed about:config into the address bar and scrolled down looking for emboldened entries which indicate user tweaked values. I noticed these two:

    gfx.blacklist.layers.direct3d11 = 3
    gfx.blacklist.direct2d = 3


    I right-clicked on the first option and selected Reset from the context menu then exited and reopened Firefox. I scrolled down my home page and it appears that the screen tearing is now gone.

    Can someone else test this please and post their findings? Thanks.

    *EDIT*
    If you type gfx into the search bar of the about:config window it will show the settings easier. There are three entries shown in bold, the other being:

    gfx.direct3d.last_used_feature_level_idx = 0

    Unfortunately, it looks like Firefox sets these three values to the ones shown above when you exit a second time so this is not a permanent fix (unless someone knows how to override these variables). I think it is the first variable (gfx.blacklist.layers.direct3d11) which when reset fixes the scrolling as that was the only one I reset when I first tried it.
     
  15. flimbo

    flimbo Master Guru

    Messages:
    757
    Likes Received:
    7
    GPU:
    MSI GTX 970
    Just install the latest drivers dude. Problem gone.
     

  16. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    15,655
    Likes Received:
    271
    GPU:
    EVGA GTX 1080 Ti SC2
    I have the latest v353.62 WHQL graphics drivers installed though!!! :3eyes:
     
  17. deets75

    deets75 Guest

    latest just out is 355.60 :)

    try updating via geforce experience
     
  18. Darren Hodgson

    Darren Hodgson Ancient Guru

    Messages:
    15,655
    Likes Received:
    271
    GPU:
    EVGA GTX 1080 Ti SC2
    Oh nice! Thanks for the heads up. :D

    *EDIT*
    Confirmed issue fixed after a reboot.

    The two gfx. variables under about:config I mentioned first are now gone, which makes sense as resetting them to null values fixed the tearing.

    Well done to NVIDIA for the quick fix.
     
    Last edited: Aug 13, 2015
  19. primetime^

    primetime^ Master Guru

    Messages:
    887
    Likes Received:
    7
    GPU:
    XFX Radeon RX580
    Even better those of us who never got the issue to begin with LOL. AMD sometimes has its good points:)
     
  20. velum

    velum Member

    Messages:
    18
    Likes Received:
    0
    GPU:
    EVGA GTX970 SLI
    Sadly not fixed for me after the update. Still getting bad tearing with Firefox 40. 970 SLI
     

Share This Page