Screen goes black. Have to reset to get it back

Discussion in 'Videocards - AMD Radeon' started by Hootmon, Jun 26, 2014.

  1. Hootmon

    Hootmon Maha Guru

    Messages:
    1,232
    Likes Received:
    6
    GPU:
    XFX THICC III Ultra
    Im kind of new to modern AMD cards. Since installing my current card Ive been having a problem where I find my screen in power-save mode that I cant return from. Apparantly my GPU just isnt putting out any signal. I have to reset my machine to get it back.

    The computer isnt asleep. I can see the drive is still active, and I my G15 KB still shows activity on its LCD and my mouse still lights up. I just cant see anything on the screen.

    Happens with 14.4 and the 14.6 beta drivers.
    Windows 8.1 Pro Update 1 64-bit

    Any ideas?
     
  2. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,562
    Likes Received:
    1,626
    GPU:
    ROG Strix 1080 OC
    I think another member here has a similar issue with any drivers since 14.1

    Give 13.12 WHQL a shot and see if it still does it, least you can eliminate hardware as the problem if it works with 13.12

    Use DDU in safemode to remove the old drivers first
    http://www.wagnardmobile.com/DDU/
     
  3. Hootmon

    Hootmon Maha Guru

    Messages:
    1,232
    Likes Received:
    6
    GPU:
    XFX THICC III Ultra
    Thanks. Ill give that a try when I get home.
     
  4. AcidSnow

    AcidSnow Master Guru

    Messages:
    427
    Likes Received:
    17
    GPU:
    VisionTek R9 290X
    I had a similar black screen issue with a previous 290, I had to under-clock it a bit using MSI-afterburner (to stock settings). So if your card is factory OC'd then put it back to 947/1000. That might reduce your black screens. Also avoid putting the computer to sleep. You might want to try unplugging one of the PCIE power plugs from your 290, and swap it for a different PCIE power plug. Some power supplies might not be delivering adequate power though every power plug.

    Ultimately I just got rid of the 290, and bought a 290X. Haven't had a single issue with this card, and that makes me far happier. I didn't like coming back to find a random black screen, it was just annoying; sometimes I got them when I was gaming, so the card was just not reliable in my case.
     

  5. Hootmon

    Hootmon Maha Guru

    Messages:
    1,232
    Likes Received:
    6
    GPU:
    XFX THICC III Ultra
    It is being OC'd. Ill try rolling that back to see if it makes a difference.

    I didnt even think about trying different power connectors. WIll check that if needed.

    The computer definately isnt going to sleep/hibernating. Both are explicitly disabled. However, Im wondering if there may be some other PCI-e power-saving that I missed.
     
  6. Hootmon

    Hootmon Maha Guru

    Messages:
    1,232
    Likes Received:
    6
    GPU:
    XFX THICC III Ultra
    I think I might have found it.

    In the Balanced Power Options profile (default state when Im not running games) Advanced Settings, the PCI Express/Link State Power Management setting was set to 'Moderate Power Savings'. I set it to 'Off'. Screen didnt go black overnight.

    It makes sense if the AMD card is more sensitive to external power management than my old nVidia card was.
     
  7. darrenj

    darrenj Ancient Guru

    Messages:
    1,732
    Likes Received:
    81
    GPU:
    EVGA 3080
    mmmmm
    thanx guys¨
    I will be testing this with my Sapphire R9 290 TRI-X OC
    Got a couple of these but not when gaming...
    Just when normal browsing the internet AND when my daughter started a win 8 game from the Win8 Tile..
     
  8. PNeV

    PNeV Ancient Guru

    Messages:
    2,069
    Likes Received:
    2
    GPU:
    MSI GTX 1070 Armor
    My 7950 sometimes goes to sleep and never wakes up. Has done it on every driver since I got it since August 2012. I think its more a hardware thing than software. I just have to press my reset button on the case to get round it.

    If your screen goes blank and doesn't come back on when uninstalling drivers, use DDU as mentioned above. It does it in safe mode and it doesn't happen. Its a God send for me.
     
  9. mtdew332

    mtdew332 Member Guru

    Messages:
    123
    Likes Received:
    1
    GPU:
    Sapphire R9 390x
    If you open up GPU-Z and watch your clock speeds when browsing you'll see what your problem is.
    You'll see the memory occansionally jump up to full 3D speeds while browsing / watching youtube etc..etc.. while the core only does a small jump.

    This forces the memory to make the jump to full 3D speeds using the 2D voltage because the core isn't jumping high enough to trigger the 3D voltages.

    On these cards the core voltage supplies the core AND memory voltage together, they aren't separate like the previous generation AMD cards.
    Also the 2D and 3D voltages are controlled together and aren't separate on the 290's either like the previous generation cards.
    ie: 290's use an "offset" to adjust the 2D and 3D voltages together dynamically. (raising one using a + offset also raises the other by the same offset % )

    So your solution would be as simple as just bumping up your core voltage a bit, so the memory controller has a bit of extra voltage in 2D mode to handle those sudden memory jumps to full 3D speeds.

    The reason why it seems random is because the voltages actually fluctuate a bit up & down.....so if your voltage just happens to be fluctuating down right when the memory is making that sudden leap to full 3D speeds...BAM!..Black Screen....simply because the memory controller didn't get enough voltage at the exact right time it needed it to handle that sudden jump to full memory clock speeds.

    And of course if your overclocking the memory, the more voltage it's gonna need in 2D mode cuz its jumping to whatever maximum 3D speeds you set using just the 2D voltage.....either that or you'll have to reduce your memory clocks so the current 2D voltage is enough to prevent the black screens when the memory does its sudden jumps to its full-speed clocks.

    Hope that makes sense.
    If you use GPU-Z and watch it, while browsing/YouTube you'll see what i mean.

    That is why it only happens to you in 2D mode.
    When actually in a game, your memory is fine since its running with full 3D voltages....
    ie: since the core is in 3D mode too while gaming... this sets both the core and memory to their full 3D voltages.
    (This is also why people who are using high core overclocks on their cards usually don't see black screens in 2d mode, since they are already using a high enough core voltage that it is also giving their memory controller the extra voltage it needs for both 2D and 3D.)

    So any time you overclock the memory on a R9 290 - I find it's best to think of it as if you are overclocking that memory in 3D AND 2D modes and it may need a bit more voltage for 2D mode even if its stable in 3D mode at the current voltage....since the memory does sometimes jump to full 3D clocks in 2D mode using just the 2D voltage and that may not be enough.
    And to give the memory controller more voltage when needed for 2D and 3D ...you need to adjust the core voltage since it controls both the core and memory controller voltage together in both 2D and 3D mode using whatever offset value you choose.
    (And of course if you get Black Screens in 3D mode when overclocking the memory then you are simply overclocking the memory too far or you need to up the core voltage a bit to give the memory controller more voltage.)

    note: i quoted your specific post on purpose so as to be sure that this isn't to be confused with the other posts where their black screens are due to the infamous "wake from sleep bug" or being caused by low power states.
    They are different issues than the random black screens while actually using the pc in 2D mode.... yet fine in 3D mode while gaming/benchmarks as you described.
     
    Last edited: Jun 28, 2014
  10. Turban

    Turban Member

    Messages:
    30
    Likes Received:
    0
    GPU:
    Gb R9 290 OC
    I use to have the same kind of problem.

    A solution was to set a 2D profile with MSI Afterburner. 520/625. Solved most of the problem.
    Still, a 3D profil was necessary, as sometimes, black screen would also happen to me during gaming.

    Final solution was to revert to drivers 13.30 whql. No black screen at all.

    I tried all power saving features and as far as I could tell, it made not difference.
    Wasn't a psu problem either.

    Edit: Like I said in another thread, with the 13.30 I don't crash anymore but my memory gets stuck at minimum frequency... easy to unstuck with MSI AB , but then going back to 13.30 is not the perfect fix, but it's the best I've found so far..
     
    Last edited: Jun 30, 2014

  11. rene mauricio

    rene mauricio Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    ASUS STRIX GTX 970
    For me the solution was none of the above. My solution was to take my stock 290 and flash it to a 290X - specifically using this BIOS.

    Sadly the shaders did not unlock but it did OC the core and memory as well as adding UEFI support. I have not had a single issue with it thus far with any of the newer drivers. I am still not 100% why this worked. I suppose this is why some cards crash and others do not as it all comes down to BIOS.
     
    Last edited: Jul 2, 2014
  12. dalewb

    dalewb New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    AMD Radeon HD R9 290X
    Former 290X litecoin miner card

    This thread helped me a lot!

    I have a R9 290X that was used 24/7 for 3 months mining litecoins, which I think may have damaged the card somehow. After ASICs invaded the market, video card mining became obsolete in early 2014. So I decommissioned my mining rig and began using the 290X in my primary PC. But the PC would freeze up randomly while playing 3D games. I tried adjusting the PCI Express Link State Power Management setting to off, but that didn't stop the issue. At first, I thought tripping the tiny switch on the card to the "other" BIOS fixed the issue, as it went away for a day or so, but that was just a red herring - it came back.

    Lowering the GPU memory and core speeds using MSI AB by about 15% has solved the problem. I suppose, after reading the post by mtdew332, that I could increase the voltage a bit, but I don't see the need right now. This card is much faster than I need for any game right now. Maybe in the future that will change and I can revisit this then.

    (I'm not sure if this played a part of the problem, but I was switching between the 290X and a Radeon HD 7950 for a bit there (I have a bunch of video cards just lying around right now). I may have had the wrong version of AMD's drivers installed for the 290X, but yesterday I used DDU to uninstall everything in safe mode and installed the latest drivers for the 290X.)

    Cheers!
     
    Last edited: Jan 2, 2015
  13. Mokum

    Mokum Member Guru

    Messages:
    156
    Likes Received:
    1
    GPU:
    x9 290x
    I Had this problem with my gigabyte r9 290x when i was running windows 7.tried all kind of drivers without result.. Now im running windows 10 technical preview and i haven't had this problem any more.
    using the latest windows 8.1 driver
     
  14. dalewb

    dalewb New Member

    Messages:
    8
    Likes Received:
    0
    GPU:
    AMD Radeon HD R9 290X
    Yeah, glad you mentioned this, as the problem came back and nothing I did could fix it. I finally wiped my system hard drive and reinstalled windows 8 and the problem seems to be gone. Just crazy!
     
  15. Fender178

    Fender178 Ancient Guru

    Messages:
    4,184
    Likes Received:
    207
    GPU:
    GTX 1070 | GTX 1060
    nm old topic
     

  16. stitch

    stitch Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    GeForce GTX 970
    Thanks, this fixed it for me :thumbup:
     
  17. Hootmon

    Hootmon Maha Guru

    Messages:
    1,232
    Likes Received:
    6
    GPU:
    XFX THICC III Ultra
    Glad to hear it.
     
  18. JonnieWare

    JonnieWare Member

    Messages:
    13
    Likes Received:
    0
    GPU:
    NVidia GTX 280m SLi
    Hey guys, I had a similar problem with an alienware m17x r2 with ATi 4870m X-Fire, giving a blank screen after trying to wake from sleep.
    I solved it by express uninstalling ALL ati drivers and software, restarting, installing the original DELL ATi drivers, then restarting then wake-up worked.
    Then, i tried installing the latest ATi drivers over this and it worked.
    Seems like some kind of ATi conflict with windows..
    I Also had another with ATi 5870m. on this one, i updated the ATi Bios and that worked on that laptop..
     
  19. Mannerheim

    Mannerheim Ancient Guru

    Messages:
    4,812
    Likes Received:
    25
    GPU:
    GTX 260 oem 1792MB
    I have same prob... I took sleep of and use "screensaver" only...
     

Share This Page