Sapphire HD 7870 OC crash with black screen and sound loop

Discussion in 'Videocards - AMD Radeon' started by Zahlokhnir, Jun 16, 2012.

Thread Status:
Not open for further replies.
  1. attrition

    attrition New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Sapphire HD 7870 Ghz OC
    Yes I think will go ahead do that. Googled 7870 problems comes up many threads on it. Well back to Nvidia, good luck to all.

     
  2. Genesis

    Genesis Active Member

    Messages:
    73
    Likes Received:
    0
    GPU:
    GTX 660 Ti
    Damn, issue happened after again after a few days. Might try out different bios.
     
  3. Jvano

    Jvano New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    Sapphire 7870 OC Ghz Edit
    Hello! I'm from Argentina, sorry for my bad English

    I have a 7870 ghz OC and I have the same problem, I am very sad and the seller does not want to change it.

    Black screens to play ... I tried many things but nothing change

    Now I am with my old 6850 Toxic, waiting for a solution to this problem .. I think when I have money, I will buy a 670.

    I have this problem in htis games: Crysis 2 / Alan Wake / Diablo 3

    But never happen in the game Men of War Assault Squad
     
  4. tayguer84

    tayguer84 New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    Sapphire 7870 OC
    I just want to remind everyone that RMA'ing with Sapphire will not fix the issue. I'm on the second card, and I even reformatted after getting it, and I still have the black screen issue.

    I'm trying the second bios that ALEUT posted. I guess knowing that Sapphire is releasing new bios should be encouraging, right? The fact that it has a different voltage might mean they are working on the issue.
     

  5. Rookie

    Rookie New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    Asus 670GTX 2GB DirectCu2
    Hello gamers :)
    I'm new here, has the same problem for ~1 week. Purchased Club3D HD7870, fast, cool, effective card...but only then didn't making black screen with freezed sound :(
    Tried to solve this problem : downclocking, disabling "all" things, different drivers and etc... no luck. Random lockup in BF3, Stalker series, Deus Ex. Today changed it for Asus GTX670 (+100$). Hope my gaming will be headpain free :)
    Before this I has owned HD5870 - super card, <HD4890<HD4870>8800GT... Five years and again returned to "green" gaming :)

    Arunas (Lithuania)
     
    Last edited: Oct 4, 2012
  6. kasiop

    kasiop Member

    Messages:
    14
    Likes Received:
    0
    So anyone thinks there will be a fix to those issues someday?? :(
     
  7. ALEUT

    ALEUT New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    Sapphire 7870
    Have you tried first bios?
     
  8. kasiop

    kasiop Member

    Messages:
    14
    Likes Received:
    0
    Yes I tried first bios with 12.4 and got some BS ;(
     
  9. ALEUT

    ALEUT New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    Sapphire 7870
    Try to increase the voltage up to 1.231 or 1.238.
     
  10. kasiop

    kasiop Member

    Messages:
    14
    Likes Received:
    0
    I can't increase voltage via software with this card... dunno whats wrong

    Afterburner doesn't show voltage anymore even if unlocked from settings, and trixx shows it but doesn't really change, voltage monitors show the same voltage
     

  11. ALEUT

    ALEUT New Member

    Messages:
    7
    Likes Received:
    0
    GPU:
    Sapphire 7870
    All the sapphire's cards allow to change voltage. Search the problem in your installed software.
     
  12. Pill Monster

    Pill Monster Banned

    Messages:
    25,216
    Likes Received:
    7
    GPU:
    7950 Vapor-X 1100/1500
    You could try the method I described here: GUIDE: Control voltage without using Afterburner or Trixx

    YMMV but worth a shot....
     
  13. rievhardt

    rievhardt Member Guru

    Messages:
    107
    Likes Received:
    0
    GPU:
    Sapphire 7870
    UPDATE:
    I got my replacement card from the shop.
    for some reason it says DUAL X on the fan instead of Sapphire... (I have no idea why...I asked the store and they don't know either)
    perhaps it's another 7870 batch? (I've searched and I can't confirm)

    what does your cards say on the Fan?

    btw I bought a ASUS Xonar DSX...because the DX is out of my budget...

    I just installed the 2...
    I hope the fans won't hit the sound card, the space between them is really tiny!

    onboard sound is also disabled.

    I'm praying that my nightmare ends and everthing would now go well
     
  14. xfarsx

    xfarsx New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    Sapphire HD 7870 OC
    Hi everybody!

    i'm from Brazil and bought this card a few months ago, since a installed this card i had this problem, tried everything that says in every topic that people created. But today i'm glad because i maybe finally got the solution for this issue (maybe only for me). Yesterday i just open the task manager and closed "MOM.exe" then i installed the 12.9 beta and tried to play, at first i played very well, But today when i tried again to play the game the PC crashed again, so i tought what could it be, then i remember that i had end "mom.exe" from task manager and after that i tried to play, it goes very nice without crashing, i think i might end the crashes now. Hope i can help someone with this, i´m still testing lets see if now is OK.
     
  15. CJB

    CJB New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    Asus 7870 DirectCut 2GB
    Maybe some useful information, I was getting a lot crashes with WoW, but 2 weeks back I disabled the setting use DX11 in WoW. and since then I havent experienced any crashes in WoW.

    So maybe its DX11 related? Since the problem only occures with specific games.
     
    Last edited: Oct 8, 2012

  16. milentenev

    milentenev New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    Sapphire 7870 OC
    Hi from me too.

    As a recent Sapphire 7870 2gb OC buyer I was plagued by the same black screen problem + constant clock switching.

    However I decided to register in this forum because I found a solution for my problems. Between many trial and errors I found this configuration to be the most stable one -
    12.6 drivers (I used Driver Sweeper before installing them) + CCC + HiS overclocking tool to disable ULPS and to disable 2d clocks. Note that 12.6 are not switching clocks but without the disable 2d clocks option it continues to black screen. Also note that during the new drivers installation (after Driver Sweeper) even if I started 12.6 drivers installer I finally got 12.9 version (noticed it through the HiS info bar). I suspected some kind of update during the installation so I installed them again (with driver sweeper) but this time disconnected from internet.

    So this configuration stopped the black screens and I managed to do a 3+ hours GW2 session + 5+ hours of Borderlands 2 session. Note that I didn't had a chance before to achieve this with other drivers. GW2 was more susceptible to black screens and I couldn't play for more than 1 hour without a black screen. For Borderlands 2 I managed to play for ~2 hours before a black screen. I tried 12.7beta, 12.8 and 12.9beta and they all produced black screens and 12.8 and 12.9beta are susceptible to clock switching all the time.

    I will play some more and report the results here. But note that I don't have the time for a long sessions during the weekdays. I really hope that this info will help you all.
     
  17. terryble

    terryble Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    ASUS GTX 670
    Sigh~~it has been 5 months now and the problem still not yet solved~~
    and again AMD did not officially acknowledge the problem
     
  18. RedHulk

    RedHulk New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7870 OC GHz
    Hi,

    I like to share this to you guys, because I have been reading and struggling with my HD 7870 OC + WOW combination.

    I had similar issue with my brand new HD 7870 OC when I was playing WOW. Without no warning the system crashed, and this buzzing sound started. Nothing helped but power on/off. My first thought was that it's something to do with GC driver but eventually I discovered that it was related Asus EPU-6 engine software which is controlling the system speed, and other things like CO2 emission level.

    I disabled the EPU-6 engine software, and after that my WOW is working fantastic. No crashes any more! I'm also using ATI driver release 12.9 beta.

    If anyone has similar setup than I have, it's worth of try.

    Good luck.

    My setup:
    Core i7 / Asus P6T delux / Intel SSD / HD 7870 OC GHz GDDR5
     
  19. milentenev

    milentenev New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    Sapphire 7870 OC
    Hi RedHulk, I'm using pretty much the same mainboard as yours except that it's not the delux model. However I literally can't use Asus EPU because my processor is overclocked and Asus EPU is not working in overclocked systems. And also with 12.9 I'm experiencing a lot of crashes in Guild Wars 2 and Borderlands 2. Also could you share if you are using the directx 11 option in WoW which is known to cause the black screen crash?

    P.S: and before someone said to me that the OCed processor could cause the problem no its not it because I was using Sapphire 5870 OC before my current 7870 and I didn't have any problems in the mentioned games.
     
  20. RedHulk

    RedHulk New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7870 OC GHz
    Hi milentenev, yes I'm using Directx 11 in WOW. I haven't OC'd my rig so I can't say anything for the OC related matters. I also checked from my windows "administrative tools" that there is no errors in the system, that can lead to the crash. I had error code 315 "printer sharing" issue, and I also fixed that one, so now my log is clean of errors. I don't think that it had anything to do with it but you never know. It's better to be sure.

    For me the WOW has now worked fantastic no crashes has happened after my "modification". I'll let you know if it happens again.

    I hope get you rig working properly, otherwise it frustrating! Take care.
     
Thread Status:
Not open for further replies.

Share This Page