Sapphire HD 7870 OC crash with black screen and sound loop

Discussion in 'Videocards - AMD Radeon' started by Zahlokhnir, Jun 16, 2012.

Thread Status:
Not open for further replies.
  1. rievhardt

    rievhardt Member Guru

    Messages:
    107
    Likes Received:
    0
    GPU:
    Sapphire 7870
    @Genesis
    my motherboard's BIOS to be exact...4203
    http://www.asus.com/Motherboards/Intel_Socket_1155/P8H61M_LEUSB3/#download

    would be different if you have a different mobo...
    I'm now on 4204, I hope it would be better

    @JonasBeckman
    did the shop from where you bought it was the one doing the replacement or Sapphire itself? Which party did you contact? the shop or Sapphire? I hope your replacement card resolves the issue completely.
     
  2. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,527
    Likes Received:
    2,930
    GPU:
    MSI 6800 "Vanilla"
    I use a Nordic store called Komplett, they can be a bit strict and there are probably cheaper alternatives though I find them to be quite good and they do the testing themselves then if it's defective usually a replacement is sent although I believe they do have contact with the actual manufacturers as well.

    They have to verify the problem you report for the procedure to pass which since this passed must have meant there was something wrong with it but if that's due to the drivers or a general problem of the 7000 series in certain configurations or this 7970 OC model I can't say but I do hope that this will improve things since this series has been swapped to a newer version judging by those images so there must have been some reason for such a replacement.
    (But it doesn't have to mean the previous model was flawed or such.)

    Guess I'll know this upcoming week when the package arrives. :)

    Just in time for some of the upcoming Autumn releases too, ha ha.
     
  3. rievhardt

    rievhardt Member Guru

    Messages:
    107
    Likes Received:
    0
    GPU:
    Sapphire 7870
  4. defcoms

    defcoms Member Guru

    Messages:
    100
    Likes Received:
    0
    GPU:
    MSI-7970ghz Bios Trifire
    That is similar to the issue I am having with Trifire 7970's and eyefinity. Only when my screen gets frozen like that it is a hard lock and the sound will make a buzzing sound loop. The system is unresponsive though. I can press numlock or caps lock and no change on keyboard lights. Only thing to do is to do a hard reset.
     

  5. Vengeful#1

    Vengeful#1 Member Guru

    Messages:
    169
    Likes Received:
    0
    GPU:
    Sapphire HD7970 OC 3GB
    Another update here, I am now running 12.8 cats with 12.8 cap2 and card is still running perfectly!..am yet to see a crash and have been running this card in bios 2 (overclocked mode) extensively in Guild Wars 2 with zero problems since day 1.

    I am of the firm opinion that this is a hardware conflict and a not faulty card issue as some people here are claiming..especially after seeing how another user has posted in this thread recently with the same card as mine but using an Asus motherboard and is experiencing problems. :question:
     
  6. terryble

    terryble Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    ASUS GTX 670
    Guys after a week of testing~~
    i am here to share the solution of MY case~~

    Forget bout the driver change...im using 12.8
    Forget bout the tessellation optimize off or surface format optimization off setting~(both is on for me now, no performance drop)
    all doesn't really resolve the problem for me~~

    again for MY CASE~~~i simply need to download Sapphire Trixx and tune up the "Board Power Li" +3 then there is no black screen for 1 week of intense D3 and SC2

    But seems like Trixx and CCC 12.8 doesnt really sync well~~
    everytime i open my comp i have to start Trixx again and tune up the board power~~

    Anyway~~im quite confident to say that my problem with the GPU is resolved~~(after 30 hours of D3 and 15 hours of SC2 + maybe another 10 for TF2)
    HOWEVER...no AMD GPU anymore!!

    hope this help some of you guys~~
    The situation might still varies between brands and boards~~
    some says that they try tune up the voltage but it doesnt help~~anyway...dun use CCC and try sapphire Trixx and up power exactly by +3..see if it makes a difference..

    UPDATE: From the Gaming tab of CCC, i also tune the " anti aliasing mode" to Performance & "Vertical Refresh" to a tab nearer to Performance, im not sure if this helps in resolving the problem, (while leaving AMD optimized and surface format optimization on) perhaps u all can also try make the same changes

    Specs info
    Asus Sabertooth X58 + i7 930 + 6GB Kingstan Hyper X RAM + 1000watt PSU
     
    Last edited: Sep 18, 2012
  7. rumpltumpskin

    rumpltumpskin Member

    Messages:
    36
    Likes Received:
    0
    GPU:
    SAPPHIRE Radeon HD 7870 G
    do you mean uninstall ccc and just use the driver? either way i got trixx and put the "board power li" to +3 and it didn't help at all. i was only able to play max payne 3 for about an hour before i got a black screen. thanks for trying to help though.
     
  8. Frequency

    Frequency New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    Powercolor 7970
    Try out the leaked 9.1.0.0 September 4 driver in the Drivers forum. Very promising so far.
     
  9. rievhardt

    rievhardt Member Guru

    Messages:
    107
    Likes Received:
    0
    GPU:
    Sapphire 7870
    Thanks for sharing your experience with your 7870.

    share your updated experiences regarding the 7870 and BF3 errors.
    (I'd update this in case the Black Screen issue shows up on me again...or if something happens)
    7870 issue on AMD thread
    http://forums.amd.com/game/messageview.cfm?catid=454&threadid=160398&STARTPAGE=1&FTVAR_FORUMVIEWTMP=Linear

    please include other details of what you have tried so far, so we can see any options we might missed. Maybe there's something similar in our builds that are causing the issue.

    1) what are your specs?

    i5-2400
    ASUS H61 M LE USB3
    FSP AURUM 600W 80+ Gold
    Sapphire 7870 non-OC ed
    Corsair Vengeance LP 2X4GB (8GB)
    WD BLUE 500GB

    Windows 7 Home Premium FPP 64bit
    NZXT Vulcan

    2) did you OC anything?
    NO

    (if you did...) does it also appear on stock clocks?

    not OC'ed. I'm on stock settings.

    3) what 7870 drivers are you using?
    -I'm using 12.7 Beta (downloaded from Sapphire, I downloaded from AMD before)

    How did you install all the AMD Catalyst...did you install all of them or only the drivers?
    -I installed all except the Accelerated Video Transcoding
    (I noticed that the 12.7 beta had the option for it not to be installed while 12.8 does not have that option)

    from which site did you download the Drivers? (I want to see if drivers from the brand would have an effect)
    -I downloaded my driver from AMD site.
    -I'm now trying 12.7 Beta from Sapphire site.

    and what 7870 drivers have you tried?

    -12.3 to 12.8
    -I haven't tried unofficial drivers and wouldn't...

    4) have you updated the drivers?
    -yes

    BIOS version?
    -I updated my mobo BIOS to ASUS 4204 (was 4203 before)

    Chipset driver?
    -I updated my Chipset driver (downloaded from ASUS this is my chipset driver Intel_Chipset_V9301019_XPVistaWin7)

    Soundcard driver?
    -I updated my realtek Driver (driver version 6.0.1.6526)

    Game driver? (what games do you experience this issue?)

    -all are up to date. BF3 (in Multiplayer only)

    any other drivers you've updated? (pls. indicate)
    -all from Windows Update (except the optional updates)

    5) how did you connect your 7870? Dual 6pin from a single atx cable or a separated 6pin atx cable?
    -I'm now using a separated 6pin atx cable, I was using Dual 6pin from a single atx cable before.

    6) what is your AVG and MAX VRM TEMP?
    -I've seen my VRM Temp 60C in AVG and it goes 225C MAX (GPUZ detects that it's spiking...not sure if that's normal)


    ---------------TEMPLATE---------------

    common questions:

    1) what are your specs?

    2) did you OC anything?

    (if you did...) does it also appear on stock clocks?

    3) what 7870 drivers are you using?

    How did you install all the AMD Catalyst...did you install all of them or only the drivers?

    From which site did you download the Drivers? (I want to see if drivers from the brand would have an effect)

    and what 7870 drivers have you tried?

    4) have you updated the drivers? (pls indicate version if possible)

    BIOS version?

    Chipset driver?

    soundcard driver?

    game driver?

    any other drivers you've updated? (pls. indicate)

    (because those aren't updated automatically by windows update)

    5) how did you connect your 7870? Dual 6pin from a single atx cable or a separated 6pin atx cable?

    6) what is your AVG and MAX VRM TEMP?
     
  10. terryble

    terryble Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    ASUS GTX 670
    updated my thread~~

    UPDATE: From the Gaming tab of CCC, i also tune the " anti aliasing mode" to Performance & "Vertical Refresh" to a tab nearer to Performance, im not sure if this helps in resolving the problem, (while leaving AMD optimized and surface format optimization on) perhaps u all can also try make the same changes
     

  11. yuni1988

    yuni1988 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    Sapphire Radeon HD 7870
    I have a display without integrated speakers, so I just disabled sound drivers that came with CCC. I left the other sound driver on. I've been playing for more than 2 hours now and it hasn't turned black yet.

    Thanks for ideas, this thread helped a lot.:cheers:
     
  12. Pashka_ch1981

    Pashka_ch1981 Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    Sapphire 7870 GE
    Yesterday got this card. Installed catalist 9.1.0.0 beta jnly driver and app (openCL), nothing more. Played for 10-15 some games (Max Payne 3, Borderlands 2, Prototype 2, I am alive), and 3 hours World of tanks. No black screens, no artifacts, everything is just great so far.
     
  13. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,527
    Likes Received:
    2,930
    GPU:
    MSI 6800 "Vanilla"
    Yeah that 9.0.1 driver seems to work really well for me too. :)
     
  14. rumpltumpskin

    rumpltumpskin Member

    Messages:
    36
    Likes Received:
    0
    GPU:
    SAPPHIRE Radeon HD 7870 G
    i called sapphire yesterday and they knew exactly what i meant when i told them i was getting the black screen problem. they assured me that it is not a hardware problem and recommended the 9.001 driver which i think is what you are talking about. lets see if it works.
     
  15. Pill Monster

    Pill Monster Banned

    Messages:
    25,214
    Likes Received:
    9
    GPU:
    7950 Vapor-X 1100/1500
    That's weird because there's a thread on Sapphire forums about black screens with over 2500 views and they've said nothing....

    I doubt they even know what the prob is hardware or software.
     

  16. Frequency

    Frequency New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    Powercolor 7970
    9.1.0.0 (Sep 4) is not perfect but it does stop the issue in many games. Here's hoping Catalyst 12.9 Beta releasing on 27th will be worth the wait.
     
  17. rumpltumpskin

    rumpltumpskin Member

    Messages:
    36
    Likes Received:
    0
    GPU:
    SAPPHIRE Radeon HD 7870 G
    you may be right but either way i'm not surprised that they are more candid on the phone than they are on a forum. i called 909-594-2830 and hardly had to wait on hold at all. i doubt they are open on the weekends but, come monday, you all should give them a call if you are still having problems. i can guarantee that you will get an answer quicker than you would by posting on their forum.
     
  18. Genesis

    Genesis Active Member

    Messages:
    73
    Likes Received:
    0
    GPU:
    GTX 660 Ti
    Just crashed with the leaked drivers(9.001), with the usual components: blackscreen, fan 100%, sound loop.

    Unfortunately they don't fix anything.
     
  19. Pashka_ch1981

    Pashka_ch1981 Member

    Messages:
    21
    Likes Received:
    0
    GPU:
    Sapphire 7870 GE
    Three days playing different games, running tests (3dmark06, Heawen). No black screens, crashes or BSODs. Driver 9.0.0.1.
     
  20. elite69

    elite69 Master Guru

    Messages:
    581
    Likes Received:
    29
    GPU:
    EVGA GTX 1060 6GB
    so i have a problem too but my lcd doesnt go down on all games have freeze problems you can play but its always with micro freeze and sometimes the lcd doesnt loose signal but stays dark black and can stil hear the sound of things like nfs can stil the car engine but no picture stupid bug
     
Thread Status:
Not open for further replies.

Share This Page