Sapphire 5770 losing signal

Discussion in 'Videocards - AMD Radeon' started by adebimpe, Nov 27, 2010.

  1. adebimpe

    adebimpe New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    Sapphire HD 5770 1Gb
    I built this rig two days ago:

    Motherboard: Asrock 870 Extreme3
    CPU: AMD Phenom II X2 560 Black Edition Callisto 3.3GHz (With 2 extra cores unlocked)
    Memory: A-DATA Gaming Series 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800)
    OS: Windows 7 Ultimate
    HDD: WD Caviar Black 640GB 7200 RPM 64MB Cache SATA 6.0Gb/s 3.5"
    Graphics: Sapphire 100283-3L Radeon HD 5770 1GB 128-bit GDDR5 PCI Express 2.0 x16
    PSU: Antec Earthwatts 650W
    Monitor: ASUS VH236H Black 23" 2ms(GTG) HDMI Widescreen Full HD 1080P


    I set it up and got it running with no issues, installed all of the drivers that windows update could find, then got the newest CCC from AMD. Here's where the issues started:

    I tried using AutoTune on AMD Overdrive to overclock the graphics. As soon as I clicked it it went to a screen with vertical green and red lines, stayed there for a few minutes, then I got the message no signal from the monitor. Everything in the computer was still running, including the graphics, just no signal. I rebooted.

    Somewhere along the way I also oc'd the CPU using an auto function on the Asrock BIOS. I immediately set it back to default though.

    I gave up on overclocking and tried to play BFBC2. It did the same no signal issue anywhere from 5 to 30 seconds into the opening cinematic. The audio would keep going for 10 seconds after the video went, then it would make weird noises and cut out.

    When I play less graphics heavy games (Guild Wars) it can last around 30 minutes before losing signal.

    I tried 3DMark06 a few times. The first few it got to the firefly forest, where it lost signal. When I lowered the resolution it got to the fourth graphics test, but didn't finish it.

    Of course I suspected overheating, but using Speedfan and the CCC temperature monitor, I found it to be cutting out at no higher that 56 C, with the CPU at 52 C.

    I tried all both ports on the card, DVI and HDMI.

    I've tried pretty much everything I can think of. I reinstalled the drivers, using the ones from the disk instead. I pulled out the card and put it in a different slot. The weird thing is, an almost identical problem was the reason I gave up on my old machine (which I didn't build).

    If anyone can help me, even if you just tell me to RMA it, that would be awesome. Thanks.
     
  2. Sever

    Sever Ancient Guru

    Messages:
    4,826
    Likes Received:
    0
    GPU:
    Galaxy 3GB 660TI
    how long are the hdmi/dvi cables? iirc, hdmi cables over 5m generally dont work well without a hdmi booster/amp.
     
  3. rflair

    rflair Don Commisso Staff Member

    Messages:
    4,184
    Likes Received:
    520
    GPU:
    5700XT
    Is this your first system build?

    You have mentioned unlocking cores, using auto-overclock, (worst thing you could do, if you don't know how to overclock properly don't rely on auto-overclock) but did you make sure the PC was stable at 100% stock settings by torture testing the hardware?

    Even at stock settings system builds should be fully tested, you shouldn't just assume its all good.
     
  4. Detection

    Detection Banned

    Messages:
    1,055
    Likes Received:
    0
    GPU:
    2 x 6850 - CrossFireX
    Also updating your BIOS to ensure it fully supports your CPU and can handle the 5770

    The Sapphire 5770 OCs well, but considering you are running a CPU designed to be DualCore unlocked to a QuadCore, I would say it is the CPU causing you problems

    They are locked at 2 Cores for a reason



    Is there a way to lock cores again ? Disable them for testing purposes ?
     
    Last edited: Nov 28, 2010

  5. The Chubu

    The Chubu Ancient Guru

    Messages:
    2,540
    Likes Received:
    0
    GPU:
    MSi GTX560 TwinFrozrII OC
    Could be all the "auto tunning" that you have done, the unlocked cores or the GPU.

    Dont. auto tune. anything. ever. again.
     

Share This Page