1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ryzen Master changed CPU frequencies permanently

Discussion in 'Processors and motherboards AMD' started by DigDeep, Jun 21, 2019.

  1. DigDeep

    DigDeep Member

    Messages:
    35
    Likes Received:
    5
    GPU:
    XFX RX580 GTS Black
    Ryzen Master wont and cant apply default settings to my CPU. When I set it to AUTO CPU stays at 3700mhz and doesnt go to default settings.

    I applied older AGESA code, thinking it will maybe fix the problem, but it didnt, I cleared CMOS, loaded optimal defaults in BIOS, changed Power plans in windows, but nothing helped.

    This guy has the same problem and he also cant fix the issue. He even reinstalled Windows but nothing changed.

    https://community.amd.com/thread/226086

    If anyone knows how would I flash or change Ryzen CPU firmware or default settings that would be good. I think only that can help or to RMA CPU.
     
  2. Kool64

    Kool64 Master Guru

    Messages:
    209
    Likes Received:
    76
    GPU:
    Gigabyte GTX 1070
    What CPU do you have?
     
  3. FatBoyNL

    FatBoyNL Ancient Guru

    Messages:
    1,534
    Likes Received:
    23
    GPU:
    MSI 2070 Gaming Z
    And what mobo? I'd suggest to start there instead of suspecting cpu.
     
  4. Clouseau

    Clouseau Ancient Guru

    Messages:
    2,295
    Likes Received:
    202
    GPU:
    ASUS STRIX GTX 1080
    Also, bios settings will not effect Ryzen Master. The software was created to override bios settings. In addition to what has been asked above, what version of the software is being used?
     

  5. The Reeferman

    The Reeferman Active Member

    Messages:
    92
    Likes Received:
    26
    GPU:
    GTX 970 @ 1400 MHz
    This is what his forum profile says:
    CPU : AMD Ryzen 2600
    Mobo : Gigabyte B450M-DS3H
    OS : Windows 10
     
  6. DigDeep

    DigDeep Member

    Messages:
    35
    Likes Received:
    5
    GPU:
    XFX RX580 GTS Black
    CPU : AMD Ryzen 2600
    Mobo : Gigabyte B450M-DS3H
    OS : Windows 10


    Yep. Those are my specs. Im using final version of RM.

    When I click on AUTO nothing happens, but when I click on Manual and click Apply, profile changes, dont know why Auto setting wont apply. I updated chipset drivers while I was using RM, could that be the reason?

    I think RM changes clock directly on the CPU, because BIOS changes dont resolve the issue, even if Ryzen Master is uninstalled.
     
    Last edited: Jun 22, 2019
  7. Kool64

    Kool64 Master Guru

    Messages:
    209
    Likes Received:
    76
    GPU:
    Gigabyte GTX 1070
    Doesn’t the 2600 have a nice PBO and XFR so you’d likely never see the stock 3.4 frequency unless you use a garbage cooler.
     
  8. Clouseau

    Clouseau Ancient Guru

    Messages:
    2,295
    Likes Received:
    202
    GPU:
    ASUS STRIX GTX 1080
    Given that RM overrides bios settings, would think the best bios settings to insure proper functionality would be auto. Would not pay to much attention to what is listed in profile. Would hold more stock in what monitoring programs like HWiNFO64, and Aida64 shows.
     
  9. Caesar

    Caesar Master Guru

    Messages:
    564
    Likes Received:
    191
    GPU:
    GTX 1070Ti Titanium
  10. DigDeep

    DigDeep Member

    Messages:
    35
    Likes Received:
    5
    GPU:
    XFX RX580 GTS Black
    I have settings in Bios on Auto. But even with RM uninstalled, my cpu frequency is 3700mhz. Auto setting in RM wont apply, manual somehow works, have no idea why.
     

  11. DigDeep

    DigDeep Member

    Messages:
    35
    Likes Received:
    5
    GPU:
    XFX RX580 GTS Black
  12. DigDeep

    DigDeep Member

    Messages:
    35
    Likes Received:
    5
    GPU:
    XFX RX580 GTS Black
    Ryzen Master changed default cpu frequency directly on cpu and now I cant revert it .
     
  13. Caesar

    Caesar Master Guru

    Messages:
    564
    Likes Received:
    191
    GPU:
    GTX 1070Ti Titanium
    SO REINSTALL IT (Ryzen MAster) and revert back to factory or "use default settings". Then restart.

    Into BIOS set your machine to EOCP (Extended Over Clock Profiles) -Gigabytes version mode- this will automatically detect your RAM speed and timings so just select the default speed and timings listed for your RAM which should now be available. Make sure you set your RAM voltage to the approved spec of your RAM don't leave it on AUTO. Next : set a negative offset on your Vcore because on AUTO it usually sets the voltage much higher than it needs to be.( a negative offset of .100V is safe)
    ____________________________
    D.O.C.P vs E.O.C.P:
    • DOCP (Direct Over Clock Profile), is from Asus for AMD mobos and came as the mobo makers didn't want to pay royalties to Intel to implement XMP on AMD mobos, it effectively uses the DRAM XMP profile to set up data rates and comparative timings on the AMD mobos for a variety of data rates.
    • EOCP (Extended Over Clock Profiles) is Gigabytes version of the Asus DOCP.
     
    Last edited: Jun 22, 2019
  14. DigDeep

    DigDeep Member

    Messages:
    35
    Likes Received:
    5
    GPU:
    XFX RX580 GTS Black
    I reinstalled Ryzen Master and applied default settings but they dont apply. I dont have EOCP and I loaded optimized defaults. I disabled CPB in bios and frequency is now 3400mhz, which is default, but problem is it stays like that all the time, even in idle. Are there any settings apart from Power option plans in Windows where I can lower CPU minimum frequencies?
     
  15. The Reeferman

    The Reeferman Active Member

    Messages:
    92
    Likes Received:
    26
    GPU:
    GTX 970 @ 1400 MHz
    So even if you edit the advanced options in the active Windows power plan and set the minimum CPU status to 5% and maximum to 50% it still is locked at 3400 MHz?
    Try running Windows in safe mode, that should disable all changes made by any software like drivers or registry settings. And check the clocks there. If they are normal it is a software problem, if they are still locked it is a hardware(or bios) problem.
     

  16. DigDeep

    DigDeep Member

    Messages:
    35
    Likes Received:
    5
    GPU:
    XFX RX580 GTS Black
    Yes, if cpb is disabled it is always at 3400mhz, if it is enabled it is at 3700mhz and sometimes goes to 2600mhz. It is the same even in the safe mode.
     
  17. LocoDiceGR

    LocoDiceGR Ancient Guru

    Messages:
    1,852
    Likes Received:
    464
    GPU:
    Gigabyte R9 380 4G
    Nice clickbait title, i think like im on youtube right now.
     
    Geryboy, fantaskarsef and Fox2232 like this.
  18. fantaskarsef

    fantaskarsef Ancient Guru

    Messages:
    10,484
    Likes Received:
    2,715
    GPU:
    1080Ti @h2o
    Uses OC software and complains about the CPU being OCed.

    Uninstall the software, reset BIOS settings and flash older BIOS / AGESA. If it still applies it can ONLY be a false read, since the CPU itself does not save anything. Not sure what else there is to do.
     
    LocoDiceGR and Geryboy like this.
  19. FatBoyNL

    FatBoyNL Ancient Guru

    Messages:
    1,534
    Likes Received:
    23
    GPU:
    MSI 2070 Gaming Z
    OP, did it ever work properly?
    If not, I'd suggest to try to re-seat the CPU in the socket.
     
  20. sykozis

    sykozis Ancient Guru

    Messages:
    20,880
    Likes Received:
    563
    GPU:
    MSI GTX1660Ti
    This is not possible.....
     

Share This Page