1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ryzen 7 2700x no display on boot

Discussion in 'Processors and motherboards AMD' started by tr00p86, May 26, 2018.

  1. tr00p86

    tr00p86 New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    GTX 780
    Hi everyone,



    I need some help... here's my new build specs:



    Ryzen 7 2700x with Wrath Prism Cooler

    ASUS Prime x470-Pro

    Corsair Vengeance LPX CMK16GX4M2B3200C16 2x8gb 3200mhz DDR4 ram (NOT ON ASUS QVL)

    G-Skill F4-3200C16D-16GTZR 2x8gb 3200mhz DDR4 ram (ON ASUS QVL)

    EVGA Supernova G2 650w

    Nvidia GTX 780 3gb



    At first, I ordered the Corsair RAM without looking at the QVL (my bad!) ... I contacted Asus Tech Support who told me to stick with QVL'd RAM. I then got the G-Skill kit that is on the list.



    I don't have any picture on boot in both cases. Here is what I tried:



    • Removed the GPU right away and tried to work with the motherboard onboard GPU instead
    • Tried to connect from 4 different monitors with 2 different HDMI cables, including a cable that does 4K on my PS4 pro. 3 PC monitors + My 58" Samsung 4K TV ... The port takes HDMI 1.4b (tried HDMI 1.4 and 2.0 ports)
    • Tried to remove the CMOS + reset the jumper by putting a screwdriver between the pins located under the SATA ports
    • Tried with my GPU, with HDMI and both DVI ports
    • With both RAM sets, I tried including RAM one by one on the motherboard, from the B2 and A2 ports only


    I can't make it work.



    Everything is properly plugged in:



    -Both PSU cables for the motherboard (8-pin + 24-pin, or is it 20?)

    -All fans connected (front, CPU, back)

    -2 SSD + 1 hybrid connected to PSU + SATA ports

    -All front panel cables properly connected



    Everything looks beautiful, the LEDs on the motherboard + CPU fan and RAM light up with multi-colors... all the fans turn fine including PSU...

    The keyboard lights up too... but nothing on screen!



    Where's what I am wondering about...



    • It is possible my motherboard is DOA? - It does have all the pretty lights working though and everything plugged on it is powered
    • Is there a compatibility issue somehow between my CPU and motherboard? - I thought X470 is supposed to support Ryzen 2nd gen out-of-the-box
    • Does first BIOS setup only work from the DisplayPort? I haven't tested it because I don't have a cable. - I really doubt this though...


    Any help would be greatly appreciated!!
     
  2. Belsarion

    Belsarion New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    EVGA gtx1070 ftw 8g
    Hi i have the same motherboard and processor.. When i booted up i had no screen but fans were on.. After some guessing, i found that the CPU fan has to be plugged into the CPU fan Slot on the top of the motherboard in a tower case, NOT the one next to the CPU, The Connection at the top of the board has two connections, It is the one on top...Labelled CPU FAN on the board and in the manual.. I hope this helps
     
  3. Killian38

    Killian38 Master Guru

    Messages:
    215
    Likes Received:
    48
    GPU:
    1060
    I know this sounds dumb but I have to ask. With the GPU installed do you have your monitor plugged in to the GPU itself? A 2700x and that board does not have onboard graphics.

    You can only use the outputs I/O of the motherboard if you have an APU installed, like the 2400G APU.

    You must use a dedicated GPU and hook your monitor to that GPU. If you still have no signal. Try 1 stick of ram at a time in every ram slot. With just a keyboard and mouse hooked up to the rear I/O panel. I'd even disconnect the case wiring going to the front panel to rule out some kinda short.

    I'm guessing it's your GPU or motherboard that is the problem.
     
    Last edited: May 26, 2018
  4. Hilbert Hagedoorn

    Hilbert Hagedoorn Don Vito Corleone Staff Member

    Messages:
    33,462
    Likes Received:
    2,399
    GPU:
    AMD | NVIDIA

    Reseat the processor, clear CMOS, make sure you connected your cables properly. Also, make sure that that the DIMMs used occupy slot 1 and 3. E.g. the closest one seen from that wide ATX motherboard power connector and the third one.

    Considering the 2700X does not have an integrated GPU, you are certainly not going to get any signal on the motherboard display connectors. Ergo, always use your dedicated graphics card.
     

  5. Fox2232

    Fox2232 Ancient Guru

    Messages:
    7,528
    Likes Received:
    874
    GPU:
    -NDA +AW@240Hz
    There are still basics which have been omitted. While board does not have BOOT time diagnostic LED, there is Speaker for this purpose and its sound codes.
     
    bernek likes this.
  6. dicen

    dicen New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    eVGA 780 GTX 3GB
    First off I replied to your post at the AMD forums. However, not only did AMD delete my post. They also deleted my account for posting it. I registered to be nice as I have had the exact same issue. I just wasted my 3 day weekend on this.

    What is the issue? Well, your PC is booting just fine except the 2700x is not recognizing your 780 GTX display card. I upgraded from a 1700x to a 2700x and my PC booted right into Windows 10. The problem was that there was no display. I could login remotely just fine. Now this compatibility issue with Nvidia GTX 780s is not new. eVGA released new GPU BIOS versions to fix it with previous CPU/motherboard upgrades (which may or may not have been AMD). So I put my old computer (an Intel 860) back together and flashed the latest GPU BIOS to my 780. Didn't fix it. Note that my old Nvidia GTX 260 works fine with the 2700x. I have an ASUS x370-pro motherboard with the latest 4011 motherboard BIOS version.

    So what to do? I can't guarantee that this 2700x will work with new GPUs and I don't want to upgrade that yet so it's going back. I know that eVGA/Nvidia isn't going to change the old 780 GTX. I must point out that this entire Ryzen experience with the BIOS/memory issues, the segfault issue and now this. Well it sucks. I don't think this is a CPU hardware failure. I think that this is yet another AMD design/manufacturing flaw that they don't want out on the Internet. The segfault issue was never fixed by the way. The chips were just binned better. Maybe they will fix this with a new motherboard BIOS? How many of those have we got now? I count 21 ASUS x370-pro motherboard BIOS versions since 2017/02/24. 21! That is completely crazy. Do they have a QA department? Yep, it's us. We are the AMD QA department.
     
  7. Schepsel

    Schepsel Member Guru

    Messages:
    129
    Likes Received:
    0
    GPU:
    Radeon RX VEGA 64
    I just upgraded and encountered the same issue.
    Used a display-port cable instead of HDMI.. worked for me..
     
  8. basco

    basco Member Guru

    Messages:
    120
    Likes Received:
    0
    GPU:
    560tfII
    i cant find info on this but are there boot leds(lights) on the mainboard that tell ya where its stuck like on a lot of asus mobos?
    i dont mean the boot code led that gives ya a number-just lights

    or is it the same that fox2232 said
     
  9. ManuelG

    ManuelG NVIDIA Rep

    Messages:
    580
    Likes Received:
    29
    GPU:
    Geforce RTX 2080 FE
    Can someone with this issue share the VBIOS version of your GeForce GTX 780 please? Thank you.
     
  10. TheLazyGrizzly

    TheLazyGrizzly New Member

    Messages:
    1
    Likes Received:
    0
    GPU:
    GTX 780 3 GB
    I'm still dealing with this problem tho i haven't tried flashing any new bios on the GPU yet.
    Bios Version: 80.10.37.0.5
     

Share This Page