Rx Vega 56 Black Screen and Radeon Settings crashing??

Discussion in 'Videocards - AMD Radeon' started by ElistonCole, Sep 12, 2020.

  1. ElistonCole

    ElistonCole New Member

    Messages:
    3
    Likes Received:
    1
    GPU:
    AMD
    Hey Guys. Need some help here...weird thing started happening to me.

    I had the 19.12.1 driver and it was all okay, then i decided to install the 20.02.2 cause i had recommendations.
    So i did install it and that driver gave me some problems, like games crashing, etc.

    But the one that is the worst is: Random black screens while i'm only using the pc. Like surfing on the internet, watching twitch streams and even using the windows explorer to search for files. Then after like 10 seconds the screen wakes up again and then Windows shows me the message "Default Radeon WattMan settings has been restored due to unexpected system failure."

    Ok, so i decided lets go back to 19.12.1 where i didnt have this error.
    So i used AMD CleanUp and DDU and installed 19.12.1 again.

    But now i am still having this error. Which i didnt have before on 19.12.1
    My GPU is vega 56 sapphire nitro+
    Does anyone know anything about this? It's so annoying
     
  2. Undying

    Undying Ancient Guru

    Messages:
    13,911
    Likes Received:
    3,147
    GPU:
    Aorus RX580 XTR 8GB
    DanielRX likes this.
  3. GlennB

    GlennB Master Guru

    Messages:
    245
    Likes Received:
    77
    GPU:
    Sapphire Vega 56 EK
    What kind of PSU are you using ?
     
  4. DanielRX

    DanielRX Member

    Messages:
    17
    Likes Received:
    4
    GPU:
    RX Vega56/GTX1070
    latest 20.8.3 working fine for almost 2 weeks, no erros! RX VEGA56, RX580 and my RX480.
     

  5. Chastity

    Chastity Ancient Guru

    Messages:
    2,563
    Likes Received:
    826
    GPU:
    Nitro 5700 XT
    Download the AMD Cleanup Utility to uninstall your driver, reboot and install again.
     
  6. Undying

    Undying Ancient Guru

    Messages:
    13,911
    Likes Received:
    3,147
    GPU:
    Aorus RX580 XTR 8GB
    Make sure there is no internet connection while installing new drivers so ms dont force their own via update.
     
    Exodite likes this.
  7. ultraex2003

    ultraex2003 Member Guru

    Messages:
    161
    Likes Received:
    31
    GPU:
    Amd 2x290 Cfx
    bro !!! my GPU is vega 56 sapphire with latest 20.8.3 working fine so far!!:)
     
  8. ElistonCole

    ElistonCole New Member

    Messages:
    3
    Likes Received:
    1
    GPU:
    AMD
    thank you my issue has been solved
     
    Undying likes this.

Share This Page