Rundll NvCpl.dll exception at startup

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by SlCKB0Y_BE, Apr 19, 2021.

  1. SlCKB0Y_BE

    SlCKB0Y_BE Member

    Messages:
    34
    Likes Received:
    4
    GPU:
    5700XT
    hi everyone,

    as you've perhaps seen on the intel thread i've built a retro computer running windows xp, but i've got a couple issues :

    my first issue, i've got a couple error messages at startup :

    - Rundll exception trying to run "c:\windows\system32\NvCpl.dll,NvStartup"
    - Rundll exception trying to tun "NVCPL.DLL,NvCplManageUserSettings 3"

    (screenshot : https://i.imgur.com/6GEEDd8.jpg )

    also get another error when i try to click the nvidia icon in the task bar, but it does open by right clicking on the desktop tho.

    tried countless clean reinstall, registry cleaning using ccleaner and glary utilities, nothing worked so far.


    my second issue, i've got a pair of gtx 960 in the computer, both are recognized in the device manager, same bios, make and model.

    but i can't activate SLI under windows XP, tho it work absolutly fine on the windows 10 dual boot.


    i kinda think both issues might be related as apparently the error message i get can prevent the nvidia control pannel from loading some modules.


    does anybody have experienced this issue and found a way to solve it ?

    thanks a lot in advance for any help you can give me guys :)
     
  2. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,301
    Likes Received:
    3,700
    GPU:
    GTX 1080ti
    sp3 installed?
     
  3. SlCKB0Y_BE

    SlCKB0Y_BE Member

    Messages:
    34
    Likes Received:
    4
    GPU:
    5700XT
    yup was installed from an XP SP3 iso right from the get go.
    fully updated from the microsoft update severs,
    lastest chipset drivers installed,
    .net framework 3.5 and 4 installed,
    every C++ redist installed
    even installed the lastest visual basics runtimes just in case.

    using Nvidia drivers version 368.81 (lastest xp compatible) downloaded from the nvidia website itself.
     
  4. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,301
    Likes Received:
    3,700
    GPU:
    GTX 1080ti
    There was a period of time where the tray icon was partially broken unless GFE was installed, delete the autorun tasks for the nvcpl using sysinternal autoruns
     

  5. SlCKB0Y_BE

    SlCKB0Y_BE Member

    Messages:
    34
    Likes Received:
    4
    GPU:
    5700XT
    unfortunatly just removing the autorun task doesn't solve my problem, as apparently i need them to run to activate SLI.

    might give a try to installed GFE tho as i never do it on average.
     
  6. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,301
    Likes Received:
    3,700
    GPU:
    GTX 1080ti
    they are irrelevant to the enablement of SLI, which is most likely actually a driver regression in the 368 drivers.

    try 365, 355 or 352.
     

Share This Page