RTX 30 series drivers and prefer max performance

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by Chrysalis, Mar 9, 2021.

  1. Chrysalis

    Chrysalis Master Guru

    Messages:
    217
    Likes Received:
    23
    GPU:
    RTX 3080 FE
    Seems this isnt working properly for me, unless its changed by design.

    So expected behaviour based on all my old nvidia gpu's, is that when this option is selected the gpu clock speed will never fall below base 3d speed (typically somewhere in the mid to high 1000mhz range.), the benefit of this option is for older games where the gpu is overpowered so it falls down to 2d clocks, but then this causes stutters as 2d clocks wont be enough to run game smoothly, so typically in these games the gpu can have a problem of looping between 2d and 3d clocks, which "prefer max performance" fixes.

    I noticed when playing fable anniversary if I use optimal performance its not that bad but it isnt perfect, e.g. game stutters when exiting menus as it has to get out of idle clocks, so I tried prefer maximum performance, and its going down to 2d clocks, and not only going down it seems to do it a lot, the game was a stutter fest. I think its a bug, as I have owned many previous gen cards and they never had this behaviour.

    But curious if anyone else has noticed this, note its probably not going to be an issue in modern games which load up the gpu, also if people are not capping framerate.
     
  2. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,268
    Likes Received:
    3,686
    GPU:
    GTX 1080ti
    what clocks are you considering "2D"

    anything >1350 is 3D clocks.
     
  3. Chrysalis

    Chrysalis Master Guru

    Messages:
    217
    Likes Received:
    23
    GPU:
    RTX 3080 FE
    210mhz. Also 420mhz and 600 (and something didnt note the exact speed).

    In optimal power it stays in the circa 600, which is just about enough for the game to work ok, but drops to 200 in the menus, so when exiting menus before it ramps up I get stutter.

    Surprisingly on the prefer max performance, it keeps going down to 210mhz all the time, so every 2-3 secs it goes down to 210, stutters, then smooth again as it ramps back up to 3d clocks, then down again. The speed it goes up to is 1710mhz but isnt staying there.

    On my 1080ti, it settled in the base 3d clocks which I think for that card is around 1500mhz, it will go higher of course if the game is demanding, but in old games it just stays on the base 3d clock.

    I can probably do a short recording on obss with osd on.
     
  4. Dan Longman

    Dan Longman Member Guru

    Messages:
    147
    Likes Received:
    88
    GPU:
    STRIX 3080
    Since I got my 3080 I have no longer had optimal power just normal and max performance.

    [​IMG]

    I have found that normal doesn't boost as well as the old optimal did - For example in P5 strikers it was running around 900mhz and would stutter - setting to max performance resolved the issue.

    But I see it running around 85% utilization and not stepping clocks up in Normal mode in lower demanding games.

    Prefer max performance works as expected in all games I have used it in - never drops to "2d" clocks with 1350 most of the time much higher than that.

    But I am not sure how you see Optimal Power still, everyone else I have talked to with a 30 series only sees normal and max perf.
     
    Last edited: Mar 9, 2021

  5. Chrysalis

    Chrysalis Master Guru

    Messages:
    217
    Likes Received:
    23
    GPU:
    RTX 3080 FE
    Dan that is odd I just checked and my 3080 I see this. Which driver version are you on?

    I am on 457.30.
     

    Attached Files:

  6. Dan Longman

    Dan Longman Member Guru

    Messages:
    147
    Likes Received:
    88
    GPU:
    STRIX 3080
    Ahh I think that is the issue I am on latest 461.81
    - I always update to latest driver, I got my card in dec so I think I have been on 460 or newer since I have had this card, I am guessing they made that change after the 457.30 driver I wonder if you update if you will lose the optimal power setting.
     
  7. Chrysalis

    Chrysalis Master Guru

    Messages:
    217
    Likes Received:
    23
    GPU:
    RTX 3080 FE
    I am uploading video clip now, and will do a second on optimal power. I did exaggerate the every 2-3 seconds but you will see does it 3 times in the clip down to 400 although I have seen it drop to 200 in other parts of the game.

    https://streamable.com/ljlp6w

    Also thanks, I think I will update the driver, it sounds like they made changes to fix it in that version.

    optimal power below, I tried to get it to stutter on menu but didnt work lol,, but can see plays much better.

    https://streamable.com/enc42u

    Also yes I will report back if my power options change as well as if prefer max works properly. Thanks for the information.

    Note the encoding I think wasnt entirely smooth so just use the FPS gauge on OSD as a measure of how smooth game is, trust me when I say its smooth outside of the downclock stutters.
     
    Last edited: Mar 9, 2021
  8. Witcher29

    Witcher29 Maha Guru

    Messages:
    1,378
    Likes Received:
    179
    GPU:
    3080 Gaming X Trio
    Dont forget to reboot your pc after applying prefer max performance, else it might glitch out or wont work.
    I am not touching that one again to scared to get another bsod :p i had one once but after that it was sorted lol.
     
  9. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,268
    Likes Received:
    3,686
    GPU:
    GTX 1080ti
    30 series doesn't use list Optimal as an option anymore, its Normal or Prefer Max, the driver you're on is actually using normal but hasn't had the setting added yet.

    turing and ampere cards get locked at base clock and may not go to boost clocks with S3 sleep if you set global to prefer max.
     
  10. kman

    kman Master Guru

    Messages:
    215
    Likes Received:
    14
    GPU:
    1080ti Strix
    What's S3 sleep?Hybrid sleep? [​IMG]
     

  11. kman

    kman Master Guru

    Messages:
    215
    Likes Received:
    14
    GPU:
    1080ti Strix
  12. Chrysalis

    Chrysalis Master Guru

    Messages:
    217
    Likes Received:
    23
    GPU:
    RTX 3080 FE
    So I updated to 461.81 drivers, I was so hopeful when I noticed I now only have normal and prefer max performance as options.

    But sadly it is still broken, and also is still the higher 1710mhz clock speed not the lower 1350 speed others report.

    The behaviour is exactly the same, just the options have changed.
     
  13. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,268
    Likes Received:
    3,686
    GPU:
    GTX 1080ti
    I suspect the right tool for this case would be nsight, but its a pain to set up
     
  14. Chrysalis

    Chrysalis Master Guru

    Messages:
    217
    Likes Received:
    23
    GPU:
    RTX 3080 FE
    I fixed it, operator error.

    I forgot to disable nvidia multi display power saver before launching game (I have it on to prevent web browsers using 3d clocks).

    Is interesting my base 3d clock is higher than others but it doesnt drop down now at all. I will keep the newer drivers on now.
     
    SaiBork and Astyanax like this.
  15. Chrysalis

    Chrysalis Master Guru

    Messages:
    217
    Likes Received:
    23
    GPU:
    RTX 3080 FE
    So 1710mhz is the boost speed (I have Founders Edition). So looks like a change from older Nvidia GPU's is that it now uses the boost clock instead of base 3d clock.

    I tested normal mode which seems much more responsive now in fable anniversary, unable to get lag exiting the menu at all.
     
    Last edited: Mar 10, 2021

  16. kman

    kman Master Guru

    Messages:
    215
    Likes Received:
    14
    GPU:
    1080ti Strix
    So you're using normal mode instead of maximum performance now?
     
  17. SaiBork

    SaiBork Master Guru

    Messages:
    236
    Likes Received:
    18
    GPU:
    GV-N108TAORUS X-11G
    :eek: I did not know about this bit of software in Inspector. This helps me so much as I have three monitors and was using way more power than needed.
     
  18. tsunami231

    tsunami231 Ancient Guru

    Messages:
    11,604
    Likes Received:
    816
    GPU:
    EVGA 1070Ti Black
    Is that new option? I dont remeber seeing option NVCP for long time is back? cause I use to disable that but been long since gone.

    I still using 457.30.

    Seeing as I use Max performance as defualt and set what need to be "adaptive" for the gpu to drop to idle clocks on desktop I curious so when I do update drivers I know how to fix
    I use Prefer Max Performance cause what you talk about old games drip to low clocks and stuttering.

    Is adaptive still a setting?


    *edit*

    you talking about Multi-Display/Mix Gpu accelerations? (inspector) that set to single, use to set long time ago in NVCP. I been habit use backing up my profiles and restoring them with Inspector every time I do drivers upgrade/downgrade. and this most likely why I never have to set that anymore

    And my goblal profile is
    Performance Management mode Prefer MAx Performance
    Vsync ON
    Triple Buffer ON
    All Texture filter Optimizing OFF
    Texture Filter Quality HIGH
     
    Last edited: Mar 10, 2021
  19. Chrysalis

    Chrysalis Master Guru

    Messages:
    217
    Likes Received:
    23
    GPU:
    RTX 3080 FE
    The multi display power saver thing is a on a old app that was designed to deal with issues of nvidia gpus not going to low power state on multi monitor setups, but I found it useful to keep gpu temps down whilst web browsing so have used it for a while, however it will mess up games if you dont turn it off before launching and I simply forgot to after I upgraded my GPU. I may actually now ditch it as my 3080 doesnt seem to have the same issue for web browsing as my older gpus had.

    In terms of the power options in nvidia control panel, yes they removed optimal power and adaptive options in new drivers, both of those are replaced with a single normal option.
     
  20. terror_adagio

    terror_adagio Member

    Messages:
    42
    Likes Received:
    13
    GPU:
    7950 GTX 512MB
    Prefer Max Performance has always never allowed my card to downclock after gaming. It stays stuck, which I don't think should still be happening, right?
     

Share This Page