1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RTX 2080 locked to base clock + Power limit slider locked in MSI Afterburner

Discussion in 'Videocards - NVIDIA GeForce' started by Andy Blondeel, Jan 25, 2019.

Tags:
  1. Andy Blondeel

    Andy Blondeel New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    RTX 2080 Gaming OC
    Description of Problem:

    After a reinstall of Windows 10, and subsequently the drivers my RTX 2080 does not exceed 1515 MHZ on Core Clock anymore. Before the reinstall, it would enable Boost and go +1900 MHZ. Also, in MSI Afterburner the Power Limit slider bar is greyed out

    Troubleshooting: I've uninstalled and reinstalled various version of the drivers using DDU, but i still have the same issues.


    Computer Type: Self Build Desktop

    GPU: Gigabyte RTX 2080 Gaming OC 8 GB(GV-N2080GAMING OC-8GC)

    CPU: Intel(R) Core(TM) i7-8700K CPU @ 3.70GHz, no overclock

    Motherboard: ASRock Z370 Extreme4, BIOS version P1.10

    RAM: Corsair Vengeance LPX CMK16GX4M2B3000C15, XMP profile enabled @ DDR4-3000

    PSU: Seasonic Focus Plus 850 Watt PSU output

    Operating System & Version:Windows 10 Pro x64, OS Version 10.0.17763.107 (Win10 RS5 [1809] October 2018 Update)

    GPU Drivers: 24.21.14.1163 - nVIDIA ForceWare 411.63
     
  2. insp1re2600

    insp1re2600 Master Guru

    Messages:
    570
    Likes Received:
    183
    GPU:
    RTX 2080TI OC
    Installed chipset drivers?
     
  3. sapo_joe

    sapo_joe Master Guru

    Messages:
    558
    Likes Received:
    8
    GPU:
    Gainward RTX 2080
    Remove your nvidia drivers with DDU in safe mode and install the latest ones, 417.75.
     
  4. Andy Blondeel

    Andy Blondeel New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    RTX 2080 Gaming OC
    I've tried that with all the other versions of the driver, what would be different with this version?
     

  5. Andy Blondeel

    Andy Blondeel New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    RTX 2080 Gaming OC
    Intel(R) Chipset Device Software 10.1.1.45 Unknown {7FB35D08-C75C-4A18-B593-1D7C3E8970AD} Intel Corporation 2019-01-10

    As taken from Aida64 software
     
  6. dcGColts

    dcGColts New Member

    Messages:
    4
    Likes Received:
    1
    GPU:
    Gigabyte 2080 GamOC
    Did you ever figure out the issue? I have same card since Sept and this issue just popped up for me after installing latest Nvidia driver.
     
  7. ngoni615

    ngoni615 Member

    Messages:
    22
    Likes Received:
    4
    GPU:
    GTX 1080ti 11gb
    Seems like an issue with the bios. if you have a dual bios card try to switch to the other one. If not reflash the bios and if not send it back
     
  8. anstaendig

    anstaendig New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    GeForce RTX 2080
    I have the same issue after updating to the latest 425.31 driver. The previous one worked fine (419.67)
     
  9. HeavyHemi

    HeavyHemi Ancient Guru

    Messages:
    6,118
    Likes Received:
    502
    GPU:
    GTX1080Ti
    Does it work if you go back to the previous driver? If not, it's probably coincidental to your GPU failing.
     
  10. anstaendig

    anstaendig New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    GeForce RTX 2080
    Reverting back to 419.27 did not solve my problem. So here's what I had to do to enable the turbo boost again:
    1. Backup VGA Bios
    2. Flash different VGA Bios
    3. Remove GPU
    4. Uninstall drivers with DDU in safe mode
    5. Install GPU
    6. Install latest drivers
    After a couple of hours hassling around with this, this finally works again and even without overclocking manually, my card boosts to 1920 MHz instead of being frozen at 1510Mhz and I can run the latest NVIDIA drivers.

    One thing to note is that I combined the step of removing the card and the BIOS flashing so flashing MIGHT not be necessary. I just thought it wouldn't hurt
     

Share This Page