RTSS "Start with Windows" toggle keeps turning itself OFF after reboot

Discussion in 'Rivatuner Statistics Server (RTSS) Forum' started by BlindBison, Mar 6, 2021.

  1. BlindBison

    BlindBison Master Guru

    Messages:
    961
    Likes Received:
    245
    GPU:
    RTX 2080 Super
    For some context I'm on the latest stable release of RTSS, but this was also happening for me on prior versions.

    When you open RTSS there is the "Start with Windows" switch under "General Properties". Note, this does not occur after every reboot, but maybe a third of time I'll boot up my PC and RTSS will NOT auto-startup despite having that switch flipped to ON.

    When this happens, I open RTSS manually then flip the switch to ON then minimize RTSS.

    From here, when I shut the PC down then boot it back up that's when the issue can occur. To get around this I've tried disabling windows fast boot, but that didn't help.

    Anyone else experience this or find a solution? Not sure why it's occurring -- perhaps I could manually send the RTSS exe into the startup folder, but in the past I've had issues with that approach working on exes that are set to run as administrator.

    Thanks for your help and time,
     
  2. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,736
    Likes Received:
    3,186
    That toggle is nothing but scheduled task state existence reflection. If it is toggled off, either the task is removed by something or access to the task scheduler service is not available and blocked by something during RTSS startup. In both cases it can be done by third party process ONLY.
     
    BlindBison likes this.
  3. BlindBison

    BlindBison Master Guru

    Messages:
    961
    Likes Received:
    245
    GPU:
    RTX 2080 Super
    Thank you very much, that's helpful! Hm, I wonder what could be causing it -- I do have a couple other startup processes (Logitech G-Hub for my Headset + Razer Synapse for my mouse).

    Apologies, I shouldn't have said the toggle keeps turning itself off since I should've considered that something else was switching it off. Thanks for your helpful reply! I'll comment again if I find out what's causing it or a work around.
     
  4. realghostvids

    realghostvids Member

    Messages:
    25
    Likes Received:
    2
    GPU:
    RTX 2070 SUPER 8GB
    I've been having the exact same issue since I started using the betas with the overlay editor in them. Now I'm on the latest stable release and I can't get it to run automatically at boot. This is just with RTSS installed, no Afterburner.

    In my case though, I can toggle the start with Windows setting to On and it'll turn itself off after a seemingly random amount of time – not just after I've rebooted.
     
    BlindBison likes this.

  5. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,736
    Likes Received:
    3,186
    There were NO changes in startup scheduling for YEARS. So no, it couldn't start when you started using betas. Not going to debate on it further, it is a waste of time.
     
  6. Joe Swanson

    Joe Swanson New Member

    Messages:
    1
    Likes Received:
    1
    GPU:
    3070 FE
    You find a reason for it not starting up yet? I'm having the exact same problems.
     
    BlindBison likes this.
  7. Astyanax

    Astyanax Ancient Guru

    Messages:
    12,464
    Likes Received:
    4,767
    GPU:
    GTX 1080ti
    it occasionally happens following an RTSS update, but not randomly.
     
    BlindBison likes this.
  8. BlindBison

    BlindBison Master Guru

    Messages:
    961
    Likes Received:
    245
    GPU:
    RTX 2080 Super
    I never found a solution unfortunately. In the end what I did was turn off the RTSS "start with windows" setting in the app and setup a custom login task to start up RTSS after a certain number of seconds has passed. That works reliably every time for me.
     
    GoldenTiger likes this.
  9. BlindBison

    BlindBison Master Guru

    Messages:
    961
    Likes Received:
    245
    GPU:
    RTX 2080 Super
    Yeah, I had noticed this, but updates don't occur very often and it still gets toggled off from time to time. It may be due to some windows shenanigans, unsure, but I've just opted to work around it with a delayed startup task.
     
    GoldenTiger likes this.
  10. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,736
    Likes Received:
    3,186
    Finally had a chance to reproduce that. Opening RTSS properties via "Setup" button then closing RTSS with "x" button does that and kills scheduled task. I'll fix that in the next beta.
     
    Maddness, BlindBison and Aserback like this.

  11. BlindBison

    BlindBison Master Guru

    Messages:
    961
    Likes Received:
    245
    GPU:
    RTX 2080 Super
    Thank you, that’s helpful -- awesome you managed to reproduce it mate.

    Thanks for your work, RTSS is one of the first programs I install on my PCs.
     
    Last edited: Jan 8, 2022
  12. TheDeeGee

    TheDeeGee Ancient Guru

    Messages:
    7,566
    Likes Received:
    1,690
    GPU:
    NVIDIA GTX 1070 8GB
    Yeah, deleting the registery keys fixes it in that case.

    Ofcourse you gotta redo some settings then.
     
  13. Astyanax

    Astyanax Ancient Guru

    Messages:
    12,464
    Likes Received:
    4,767
    GPU:
    GTX 1080ti
    no? just turn the auto start back on XD
     

Share This Page