RTSS "Start with Windows" toggle keeps turning itself OFF after reboot

Discussion in 'Rivatuner Statistics Server (RTSS) Forum' started by BlindBison, Mar 6, 2021.

  1. BlindBison

    BlindBison Master Guru

    Messages:
    570
    Likes Received:
    102
    GPU:
    RTX 2080 Super
    For some context I'm on the latest stable release of RTSS, but this was also happening for me on prior versions.

    When you open RTSS there is the "Start with Windows" switch under "General Properties". Note, this does not occur after every reboot, but maybe a third of time I'll boot up my PC and RTSS will NOT auto-startup despite having that switch flipped to ON.

    When this happens, I open RTSS manually then flip the switch to ON then minimize RTSS.

    From here, when I shut the PC down then boot it back up that's when the issue can occur. To get around this I've tried disabling windows fast boot, but that didn't help.

    Anyone else experience this or find a solution? Not sure why it's occurring -- perhaps I could manually send the RTSS exe into the startup folder, but in the past I've had issues with that approach working on exes that are set to run as administrator.

    Thanks for your help and time,
     
  2. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,304
    Likes Received:
    2,606
    That toggle is nothing but scheduled task state existence reflection. If it is toggled off, either the task is removed by something or access to the task scheduler service is not available and blocked by something during RTSS startup. In both cases it can be done by third party process ONLY.
     
    BlindBison likes this.
  3. BlindBison

    BlindBison Master Guru

    Messages:
    570
    Likes Received:
    102
    GPU:
    RTX 2080 Super
    Thank you very much, that's helpful! Hm, I wonder what could be causing it -- I do have a couple other startup processes (Logitech G-Hub for my Headset + Razer Synapse for my mouse).

    Apologies, I shouldn't have said the toggle keeps turning itself off since I should've considered that something else was switching it off. Thanks for your helpful reply! I'll comment again if I find out what's causing it or a work around.
     
  4. realghostvids

    realghostvids Member

    Messages:
    20
    Likes Received:
    0
    GPU:
    RTX 2070 SUPER 8GB
    I've been having the exact same issue since I started using the betas with the overlay editor in them. Now I'm on the latest stable release and I can't get it to run automatically at boot. This is just with RTSS installed, no Afterburner.

    In my case though, I can toggle the start with Windows setting to On and it'll turn itself off after a seemingly random amount of time – not just after I've rebooted.
     

  5. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,304
    Likes Received:
    2,606
    There were NO changes in startup scheduling for YEARS. So no, it couldn't start when you started using betas. Not going to debate on it further, it is a waste of time.
     

Share This Page