RTSS not working in Rising Storm 2: Vietnam

Discussion in 'Rivatuner Statistics Server (RTSS) Forum' started by jiminycricket, May 23, 2018.

  1. jiminycricket

    jiminycricket Master Guru

    Messages:
    203
    Likes Received:
    4
    GPU:
    GTX 1080
    I'm using MSI Afterburner 4.5.0 and RTSS 7.1.0 and I cannot get the OSD to appear in RS2. Also, the screenshots I take only capture a black image of the desktop. These functions work fine in my other games.

    Rising Storm 2 uses EasyAntiCheat, but I don't know if the anti-cheat is blocking anything as there are no error messages. I have tried contacting EAC about this, but they are extremely slow in responding.

    I have tried creating a profile for the game's executable (VNGame.exe) in RTSS and adjusting all the options, but I still cannot get the OSD to show up.

    Th game is based on Unreal Engine 3/3.5 and uses the DX11 API.

    What's strange is that up until the end of last year, the OSD was working in RS2 using a much older version of RTSS (6.4.1). I only recently re-installed the game and the latest AB/RTSS, and that's when I noticed this problem.
     
  2. jiminycricket

    jiminycricket Master Guru

    Messages:
    203
    Likes Received:
    4
    GPU:
    GTX 1080
    Last edited: May 25, 2018
  3. MaCk0y

    MaCk0y Maha Guru

    Messages:
    1,169
    Likes Received:
    480
    GPU:
    5700XT
    It does work but disables Steam in-game interface just like Killing Floor 2. Using latest version of MSI and Rivatuner.

    [​IMG]
     
    Last edited: Jun 4, 2018
  4. jiminycricket

    jiminycricket Master Guru

    Messages:
    203
    Likes Received:
    4
    GPU:
    GTX 1080
    No, nothing I've tried for the last 2 weeks has worked.

    I seriously suspect it's an Nvidia GPU/driver or Windows 7 problem at this point. Every person who has shown me that it works, is using an AMD GPU on Windows 10.

    I just tried disabling the injection delay in RTSS, and now the game doesn't even start anymore even after putting the 15s delay back! I'm so done with this crap.

    [​IMG]

    [​IMG]
     

  5. MaCk0y

    MaCk0y Maha Guru

    Messages:
    1,169
    Likes Received:
    480
    GPU:
    5700XT
    BTW, for me when I turn on Afterburner, the game goes into window mode and then I can go back to fullscreen mode. Maybe try to set the game to window mode. Close it, start Afterburner, start the game and then try to enable Afterburner.
     
  6. jiminycricket

    jiminycricket Master Guru

    Messages:
    203
    Likes Received:
    4
    GPU:
    GTX 1080
    Wish I could try this, but the game completely refuses to work now...
     
  7. MaCk0y

    MaCk0y Maha Guru

    Messages:
    1,169
    Likes Received:
    480
    GPU:
    5700XT
    Did you try to verify game files from Steam? Also try to reinstall the Visual C++ from the CommonRedist ->vcredist folder.
     
  8. RealNC

    RealNC Ancient Guru

    Messages:
    3,965
    Likes Received:
    2,171
    GPU:
    EVGA GTX 980 Ti FTW
    To me it sounds like some anti-cheat software that's blocking RTSS. Maybe use an older RTSS version that might have been whitelisted by the anti-cheat.
     
  9. jiminycricket

    jiminycricket Master Guru

    Messages:
    203
    Likes Received:
    4
    GPU:
    GTX 1080
    I fixed it by deleting the contents of the EasyAntiCheat folder inside the game directory. Screw EAC, they are the worst.

    It can't be the anti-cheat blocking it, if it's working for @MaCk0y.
     

Share This Page