RTSS display causes DXGI ERROR_ACCESS_DENIED in LM Prepar3D v5

Discussion in 'Rivatuner Statistics Server (RTSS) Forum' started by Ray Proudfoot, Mar 29, 2021.

  1. Ray Proudfoot

    Ray Proudfoot Active Member

    Messages:
    99
    Likes Received:
    0
    GPU:
    Asus Extreme 8800GTX
    I run MSI Afterburner and RTSS v1.3.1 so I can monitor VRAM and CPU usage in Lockheed-Martin Prepar3D v5.1.

    But when changing vehicles inside a fully loaded sim P3D displays the following message:-

    I have found the 'culprit'. The RTSS display is causing it. If it's turned off whilst changing vehicles the error doesn't occur.

    Is this a known problem and if so, is there a solution planned? It would be nice to have a fix otherwise I have to remember to turn off the display when switching vehicles.
     

    Attached Files:

  2. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,304
    Likes Received:
    2,606
    I do not own Prepar3D and do not play to purchase it, sorry.
     
  3. Ray Proudfoot

    Ray Proudfoot Active Member

    Messages:
    99
    Likes Received:
    0
    GPU:
    Asus Extreme 8800GTX
    Are you the author of RTSS? If so I understand.

    L-M are aware of the problem and may issue a fix for it. But it's easy enough to temporarily disable the display when changing vehicles.

    Thank you for such a useful utility. :)
     
  4. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,116
    Likes Received:
    3,601
    GPU:
    GTX 1080ti
    I believe this might be solved on the RTSS side with a profile containing

    [Hooking]
    HookDXGISwapChainPresentVT = 1

    [RendererDirect3D12]
    QueueDetection = 1
    RestrictMultithreading = 1

    Though it might also be

    [RendererDirect3D12]
    D3D11on12 = 0

    Though like Unwinder, i don't plan to buy this to try, please try yourself by creating a template matching the executable.exe.cfg name with notepad and saving this into it.
     

  5. Ray Proudfoot

    Ray Proudfoot Active Member

    Messages:
    99
    Likes Received:
    0
    GPU:
    Asus Extreme 8800GTX
    @Astyanax , thank you for that. Where is the location of the template I need to create?
     
  6. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,116
    Likes Received:
    3,601
    GPU:
    GTX 1080ti
    c:\Program Files (x86)\RivaTuner Statistics Server\ProfileTemplates\
     
    Ray Proudfoot likes this.
  7. Ray Proudfoot

    Ray Proudfoot Active Member

    Messages:
    99
    Likes Received:
    0
    GPU:
    Asus Extreme 8800GTX
    @Astyanax , I'm sorry to report neither worked. I did close Afterburner and RTSS and restarted both before launching P3Dv5.

    The cfg is named Prepar3D.cfg - the same name as the exe. I included a space before and after the = on each line. Not a problem I assume.

    Assuming the formatting is correct it would seen the problem can only be circumvented by temporarily turning off the display option.
     
  8. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,304
    Likes Received:
    2,606
    Then you're out of luck. P3D's licensing model is greedy as hell and it leaves zero chances that I'll ever purchase it for testing purposes.
     
  9. Ray Proudfoot

    Ray Proudfoot Active Member

    Messages:
    99
    Likes Received:
    0
    GPU:
    Asus Extreme 8800GTX
    Thank you for your help all the same. It's a problem I can work around.
     
  10. Astyanax

    Astyanax Ancient Guru

    Messages:
    10,116
    Likes Received:
    3,601
    GPU:
    GTX 1080ti
    Prepar3D.exe.cfg
     

  11. Ray Proudfoot

    Ray Proudfoot Active Member

    Messages:
    99
    Likes Received:
    0
    GPU:
    Asus Extreme 8800GTX
    I edited the filename to include .exe but it made no difference with either configuration. Seems it's down to LM. They are working on DXGI errors so it's probable they will sort this one.

    Thanks!
     

Share This Page