RivaTuner doesn't recognize auto fan

Discussion in 'Rivatuner Statistics Server (RTSS) Forum' started by fuli, Aug 27, 2009.

  1. fuli

    fuli New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    Asus / EN GTS 250 / 512
    I got Asus GTS 250 with very loud Glaciator fan. For unknown reason RivaTuner does not let me enable (grayed out) Auto setting for the fan from low level settings. Power user > RivaTuner\Fan\AutoFanSpeedControl is set to 3 as instructed.

    Here Unwinder explains, that Auto setting is not available, if card does not have that feature. However this card has automatic fan setting and it is working, as you can see from these stress tests.

    I can set fan speed to 34% from drivers using manual controls, but with auto speed setting fan speed never goes under 48%. Also card seems to idle at 48°C temperature whether the fan is set to 20% or 50%.

    I've tested this with 186.18 and 190.62 drivers and reinstalled latest RivaTuner once.

    Is this RivaTuner bug or how could I set the fan for low speed and get it to speed up when needed?
     
  2. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,673
    Likes Received:
    3,139
    Nope, it's a bug in your understanding, sorry. And I'll repeat the same once again: cheap cards are NOT equipped with hardware automatic fan controller chip. You cannot expect to get access to any low-level fan controller settings because the hardware is unable to adjust fan speed automatically itself on such cards. Period.
    The only option for such cards is software automatic fan control circuit implemented inside NVIDIA driver for such cards.
     
  3. fuli

    fuli New Member

    Messages:
    4
    Likes Received:
    0
    GPU:
    Asus / EN GTS 250 / 512
    So cheap cards in fact do support automatic fan adjustment based on GPU temperature, but RivaTuner just is incapable to tune it? I thought the whole point of RivaTuner is to fiddle driver and card settings to please user preferences. But I got it now, thanks!
     
  4. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,673
    Likes Received:
    3,139
    Ugh... Probably you have to research basics at least a bit before claiming thar RT is just incapable of tuning something?
    Once again, cheap cards DON'T have hardware automatic fan controller and use software emulation at ForceWare level instead. That's a hardcoded SOFTWARE algorithm inside NVIDIA driver, nothing can be tuned there.
    The only purpose of low-level fan control tab is tuning fan controller directly and allowing your graphics subsystem to adjust fan speed itself, without any addional software and drivers. It is just plain stupid to expect some "auto" tuning mode in low-level settings because of lack of automatic fan controller on these cards.
    Furthermore, you can always use the scheduler to program your own automatic SOFTWARE(!!!!) synamic fan control in RT, if you're not satisfied with ForceWare's software automatic fan control implementation for these cards.
    Closed.
     

  5. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,673
    Likes Received:
    3,139
    P.S. I can please user preferences as soon as users understand the basics and their own actions.
     
  6. sauronnikko

    sauronnikko New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    XFX Nvidia 9800 GT 512 MB
    I have a XFX Geforce 9800 GT with 512 MB DDR3. Can someone tell me if this card doesn't allow automatic fan speed controller? I checked in low-level fan control and I can't select auto... Thanks!
     
  7. Stormie74

    Stormie74 Member

    Messages:
    38
    Likes Received:
    0
    GPU:
    Ati HD4670 512
    So i had nowdays gts 250, my friends own 8800 and 9800 and 9600gt cards .... lo price cheap cards ...... no rivatuner fan control
     
    Last edited: Sep 1, 2009
  8. ITGL72

    ITGL72 Member

    Messages:
    10
    Likes Received:
    0
    I assume my GTS 250 is a cheap card then. :wanker:

    When I go to low-level fan control and click ENABLE, I see the slide come alive but when I slide it to 100% and click apply it goes back to 34%.

    Oh well. On my 8800GTX I used to be able to jack it to 100%.
     
  9. Herr_Koos

    Herr_Koos New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    MSI GeForce 9800GTX+ 512
    +1 there, I have a 9800GTX+ which has the same problem. Not a cheap card by any means, at least in its day.
     

Share This Page