1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Rivatuner 2.10 released

Discussion in 'Rivatuner Statistics Server (RTSS) Forum' started by Hilbert Hagedoorn, Sep 1, 2008.

  1. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,209
    Likes Received:
    1,270
    Tricks with signed driver won't help. Fan control implementation from RT's side doesn't depend on the OS, driver or anything else, it is direct low-level access to the controller. For me it looks like the issue of some background software (probably CCC or even ATI driver itself) and capturing the bus.
     
  2. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,209
    Likes Received:
    1,270
    Define "doesn't work for me either". There are issues with 4870 X2 external fan controller support (which is not declared to be supported at all), your 4850 is a completely different story so you hardly can have the same problems.
     
    Last edited: Sep 3, 2008
  3. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,209
    Likes Received:
    1,270

    No. NVStrap doesn't support G9x and newer chips.
     
  4. ribbell

    ribbell Active Member

    Messages:
    55
    Likes Received:
    0
    GPU:
    4870X2
    Have you enabled hardware background monitoring?
    Lemme see the tasks you created and how you set the parameters for one of them. It is better if you report in the thread where i posted the guide.
     

  5. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,209
    Likes Received:
    1,270
    By the way, if you wish we can try special logged build v2.10 to ensure that the problem is in bus capture from some third party software side.
     
  6. ribbell

    ribbell Active Member

    Messages:
    55
    Likes Received:
    0
    GPU:
    4870X2
    Yes, i'm ok wih this attempt.
     
  7. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,209
    Likes Received:
    1,270
    Then give me your email address via PM and I'll send you logged build.
     
  8. Bullu$

    Bullu$ Master Guru

    Messages:
    410
    Likes Received:
    0
    GPU:
    R290X CFX@1050/1350
    I use the driver/cat. from my cd (8.52.6) in xp, after it works i installed the same driver/cat. for vista 64 but still no go. As you already said tricks with signed driver didn't helped.

    That explained rt is freezing,because something capturing the bus?
    That happended when i click on detect now(for the fan).It happend in xp and in vista.

    Also uninstalled some software (xpresstool/att/everest) but still no go.
     
    Last edited: Sep 3, 2008
  9. Bullu$

    Bullu$ Master Guru

    Messages:
    410
    Likes Received:
    0
    GPU:
    R290X CFX@1050/1350
    Ok,will do that after work...(midnight)
     
  10. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,209
    Likes Received:
    1,270
    Nope, delay is supposed to be there, during this delay fan controller's detault state is dumped to the registry.
     

  11. Bullu$

    Bullu$ Master Guru

    Messages:
    410
    Likes Received:
    0
    GPU:
    R290X CFX@1050/1350
    Hope the log build will help us all.
     
  12. ribbell

    ribbell Active Member

    Messages:
    55
    Likes Received:
    0
    GPU:
    4870X2
    Email received, i'll email you the results after work.
    Thank you.
     
  13. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,209
    Likes Received:
    1,270
    Thanks. Check PM please.
     
  14. Bullu$

    Bullu$ Master Guru

    Messages:
    410
    Likes Received:
    0
    GPU:
    R290X CFX@1050/1350
    I see some difference in xp/vista at the driver settings.

    In vista the file ati2evxx.dll (external event utility)isn't found.
    In xp it is ok, it uses version 4177.

    Don't know what that exactly means, but could it be?
    (just wondering)
     
  15. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,209
    Likes Received:
    1,270
    XP and Vista drivers include absolutely different components due to OS architecture differences, that is normal.
     

  16. darkamikaze

    darkamikaze New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    VisionTek ATI HD4850
    well when i Enable Low-Level Fan Control to Auto and run at startup..
    i notice my temperatures don't go down at all.
    Lookup entry 0 says at 60c the fan would be at 31% (unless i'm reading it wrong) and my temperatures go above 70 and then the fan doesn't seem to be spinning at 42%.
    only thing i have are CCC, drivers and RT.
     
    Last edited: Sep 3, 2008
  17. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,209
    Likes Received:
    1,270
  18. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,209
    Likes Received:
    1,270
    ribbel

    Well, I've finished analysing RT activity log captured on your system, thanks. That's not an I2C access trouble for sure, according to log ADT7473 always responds via I2C bus properly. The issue some X2 owners are having actually looks like RT's fan control architecture problem, X2 has 2 chips with 2 different fan controllers active on each of them (external one connected to the first chip and on-die controller intagrated in the second one) and fan defaults detection routine just simply overwrites external fan defaults with internal fan defaults data when enumerating all fan controllers available in the system.
    Don't want to give X2 owners false hopes because it is rather troublesome to bypass and debug such things distantly, but anyway I'll try to implement a workaroung (something like fan controller priority system with external controllers having the highest priority). Will send you test build when new algorithm is ready.
     
  19. ribbell

    ribbell Active Member

    Messages:
    55
    Likes Received:
    0
    GPU:
    4870X2
    Thank you.
    Just out of curiosity, i seen myself the .log generated and if i rembember correctly rivatuner first interrogates display 1 and get controller a controller type, then interrogates display 2 and get another controller type, finally it interrogates for the second time the display 1 and the output of the procedure is true: so it takes as the default controller the controller of display 1 (that is the integrated one, not the external one) and for this reason the check box of low fan settings remains unchecked: it works in this way?
     
  20. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    14,209
    Likes Received:
    1,270
    Yep, almost. And the differences seen under XP and Vista are caused by the specifics of logical display adapters (GPUs) enumeration by different OSes. In simplier words, last polled controller wins. Let's think what can I do to bypass it.
     
    Last edited: Sep 4, 2008

Share This Page