Review: Addlink S70 1TB NVMe M.2 SSD - Is a cheap 3400 MB/s Amazon SSD actually good?

Discussion in 'Frontpage news' started by Hilbert Hagedoorn, Oct 18, 2019.

  1. K.S.

    K.S. Ancient Guru

    Messages:
    1,769
    Likes Received:
    416
    GPU:
    RTX 2080 GAMING OC
    Uh oh! I literally have mine on the desk besides me with a documentary running as I speak er um well type; I'm preparing to install it paired with a Mushkin 1TB NVME kit for RAID. I really hope I don't have similar issues and yours is an isolated incident. :( (I'm just one step up from ya - B450)
     
  2. sykozis

    sykozis Ancient Guru

    Messages:
    21,064
    Likes Received:
    675
    GPU:
    MSI RX5700
    Hopefully your luck is better than mine. If I have to, I'll just keep it as a storage drive until my next upgrade. Right now it's handling my pagefile.
     
  3. alanm

    alanm Ancient Guru

    Messages:
    8,954
    Likes Received:
    1,315
    GPU:
    Asus 2080 Dual OC
    Fresh install? Have you tried both MBR and GPT to initialize the disk?
     
  4. fry178

    fry178 Maha Guru

    Messages:
    1,197
    Likes Received:
    137
    GPU:
    MSI 1080 X@2GHz
    bios set to uefi/win installed that way? using the 1903 build?
     

  5. sykozis

    sykozis Ancient Guru

    Messages:
    21,064
    Likes Received:
    675
    GPU:
    MSI RX5700
    Not yet. I tried cloning the MX300 to the 660P. I planned to try a clean install over the weekend. When I installed the MX300, I simply cloned the Crucial M4 that it replaced. I was hoping the same approach would work again.

    Yes and Yes. UEFI sees the drive. It just won't let me boot from it. It may have been a failed cloning attempt, a compatibility issue, a UEFI issue or just an issue with Windows bootloader itself. I'll find out for certain next weekend. It's really time for a clean install anyway. All the important stuff is already on a separate drive anyway.
     
  6. Mufflore

    Mufflore Ancient Guru

    Messages:
    11,372
    Likes Received:
    589
    GPU:
    Redacted by NDA
    UK Amazon has the Sabrent Rocket 1TB for £109.99 with free delivery.
    Same 5 yr warranty.
    Get it while the EU still exists :p
     
    K.S. likes this.
  7. K.S.

    K.S. Ancient Guru

    Messages:
    1,769
    Likes Received:
    416
    GPU:
    RTX 2080 GAMING OC
    It worked! I threw the 660P into RAID0 with my Mushkin and restored Windows 10 via Microsoft system image. I'm in :)
     
    Last edited: Oct 24, 2019
  8. fry178

    fry178 Maha Guru

    Messages:
    1,197
    Likes Received:
    137
    GPU:
    MSI 1080 X@2GHz
    @sykozis
    Yeah, not cloning drives anymore after switching to the 10, especially when swapping drives.
    It most likely stems from the fact the os doesn't have driver related to the ssd stored since your previous install didn't incl those.
    At least every time i failed with cloning, the same drives would work fine using fresh install...
     
  9. Mufflore

    Mufflore Ancient Guru

    Messages:
    11,372
    Likes Received:
    589
    GPU:
    Redacted by NDA
    You can use a tool to convert E12 drives to 512bytes per sector (they use 4Kbytes by default and are not compatible with 512byte transfers)
    Then you can clone your OS as before.
     
  10. sykozis

    sykozis Ancient Guru

    Messages:
    21,064
    Likes Received:
    675
    GPU:
    MSI RX5700
    I haven't reinstalled Windows since the forced upgrade to Win10. I've been on the same installation this entire time. It started out as a Windows 8.1 install 5 or more years ago so I'm sure a reinstall is probably warranted at this point. It's definitely been recommended enough times in the last 9 months.
     

  11. Robbo9999

    Robbo9999 Maha Guru

    Messages:
    1,333
    Likes Received:
    222
    GPU:
    GTX1070 @2050Mhz
    (Has to be in UEFI mode right?)
     
  12. fry178

    fry178 Maha Guru

    Messages:
    1,197
    Likes Received:
    137
    GPU:
    MSI 1080 X@2GHz
    @sykozis
    :eek:
    Geezus, hope you have at least the MS updates :D

    I don't care to clone anymore, as install from usb to nvme took the same 5min.
    Once i have an image of the OS drive,
    i use that to recover, even to a new drive...
     
  13. sykozis

    sykozis Ancient Guru

    Messages:
    21,064
    Likes Received:
    675
    GPU:
    MSI RX5700
    I don't know if it HAS to be....but I installed Win8.1 in UEFI mode years ago and if I change the OS Compatibility mode to Win10, it forces UEFI mode.
     
  14. fry178

    fry178 Maha Guru

    Messages:
    1,197
    Likes Received:
    137
    GPU:
    MSI 1080 X@2GHz
    might depend on controller/connection (sata vs pcie),
    but for nvme it needs to be on uefi, csm on/off depends on some board/drives but most neds off.
     
  15. sykozis

    sykozis Ancient Guru

    Messages:
    21,064
    Likes Received:
    675
    GPU:
    MSI RX5700
    Got it done and working. Was forced to use Macrium for the cloning. Then had to boot from Windows install media and repair bcd. All in all, took about 2 hours to get everything done. This has been a bit of fun none-the-less.

    In a few months, if there's no issues with the 660P, I'll grab one of the drivers Hilbert just reviewed and we'll see what happens.
     

Share This Page