1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Restart is much slower than shut down - Win 10

Discussion in 'Operating Systems' started by southamptonfc, Oct 7, 2019.

  1. southamptonfc

    southamptonfc Ancient Guru

    Messages:
    1,751
    Likes Received:
    44
    GPU:
    (.)an X
    My system shuts down in less than 5 seconds when I click shut down but takes nearly a minute to shut down if I click restart.

    Anybody know how I can fix this?

    Thanks
     
  2. theoneofgod

    theoneofgod Ancient Guru

    Messages:
    4,068
    Likes Received:
    49
    GPU:
    RX 580 8GB
    Shutting down on later Windows versions is more like hibernation. Are you using an SSD?
     
  3. southamptonfc

    southamptonfc Ancient Guru

    Messages:
    1,751
    Likes Received:
    44
    GPU:
    (.)an X
  4. tsunami231

    tsunami231 Ancient Guru

    Messages:
    9,670
    Likes Received:
    360
    GPU:
    EVGA 1070Ti Black
    turn off fast startup. it one of the first things I do, along with disabling hibernation
     
    Blackfyre likes this.

  5. HK-1

    HK-1 Master Guru

    Messages:
    586
    Likes Received:
    240
    GPU:
    XFX RX460
    ^^
    same here
     
  6. southamptonfc

    southamptonfc Ancient Guru

    Messages:
    1,751
    Likes Received:
    44
    GPU:
    (.)an X
    Surely that will just slow down shutdowns? With an NVME, hibernation is ultra-quick.

    IMO They should make restart default behavior the same as shutdown. 99% of the time you don't want to reset your kernel. For the 1% of the time that you do, we just need a new reset option.
     
  7. Astyanax

    Astyanax Ancient Guru

    Messages:
    3,271
    Likes Received:
    844
    GPU:
    GTX 1080ti
    hiberboot introduces so many issues with windows, its not worth the extra shutdown speed
     
  8. K.S.

    K.S. Maha Guru

    Messages:
    1,448
    Likes Received:
    275
    GPU:
    RTX 2080 GAMING OC
    hybrid shutdown vs hard shutdown (lookup registry entries for it)

    far as slow restarts - play with msconfig - iso to ms services and component iso until you find whatever is holding your machine up.
     
  9. tsunami231

    tsunami231 Ancient Guru

    Messages:
    9,670
    Likes Received:
    360
    GPU:
    EVGA 1070Ti Black

    no it actual made things slower which is why I turn it off, and seeing I dont use hibernations or any of that sleep stuff I dont care for what the function does. what 10 seconds to start the pc from first boot to desktop usability to slow or something? reboot and shut downs takes seconds for me, with it off with it on it was double. Every pc I left Fastboot on has had extend reboot/shutdown times, and turned off it much quicker and this is with SSD

    This is another reason why dont use that stuff

    When I go to shutdown my pc I want to shutdown and when I reboot my pc I want to reboot and usual for good reason, I dont want it to remeber what I was last doing and save things so i all opens up again. I even turn off that in windows function that restore open programs upon reboot cause I hate that too.
     
    Last edited: Oct 8, 2019
  10. southamptonfc

    southamptonfc Ancient Guru

    Messages:
    1,751
    Likes Received:
    44
    GPU:
    (.)an X
    I switched off fast startup. Shut down takes a little longer but hasn't helped at all with restarts.

    Thanks, I'll have a look
     

  11. tsunami231

    tsunami231 Ancient Guru

    Messages:
    9,670
    Likes Received:
    360
    GPU:
    EVGA 1070Ti Black
    there has to be something causing restart to hang and take longer. which make me wonder if you have some sort hibernation or sleep going that save the state of the system instead of restarting, I have all that stuff turned off iin windows and some of it disable in bios.

    Hell it could stray app that got update which interacting with the system in a bad way. I remeber years back I had issue where my startup and shutdown/restart took twice as long cause Avast and it took Avast 2 years to fix it. which was also related to fast startup but turn fast startup off didnt solve the issue just reduce the bootup/restart/shutdown times, only when Avast fix there crap or I remove avast did that issue go away, but for me I have faster bootups and shutdowns and restart with that off.
     
    Last edited: Oct 10, 2019 at 1:17 AM
  12. RealNC

    RealNC Ancient Guru

    Messages:
    3,073
    Likes Received:
    1,315
    GPU:
    EVGA GTX 980 Ti FTW
    That would make a restart meaningless, since it wouldn't restart the OS. It would just do a pause/resume.
     
  13. southamptonfc

    southamptonfc Ancient Guru

    Messages:
    1,751
    Likes Received:
    44
    GPU:
    (.)an X
    Agreed, except if like me, you wanted to change a BIOS setting and don't need to restart the kernel.
     
  14. RealNC

    RealNC Ancient Guru

    Messages:
    3,073
    Likes Received:
    1,315
    GPU:
    EVGA GTX 980 Ti FTW
    I'm pretty sure the kernel should always be restarted when there's BIOS settings changes, otherwise you'd end up with in-kernel UEFI variables that are out of sync.
     
    sykozis likes this.
  15. southamptonfc

    southamptonfc Ancient Guru

    Messages:
    1,751
    Likes Received:
    44
    GPU:
    (.)an X
    OK yes, sounds like that could cause issues, it will happen however if people shutdown (with fast boot enabled) and then make BIOS changes, so maybe it's a use-case that M$ have accounted for?

    I've been doing it all week as I mess around with my new system. Generally it was OK, Windows didn't seem affected apart from 1 time where Heaven just wouldn't run after an OC failure. The fix was to do a restart, not a shutdown.
     

  16. sykozis

    sykozis Ancient Guru

    Messages:
    21,004
    Likes Received:
    656
    GPU:
    MSI RX5700
    I have to disable Fast Start to be able to get into UEFI without rebooting.

    Aside from changing hardware, I've never had any issues related to Fast Start being enabled so exactly what problems is it supposed to cause?
     
  17. airbud7

    airbud7 Ancient Guru

    Messages:
    7,409
    Likes Received:
    4,041
    GPU:
    pny gtx 1060 xlr8
    Hold the shift key while shut down or hit restart,,,,Same thing....it will be a longer restart though!

    everything is clear.
     
  18. Astyanax

    Astyanax Ancient Guru

    Messages:
    3,271
    Likes Received:
    844
    GPU:
    GTX 1080ti
    It isn't nice with a number of drivers for networking / wifi, XFI issues,
    on and off Windows bugs (some noted on the dashboard right now). (Gamma/night light, etc)
    Doesn't support WOL/WWoLAN,


    Since it is literally just a partial Hibernation, the usual issues that go with hibernation are there.

    Depending on the software you have installed, you might not even realist the feature is disabled.

    PerfectDisks boot loader disables it
    Acronis WD edition disables it (or more accurately, the scheduler does)

    I could sit here all day posting up windows build and system specific fast startup related topics, but that'd be a pita.
     

Share This Page