Red Faction Guerrilla - I Can make it not lag, but it wont stay not laggy.

Discussion in 'Games, Gaming & Game-demos' started by 13thvulture, Dec 11, 2010.

  1. 13thvulture

    13thvulture Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    ATI Mobility Radeon 4200
    I am having a very hard time getting red faction guerrilla working.

    here's my problem, it lags.

    ive tried all the common lag fixes for this game: windowed mode, changing its priority in task manager, patching it, forcing directx9, shutting off vsync, and of course smaller resolution/low detail. none of it did a thing.

    but i noticed something interesting, the first time i ran it after a fresh install it would run fine, and in the settings it would have the refresh rate at 60hz and run perfectly on the first run, and any time after the first run after a fresh install, it would change to 59hz and lag like crazy. either way, it wont let me change the refresh rate setting, it sticks on whatever its on.

    for a while, i could get it to go back to 60hz by deleting the options folder (c:/documents/my games/red faction guerrilla/options) but after a few times, that stopped working and a reinstall is all that would get it back, and now even reinstalling wont do it, it stays 59hz no matter what i do.

    what could have caused this? and any advice on keeping it 60hz? im thinking its something to do with the game itself rather than my computer, but im not 100% sure. and why did uninstalling and reinstalling stop working? every time i had it delete all savegames and preferences, did it keep something?
     
  2. shimyns

    shimyns Ancient Guru

    Messages:
    1,657
    Likes Received:
    0
    GPU:
    SAPPHIRE r9 290x Tri-X OC
    I had lots of lag and input delay problems with that game (when I played it a long time ago). I'm sorry, I don't have any concrete advice to offer, especially about your Hz question. I do remember that setting Ambient Occlusion off helped somewhat, and also Alt-Tabing out and back in sometimes helped, as well.
     
  3. Paulo Narciso

    Paulo Narciso Maha Guru

    Messages:
    1,219
    Likes Received:
    32
    GPU:
    ASUS Strix GTX 1080 Ti
    This game needs a fast cpu. And ATI cards won't get along very well with this game.
     
  4. TheHunter

    TheHunter Banned

    Messages:
    13,408
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    when it first came out it was ok, even with 1.1 patch it ran smooth, but after the latest patch they did something- also removed some adv settings and now it runs much worse.. if you can then downgrade to 1.1 patch, well i could mine was retail not steam.
     

  5. 13thvulture

    13thvulture Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    ATI Mobility Radeon 4200
    the times when i somehow manage to get it running at 60hz it plays completely smooth, i didn't check the fps but id guess it was in the 35-40 range, even when blowing stuff up. no input lag at all. and i played for hours like that, so i know my card can do it. i just dont know how to keep it that way, because it resets to 59hz upon restarting it, and deleting the options and reinstalling no longer works for who knows why.
     
  6. Damien_Azreal

    Damien_Azreal Ancient Guru

    Messages:
    10,226
    Likes Received:
    1,344
    GPU:
    Gigabyte 1070 Ti
    I'd say your CPU is a big problem with this game. As Paulo said, the game needs a really strong CPU... and yours just doesn't have enough.. umph.
     
  7. IcE

    IcE Don Snow Staff Member

    Messages:
    10,693
    Likes Received:
    73
    GPU:
    Zotac GTX 1070 Mini
    Yeah, it really doesn't like ATI cards. Ran very poorly with a strange skipping issue on my old 4850. With my 470 it's butter smooth.

    The game is actually much more GPU dependant surprisingly. I had it running just fine framerate wise on an ancient Athlon 64 X2 at one point.
     
  8. Damien_Azreal

    Damien_Azreal Ancient Guru

    Messages:
    10,226
    Likes Received:
    1,344
    GPU:
    Gigabyte 1070 Ti
    Yeah, I ran it well on an AMD x2 4600 as well.
     
  9. 13thvulture

    13thvulture Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    ATI Mobility Radeon 4200
    the thing is, when it is at 60hz the game plays perfectly... thats what doesnt make sense. nice avatar btw, blood is one of the best games ive ever played
     
  10. 13thvulture

    13thvulture Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    ATI Mobility Radeon 4200
    here's what i really want to know (because i can live with reinstalling if i must) what could possibly make it stop working after a fresh install? i set it to delete the save games and preferences, and i thought i cleared out any files left... what else can i try? whats it keeping?
     

  11. sprower

    sprower Master Guru

    Messages:
    226
    Likes Received:
    0
    GPU:
    TriFire5770 9800GT Physx
    Not sure about your issue 13th. All I can say is this game is pretty damn picky. More recent drivers were giving me crap with it left and right (though that was more of a crossfire issue).

    Try different drivers or maybe RadeonPro to force the frame rate to 60?

    Another thought is if the game crashes on you the settings.ini may return to defaults after restarting the game. That may be causing some conflict or IQ settings to be set higher than your mobility likes.
     
  12. 13thvulture

    13thvulture Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    ATI Mobility Radeon 4200
    radeonpro didn't help it :bang:
     
  13. TheHunter

    TheHunter Banned

    Messages:
    13,408
    Likes Received:
    1
    GPU:
    MSi N570GTX TFIII [OC|PE]
    so did you try and downgrade to 1.1 patch?
     
  14. shimyns

    shimyns Ancient Guru

    Messages:
    1,657
    Likes Received:
    0
    GPU:
    SAPPHIRE r9 290x Tri-X OC
    If the game wants to run at 59 Hz, why don't you just change your monitors refresh rate to 59 Hz (in CCC)? Make sure that you are playing the game at the same resolution as the main resolution you have set in CCC. Just a thought.

    Here is a general article of 59/60 Hz in win 7, although it doesn't provide any solutions for your particular case, it does kinda seem that it has to do with your monitor and win 7either rounding the integer up or down http://support.microsoft.com/kb/2006076

    Anyway, I would try gaming at the same res as your desktop while making sure that the Hz setting in CCC is identical to the ingame Hz.
     
  15. Agonist

    Agonist Ancient Guru

    Messages:
    2,762
    Likes Received:
    179
    GPU:
    RX Vega 56 8GB
    It runs great on my 5770 my hd 4870 and hd 3850 lol. 3850 isnt too far off the performance of my 9800gtx+ either. its only a hd 3850 256mb.
     

  16. 13thvulture

    13thvulture Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    ATI Mobility Radeon 4200
    well, im not actually able to set my screen's refresh rate, because in the monitor settings, graphics card settings, and CCC all of them only have 60hz as an option.
     
  17. shimyns

    shimyns Ancient Guru

    Messages:
    1,657
    Likes Received:
    0
    GPU:
    SAPPHIRE r9 290x Tri-X OC
    In CCC, I personally have the option of setting 56, 59 or 60 Hz. Must be that options are limited to the particular screen.

    [​IMG]
     
    Last edited: Dec 15, 2010
  18. 13thvulture

    13thvulture Member

    Messages:
    11
    Likes Received:
    0
    GPU:
    ATI Mobility Radeon 4200
    yep. same box for me only has 60 as an option :/
     
  19. ScoobyDooby

    ScoobyDooby Ancient Guru

    Messages:
    7,090
    Likes Received:
    58
    GPU:
    1080Ti & Acer X34
    I was never able to get this game playing smoothly really at all. Wasn't too bad when on foot, was tolerable, but once you started to do quests driving around and whatnot it was a serious PITA.

    I remember hearing the same advice, you need a better CPU but I honestly think that's incorrect. The game may need a stronger CPU, but when every other game I play doesn't stutter like that you know its either that it just doesnt prefer ATI cards or that its poorly coded.
    I am going with the latter, because many people had stutter and jitter issues with the game at all settings. I could have played it at 1024x768 with all settings low and it would still stutter.. even crysis didn't play anywhere near that poorly for me with a dual core, so I don't buy that argument at all.

    I recall some people saying to use particular drivers and to not update it past 1.1, but for the drivers I can't recall which set. Probably far too old by now anyway to matter.
     
  20. IcE

    IcE Don Snow Staff Member

    Messages:
    10,693
    Likes Received:
    73
    GPU:
    Zotac GTX 1070 Mini
    As I said, the game seems to hate ATI cards. I would get a weird skipping issue on my old 4850 no matter what the settings. On my 470 it's literally butter smooth and very enjoyable.

    That was just my experience but I know I'm not alone.
     

Share This Page