Recording Issue (Compressed) - GTX 670

Discussion in 'MSI AfterBurner Application Development Forum' started by KNFr-Rhe7oric, Jan 3, 2013.

  1. KNFr-Rhe7oric

    KNFr-Rhe7oric New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    nVidia Geforce GTX 670
    Alright, so I've already tried looking around for this issue and I can't seem to find other existing threads on it.

    Settings: http://i.imgur.com/1cpEI.jpg

    Whenever I try to record using MSI Afterburner using either the MJPEG or RTV1 Compression setting, I run into the issue of it partially recording everything. In other words, I'd film a 10 minute gameplay of whatever game I'm playing, but the resulting video length would only be around 1:47 and the audio would cut out around halfway into said video, even though during the actual recording process, I would see the little purple circle recording icon during that full 10 minute period.

    This issue does not happen when I record uncompressed, but I'll be damned if I keep on making 80GB~ file sizes for a 10~15 minute recording. The only workaround I have right now is recording uncompressed, and then using either VirtualDub with the XviD compression for .AVI files that I will use in Sony Vegas to edit, or for just raw gameplay videos that I want to upload with no editing whatsoever, using Handbrake to convert them to .MP4 files for quick uploads. It works, but its more work to achieve the same goal.

    I've messed around with the resulting video sizes, including the 1080p and 720p presets and I still get the same issues. Will provide more specific details as requested. Any help would be greatly appreciated.
     
    Last edited: Jan 4, 2013
  2. KNFr-Rhe7oric

    KNFr-Rhe7oric New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    nVidia Geforce GTX 670
    Bump: I think I may have isolated the problem, which was having the "Enable MJPEG Decoder" box checked. Having it unchecked, I was able to record in the Lagarith Lossless video codec for about a good 7 minutes without any premature sound loss or video cutting off prematurely. I still don't know how well the default MJPEG or RTV1 recording will work, but at this point, any compressed video is better than recording uncompressed.

    Note that I had tried another recording prior with the Lagarith lossless codec but with the "Enable MJPEG Decoder" box enabled, and I was still getting the above problems. Further testing is required, but I think I may have solved the issue.
     
  3. Unwinder

    Unwinder Moderator Staff Member

    Messages:
    15,564
    Likes Received:
    2,963
    Unreal and 100% placebo effect. It doesn't affect capture.
     
  4. KNFr-Rhe7oric

    KNFr-Rhe7oric New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    nVidia Geforce GTX 670
    If it [Enable MJPEG Decoder] is a placebo effect, then what could the problem be? I'm really thrown for a loop on this one. As I said before, I don't have the premature video and/or audio cutting out issue when I record uncompressed, it only seems to happen when I have any type of compression setting, regardless of codec used.

    The only other thing I can think of is that it might be a hard drive issue. I have two hard drives, one 72GB for my operating system only, and a 1TB one for all my games/programs/etc and recording. Ideally, I'd have a third one for straight up recording, but all things in time...
     
    Last edited: Jan 9, 2013

Share This Page