Recent Nvidia Drivers are the cause of your hitching/stuttering in games.

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by snight01, Sep 14, 2015.

  1. Netherwind

    Netherwind Ancient Guru

    Messages:
    8,013
    Likes Received:
    1,760
    GPU:
    MSI 3080 Gaming X
    Nothing helps for me either and a reformat would probably solve things. But if you dont want to reformat you can simply increase process priority like I do. Works really well.
     
  2. Margusx

    Margusx Active Member

    Messages:
    50
    Likes Received:
    0
    GPU:
    Msi GTX970 gaming 4g
    netherwind

    no need format just do reset its restore os to state its was 1st installed you not lose files only have to reistall stuff if you use steam on other drive just reinstall it to that drive you not have to download anything.

    Probably you have some annoying virus or rootkit somewhere hidden.
     
    Last edited: Sep 23, 2015
  3. IcE

    IcE Don Snow Staff Member

    Messages:
    10,696
    Likes Received:
    78
    GPU:
    3070Ti FE
    I reformat like every week, lol. I did it again yesterday. Very unlikely its OS related.
     
  4. psefergr70

    psefergr70 Member

    Messages:
    26
    Likes Received:
    2
    GPU:
    gigabyte g1 gaming gtx970
    I don't want to play it smart but have you thought that may be the antivirus you are using sucks? I had enough problems with hitch and stuttering (nvidia gtx 970) and it was my antivirus.I don't know why they release antivirus and security if they are not 100% sure that they are complete compatible.I was using kaspersky for many years without a problem but in windows 10 it's terrible and some problems are not solved even if you exit the program from the taskbar.You have to completely uninstall it!
     

  5. Deedge

    Deedge Banned

    Messages:
    106
    Likes Received:
    0
    GPU:
    680m SLI
    Did you defiantly do the " MSI Mode" correctly? from here : Google this as i can not post links still : " Windows: Line-Based vs. Message Signaled-Based Interrupts ... " I also do not have an anti virus program running right now. I also have set afterburner to 120 FPS max limit, i have river tuner also set to 120 FPS as i have a 120hz monitor. I also use program named "Powermizer Switch.exe" im not sure if it will aslo work with the 970. I also applied this from this you-tube video, Youtube this : " How to Enable PCI Express 3.0 Bus Speeds in Windows 7/8 " there is a program to download and run there. " I also have " bcdedit /set useplatformclock true " set! I also have these power reg files installed. Look here for them, Google this : " TweakTown's Ultimate Windows SSD Performance Installation Guide - Advanced Power Settings " I am running the 355.82 driver just now. I have no stuttering at all in games. I do find that driver dose randomly crash after a few hours of constant use. I also have Intel management engine 11.0.0.144 installed. I do not own witcher 3 so i can not comment on the performance of that game.
     
  6. Deedge

    Deedge Banned

    Messages:
    106
    Likes Received:
    0
    GPU:
    680m SLI
    ...sorry one more thing is that i went through all my devices in device manager and made sure that all the devices power management settings are all turned to off.
     
  7. mbk1969

    mbk1969 Ancient Guru

    Messages:
    12,620
    Likes Received:
    10,793
    GPU:
    GF RTX 3060TI
    This is old story and was true only for x79 chipset with IB-E processors - due to bad implementation of PCIe v3 in those CPUs.
     
  8. Deedge

    Deedge Banned

    Messages:
    106
    Likes Received:
    0
    GPU:
    680m SLI
    Thanks.. i did not know.To be fair i think i have applied every fix i could find to get the games running well and to stop the stutter that i had....:bang: :)
     
  9. IcE

    IcE Don Snow Staff Member

    Messages:
    10,696
    Likes Received:
    78
    GPU:
    3070Ti FE
    I don't actually use any AV at all. Windows Defender is on right now in 10, but I tried going with out that too and nothing changed.

    I've tried all that stuff before and never really had any success or noticed any difference. The Intel and Nvidia drivers are already set up to use MSI mode so I don't see the point of messing with that in particular.

    Anyway, for those with the Mad Max issue, let's see if we have anything in common that might be related. What OS are you guys on, and what AV are you using?
     
    Last edited: Sep 24, 2015
  10. tsunami231

    tsunami231 Ancient Guru

    Messages:
    12,990
    Likes Received:
    1,173
    GPU:
    EVGA 1070Ti Black
    nvidia drivers defualt to msi mode for you?? they dont for me and never have, maybe cause i using x58 still

    neither Win7 or Win10 defualt to msi mode for nvidia drivers i have to do manual, not that i ever seen diffrence, I just do it cause i dont want my GPU/Sound/USB ports sharing the same irq
     

  11. IcE

    IcE Don Snow Staff Member

    Messages:
    10,696
    Likes Received:
    78
    GPU:
    3070Ti FE
    Could have sworn they switched to MSI a while ago as part of their massive "optimization" phase to compete with Mantle. At least for the actual graphics driver.
     
  12. Ital

    Ital Member Guru

    Messages:
    196
    Likes Received:
    75
    GPU:
    ZOTAC GTX 1080 AMP
    MSI mode is enabled by default only for Quadro cards. For GeForce cards, MSI is disabled by default.
     
  13. Monchis

    Monchis Maha Guru

    Messages:
    1,303
    Likes Received:
    36
    GPU:
    GTX 950
    For me latest couple of drivers make F1 2015 stutter like mad after restarting races. With 353.94 everything is fine again.

    Also, anyone having constant stuttering in Leo´s Fortune?. Game runs at constant 60fps and my screen is at 60hz but scrolling is very jumpy.
     
  14. Memorian

    Memorian Ancient Guru

    Messages:
    3,427
    Likes Received:
    434
    GPU:
    RTX 3080 Ti
    Win10 Pro 64bit
    I use Malwarebytes but realtime protection is disabled, so it doesn't even run. Well, i use the cracked version of the game, so i don't know if that has any effect.
     
  15. Deedge

    Deedge Banned

    Messages:
    106
    Likes Received:
    0
    GPU:
    680m SLI

    Mad max runs fine here. I am on windows 8.1. Just installed Nvidia 356.04 developer driver last night.It ran very well! Would sure recommend. :)
     

  16. MrH

    MrH Ancient Guru

    Messages:
    2,810
    Likes Received:
    14
    GPU:
    RTX 3080 FE
    Windows 10_Home 64. Defender, with the Steam folder as an exception. 60fps on very high 99.9% of the time, but with the random 1 second freeze every 10 - 15 minutes.
     
  17. RzrTrek

    RzrTrek Ancient Guru

    Messages:
    2,549
    Likes Received:
    740
    GPU:
    RX 580 ♥ MESA 22.2
    I'm glad to hear (despite how unfortunate) that I'm not the only one having 1s freezes with 353/355.xx (also applies to 356.04) drivers even with having the latest IME driver installed on Windows 10 (x64) every once in a while...
     
    Last edited: Sep 24, 2015
  18. drewho

    drewho Master Guru

    Messages:
    431
    Likes Received:
    19
    GPU:
    RTX3090
    Mad max 1sec freeze here randomly around 30 mins, no antivirus.
    Win10 Pro 64bit.
    Just afterburner running.
     
  19. Memorian

    Memorian Ancient Guru

    Messages:
    3,427
    Likes Received:
    434
    GPU:
    RTX 3080 Ti
    So it's not a ''GTX970 thing''..What a surprise..
     
  20. snight01

    snight01 Master Guru

    Messages:
    343
    Likes Received:
    40
    GPU:
    RTX 2080 Ti FE
    Finally found out the issue..

    Nvidia is gimping performance. Metal gear solid ground zeroes ran a perfect 60 with all settings very high on 347.25.. and suddenly with the recent drivers including 355.98, it now drops to 51 which causes the game to hitch.

    im using kepler... titan black. well done nvidia, back then i use to worry about the optimization of the game now its about nvidia and they shady tactics to buy new gpu's by gimping performance and introducing hitching in games


    After a couple of days i came to conclusion. Its going to get worse for older cards and performance because nvidia drops performance, even going the length of removing performance updates from older titles that previously had it.

    This came from extreme testing and disabling everything, even deleting cortana, and the shellexperiencehost. which allows me to use my full amount of vram with no interruptions. The disable shader cache and threading advice is rubbish

    This isnt a driver issue, overclocking issue, not even a HPET issue. If it was someone would've put the pieces together and resolve it. Just as the CUDA issue, the MEI and timer resolution issue with cryengine etc and nvidia driver sabotage.

    This is a nvidia driver issue and believe i did all i could to resolve this. Only option is to downgrade to 347.25 if you want the Real game ready for the phantom pain and ground zeroes.


    Would love to hear manual g thoughts on this.
     
    Last edited: Sep 24, 2015

Share This Page