Recent Nvidia Drivers are the cause of your hitching/stuttering in games.

Discussion in 'Videocards - NVIDIA GeForce Drivers Section' started by snight01, Sep 14, 2015.

  1. snight01

    snight01 Master Guru

    Messages:
    222
    Likes Received:
    0
    GPU:
    EVGA GTX 1080
    Including the latest release 355.82.

    You can disable Speedstep, C states, raise voltage, disable link power management, set high performance and everything else. Nothing will stop it from hitching.

    This happened many times before and documented here

    https://forums.geforce.com/default/topic/797098/geforce-drivers/occasional-stuttering-pause-/1/

    Being fixed in 347.25 and reintroduced with the later drivers. If you're stuttering in many games, downclock. 347.25 works with the phantom pain and doesnt stutter or hitch unless its the game steaming its assets, but the witcher 3 plays horrible with 347.

    If the new drivers are giving you a hard time just downgrade to a version you remembered worked perfectly. I havent tested and monitored all.
     
    Last edited: Sep 14, 2015
  2. snight01

    snight01 Master Guru

    Messages:
    222
    Likes Received:
    0
    GPU:
    EVGA GTX 1080
  3. Netherwind

    Netherwind Ancient Guru

    Messages:
    4,932
    Likes Received:
    5
    GPU:
    MSI 1080Ti 2038/12006MHz
    ManuelG - Care to comment?
     
  4. Nono06

    Nono06 Master Guru

    Messages:
    865
    Likes Received:
    0
    GPU:
    680 GTX SLI (1215/6884)

  5. RzrTrek

    RzrTrek Maha Guru

    Messages:
    1,117
    Likes Received:
    30
    GPU:
    RX580 (8GB)
    Thank you for the advice!
     
  6. khanmein

    khanmein Maha Guru

    Messages:
    1,333
    Likes Received:
    11
    GPU:
    EVGA GTX 1070 SC ACX 3.0
    he's busy fixing the driver..
     
  7. Netherwind

    Netherwind Ancient Guru

    Messages:
    4,932
    Likes Received:
    5
    GPU:
    MSI 1080Ti 2038/12006MHz
    Hope that's true...
     
  8. MrH

    MrH Ancient Guru

    Messages:
    2,790
    Likes Received:
    5
    GPU:
    MSI GTX 970 4G
    I've been getting hitching in games, I've reinstalled Win8.1, Win10, reset bios, removed overclocks etc and I've just started the process to RMA my card as I thought it was faulty, if it's just a driver issue that would be crazy. My issue is I can play for maybe 2 - 3 hours with no issue, then any game will start to hitch and drop frames constantly, is this the problem caused by the drivers? And Witcher III is the game giving me most issues with the stuttering. I'm on Win10 though so this solution isn't for me :/

    This is a video I made: https://www.youtube.com/watch?v=3eo7sEukl6E
     
    Last edited: Sep 14, 2015
  9. NeoandGeo

    NeoandGeo Master Guru

    Messages:
    736
    Likes Received:
    0
    GPU:
    Geforce GTX 970 @1420
    I haven't been getting hitching in the recent games I've played, including Mad Max and Witcher 3 with any of the Windows 10 driversets and Win10 Insider builds, even with a very high overclock on my 980 (1,540Mhz). What exactly is happening with your guys' GPU/GPU usage when the hitching occurs?
     
  10. PapaJohn

    PapaJohn Member Guru

    Messages:
    160
    Likes Received:
    0
    GPU:
    980 Ti
    Got to be honest, I was tearing my hair out on a new rig. I started a thread about stuttering in most games, albeit I'm on an older card it should only result in less fps, not stuttering if I'm staying within vram restraints and don't overdo settings.

    What do you know, out of desperation I installed Windows fricking 7 last night and a driver from last year. Flawless in every game I have tried.

    I'm staying on that till I can afford a nice high end card and monitor, hopefully Windows 10 and driver issues will be smooth sailing at that point. Shame as I do like the new OS just doesn't work well for me at the moment :)
     

  11. MrH

    MrH Ancient Guru

    Messages:
    2,790
    Likes Received:
    5
    GPU:
    MSI GTX 970 4G
    @PapaJohn can you watch my video and see if you had the same issue?
     
  12. NeoandGeo

    NeoandGeo Master Guru

    Messages:
    736
    Likes Received:
    0
    GPU:
    Geforce GTX 970 @1420
    Mr. H, in that video it looks like your game is hitching due to CPU usage maxing out, do you get the exact same hitching when your CPU usage isn't maxed and what does your GPU usage look like throughout the hitching?
     
  13. PapaJohn

    PapaJohn Member Guru

    Messages:
    160
    Likes Received:
    0
    GPU:
    980 Ti
    No that looks worse and more consistent to be fair. Mine was more intermittent, distracting enough that I would be waiting for the next one. Frametime variance was the issue, it was all over the place and didn't correlate to the framerate displayed.

    For example, 30fps you expect 33.3ms but mine would be jumping way above and below so kinda like 26ms,38,32,33, 39 ms and so onscreen it would look like a jumpy mess.

    Not getting that on good old ancient Windows 7. It's been that long, I've forgotten how to use it.....Any Metro is back apps out there?:3eyes:J/K
     
  14. NeoandGeo

    NeoandGeo Master Guru

    Messages:
    736
    Likes Received:
    0
    GPU:
    Geforce GTX 970 @1420
    For frametime variations with a solid framerate you should try capping your framerate using Rivatuner or a similar program and also try switching back and forth between in-game and NVCP V-Sync, sometimes in-game is inconsistent compared to NVCP and vice versa.

    A good example: Most UE3 games suck balls on anything but Windows 7, with solid framerates but horrid frametimes that bounce all over the place. For Borderlands I have to cap the framerate to 60 with Rivatuner and use NVCP V-Sync (this is due to developer incompetence) to get a somewhat steady frametime. For 30fps games the best gameplay experience comes from "NVCP Half Refresh Rate V-Sync" and capping the framerate to 30 using Rivatuner.
     
  15. BadDriver

    BadDriver Master Guru

    Messages:
    271
    Likes Received:
    0
    GPU:
    ASUS ROG STRIX-GTX1070-8G
    NO he is on the beach having fun spending the money where we bought the bad product with.
     

  16. NeoandGeo

    NeoandGeo Master Guru

    Messages:
    736
    Likes Received:
    0
    GPU:
    Geforce GTX 970 @1420
    Also contemplating how to retract lies about overclocking capabilities of laptop GPUs.:puke2:
     
  17. RzrTrek

    RzrTrek Maha Guru

    Messages:
    1,117
    Likes Received:
    30
    GPU:
    RX580 (8GB)
    The stuttering started after having "upgraded" to Windows 10 using 353/355.xx drivers to the point where Saints Row IV, Team Fortress 2 and Warhammer 40,000: Space Marines are almost non-playable.
     
  18. NeoandGeo

    NeoandGeo Master Guru

    Messages:
    736
    Likes Received:
    0
    GPU:
    Geforce GTX 970 @1420
    Have you tried doing a clean install of Windows 10 and/or the drivers themselves? Something may have went wrong with the upgrade and your system is corrupt.
     
  19. RzrTrek

    RzrTrek Maha Guru

    Messages:
    1,117
    Likes Received:
    30
    GPU:
    RX580 (8GB)
    You know what, I wasn't born yesterday... but yes, several times!
     
  20. snight01

    snight01 Master Guru

    Messages:
    222
    Likes Received:
    0
    GPU:
    EVGA GTX 1080
    The new version 1163 removes the timer resolution optimization. It basically performs like the older drivers in windows 7. While 1144 optimizes the cpu timer resolution and scales it to perform perfectly.

    Known games that perform horrible and the dpc latency is high when the cpu timer is not optimized is counter strike, half life 2, saints row, crysis 3 and ori and the blind forest.

    Crysis 3 is the main testbench since it requires the cpu timer to be really low to perform great and this is where it shines the most.

    If you don't want to downgrade to 1144 you can use cpu timer resolution tool but i highly recommend you use install the mei driver and test for yourself.

    Strangly enough, this driver was actually hard to find until biostar listed it. I'm using all the drivers from biostar windows 10 selection and it works great on windows 8.1 also.

    Also what puzzles me is, why did intel remove this optimization from the later releases?
     

Share This Page