RadeonPro & STALKER Call of Pripyat

Discussion in 'Games, Gaming & Game-demos' started by Bacab, Aug 3, 2013.

  1. Bacab

    Bacab New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    AMD Radeon 7870 2Gb
    Hello !
    Not sure I'm in the right section. If I'm not could you please move this thread to the appropriate one. Thanks.

    I've always experienced stuttering while playing Call of Pripyat no matter the settings. Recently I've heard that enabling dynamic Vsync using RadeonPro may fix this issue. An other solution would be to set Vsync to double and frame rate limit to 30 fps. I would like to try those solutions however I can't figure out how to correctly set the launchers options of Call of Pripyat (in RadeonPro) to make it work (I'm using the box version of CoP). FRAPS indicates that I have between 100 fps and 60 fps. Even the Vsync from the game options does not work.
    Do you have any idea how I may solve the problem ?
    Thank you in advance for your help.

    PS: If you have noticed any grammatical or misspelling mistakes please ignore them. English isn't my mother tongue.
     
    Last edited by a moderator: Aug 5, 2013
  2. Vector

    Vector Ancient Guru

    Messages:
    1,509
    Likes Received:
    0
    GPU:
    GTX 770 FTW 4gb w/bkplate
    Try -noprefetch on the command line. Make sure you have a space before the dash. However some statements on the Internet say that this switch was disabled in CoP. I don't know for sure if this is true.


    I found this post at GSC forums:

    For anyone having stuttering problems ...

    I tried a' NO PREFETCH' patch and it got rid of 99% of my stuttering.

    File name was 'stalker_cop_prefetch_options_mod.rar' from here 'http://www.mediafire.com/?eoukyzlylyj'.

    At your own risk.
     
    Last edited: Aug 3, 2013
  3. Bacab

    Bacab New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    AMD Radeon 7870 2Gb
    I will try.

    EDIT: It may be a bit better but the game still freeze a lot.
     
    Last edited: Aug 4, 2013
  4. millibyte

    millibyte Maha Guru

    Messages:
    1,201
    Likes Received:
    134
    GPU:
    2070 subpar RTX OFF
    Try with RadeonPro, create a new profile selecting the xrEngine.exe, not Stalker-COP.exe located in the main directory. Should look something like this:

    ...\bitComposer Games\S.T.A.L.K.E.R. - Call of Pripyat\bin\xrEngine.exe

    Then in the tweaks section, select "Always on" from Vsync Control, Triple Buffering, and Dynamic Frame Rate keep to 60 fps.

    You can deselect Vsync in the in game options.

    I was just playing the other day and it felt really smooth with no screen tearing. Keep in mind that if you're near a hub like the Skadovsk or Yanov, you'll experience some CPU related stuttering as the multiple NPC's come on line.
     

  5. Bacab

    Bacab New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    AMD Radeon 7870 2Gb
    Ok thanks, I'll try.
     

Share This Page