1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RadeonPro BETA (Automating 3D Settings)

Discussion in 'Videocards - AMD Radeon Drivers Section' started by japamd, May 20, 2010.

Thread Status:
Not open for further replies.
  1. japamd

    japamd Ancient Guru

    Messages:
    2,448
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970Ghz
    What's the exactly message you got? (the one shown on GetGpuInfo exception window, not the balloon message)
     
  2. deastynova77

    deastynova77 Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    ATI radeon 4770 512MB
    GetGpuInfo exception.Riferimento a un oggetto non impostato su un'istanza di oggetto.
     
  3. japamd

    japamd Ancient Guru

    Messages:
    2,448
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970Ghz
    Thanks. Download the installer again and see if it works now. You'll see more details on error if it's the case (the error message will be copied to clipboard, just paste it here so I can have a look)
     
    Last edited: Sep 11, 2012
  4. PF Prophet

    PF Prophet Master Guru

    Messages:
    232
    Likes Received:
    0
    GPU:
    Zotac 1070 mini/290x
    this dosnt seem to be true with Guild Wars 2 when I check, it appears to be using supertile because AFR causes flicker on some textures(like 2d images of "toons" supertile seems to work fine tho.

    im guessing that AMD's preferred is AFR(as i hear it is for nvidia and sli as well) the sizor mode worked for very few titles and from what I understand is only used in very specific profiles (part of the caps) in cases where other modes didnt work.

    on a side note: is applying changes when game is running broken for anybody else?

    the old version allowed me to do this, the current preview will not apply changes to any game I have tested when the games running.....
     

  5. deastynova77

    deastynova77 Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    ATI radeon 4770 512MB
    GetGpuInfo exception: Riferimento a un oggetto non impostato su un'istanza di oggetto.

    ADL_Main_Control_Create
     
  6. japamd

    japamd Ancient Guru

    Messages:
    2,448
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970Ghz
    A profile isn't made only of AFR, there's other variables that might me missing in order to avoid the flickering. Try Crysis.exe profile and see if it works for GW2.

    How are you applying those changes when game is running? Which settings aren't changing?

    BTW, all D3D tweaks and OSD settings are not changeable after the game starts.

    It's happening at the very beginning... really weird.

    Are you running Win 7 32-bit?
     
  7. vmagic

    vmagic New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970
    Hi there, been following this thread for a little while but am about to take the plunge and try RadeonPro out to see if it can fix some issues I've been seeing in games with my 7970, however I'm just wondering:

    Some games seem to have a problem locking vsync @ 60, namely skyrim, AC:Brotherhood, WoW (if "reduce input lag" is not enabled) does radeonpro have a facility to cap vsync at a specific amount and/or a frame rate limiter inbuilt?
     
  8. PF Prophet

    PF Prophet Master Guru

    Messages:
    232
    Likes Received:
    0
    GPU:
    Zotac 1070 mini/290x
    updated to 12.8's and apply works now for some settings and not others, the OSD never shows up for me in gw2(worked on old build for whatever reason) I only use it for FPS counter, I will try msi afterburner see if its overlay works(in game counter is known to be inaccurate at present)

    as to how i apply changes, rclick the profile and hit "apply profile" this works for most settings now, but some are still non-functional, and some dont kick on no matter what I try(osd/fps counter)
     
  9. deastynova77

    deastynova77 Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    ATI radeon 4770 512MB
    Yes,i'm on windows 7.
    I've found a solution copying the two files atiadlxy.dll and atiadlxx.dll from AMD system monitor to windows\system32\ directory.
    Now it works without error messages.
    Maybe u can add those files in the radeonpro installation program.
     
  10. Mikedogg

    Mikedogg Banned

    Messages:
    2,844
    Likes Received:
    0
    GPU:
    Radeon HD 4650M 1GB
    Another one.

    Assassins Creed 2:
    Oddly enough, Assassins Creed 2 seems to crash on start with "Ati tray Tools v1.7.9.1573" loded into memory.

    Strange.
     

  11. deastynova77

    deastynova77 Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    ATI radeon 4770 512MB
    There's another problem. Radeonpro profiles not working after exit the games.
     
  12. japamd

    japamd Ancient Guru

    Messages:
    2,448
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970Ghz
    Don't have that game, but you can activate debug mode at program settings/advanced and post the debug log so I can have a look at it.

    As I told, OSD/D3D tweaks settings and some other settings can't be applied after the game. Out of curiosity, why do you need to change settings after starting the game?

    Yes, but I found why it wasn't working for you and already fixed it on my working build.

    You should try without ATT on memory (raphook.dll) as it could be interfering with RP hooking engine.

    Can you be more specific? A debug log can help too.
     
  13. Mikedogg

    Mikedogg Banned

    Messages:
    2,844
    Likes Received:
    0
    GPU:
    Radeon HD 4650M 1GB
    Yeah that's what I have been doing. I think there are only like two games out of my lot that interfere with ATT across the board, I just use it for overclocking. So it's not a RadeonPro specific error.

    Also, what are the limitations of "Dynamic Vsync"? There were a few games (along with triple buffering) it wasn't working for last night.
     
    Last edited: Sep 13, 2012
  14. Valken

    Valken Maha Guru

    Messages:
    1,459
    Likes Received:
    74
    GPU:
    Forsa 1060 3GB Temp GPU
    It seems some old games are not hooking with the last few versions of RP:

    Doom 3
    Splinter Cell - first one

    HWINFO64's OSD is working in these but not RP.
     
  15. dox_aus

    dox_aus Master Guru

    Messages:
    301
    Likes Received:
    0
    GPU:
    MSi 290 Gaming CF
    Yeh can confirm original splinter cell doesnt hook (its dx8 yeh cant recall if it did before tho), sc chaos theory crashes after loading after 2d menus with rp active, and sc conviction isnt hooking either. Sc double agent worked fine tho :p
     

  16. deastynova77

    deastynova77 Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    ATI radeon 4770 512MB
    Radenpro profile is working the first time i start a game but when i close the game and start it again the profile is not applied.
    I've to close radeonpro and open it again to apply the profile.
     
    Last edited: Sep 13, 2012
  17. Mr.Joe

    Mr.Joe Master Guru

    Messages:
    287
    Likes Received:
    0
    GPU:
    670DC2-1333/3915-EK~H20
    Can confirm that SMAA does not work at all for me with the latest release, and FXAA only works in some games.

    12.8

    Also find it hard to get automatic vsync to work with crysis...?

    maybe this has already been said at numerous occasions, but if not. there it is. :)
     
  18. Mikedogg

    Mikedogg Banned

    Messages:
    2,844
    Likes Received:
    0
    GPU:
    Radeon HD 4650M 1GB
    SMAA is not properly implemented yet.

    Post logs of the games that FXAA are not working in.
     
  19. japamd

    japamd Ancient Guru

    Messages:
    2,448
    Likes Received:
    0
    GPU:
    AMD Radeon HD 7970Ghz
    DVC needs triple-buffering, if the game doesn't support it natively and RP can't force it at startup, DVC will likely fail to keep framerates inbetween 30~60 fps.

    OpenGL and DX8, both not supported by OSD.

    Chaos Theory is the one before Double Agent?

    See if you have any other type of hook programs installed (i.e. xbox360ce)
     
  20. deastynova77

    deastynova77 Member

    Messages:
    25
    Likes Received:
    0
    GPU:
    ATI radeon 4770 512MB
    Ok, now it works without xbox360ce but i hope u can fix it because i'd like to use my controller.
    No problem with x360ce and previous Radeonpro no beta builds.
    Thanks.
     
Thread Status:
Not open for further replies.

Share This Page