RadeonPro BETA (Automating 3D Settings) #2

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Hilbert Hagedoorn, Jan 8, 2013.

Thread Status:
Not open for further replies.
  1. cap5lock

    cap5lock New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    Red Devil RX480 8GB
    Anyone can get radeonpro to work with Middle-earth: Shadow Of War ?
     
  2. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,004
    Likes Received:
    137
    GPU:
    Sapphire 7970 Quadrobake
    One of the few games you actually don't need it for. It supports frame limiting and various vsync modes by itself.
     
  3. cap5lock

    cap5lock New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    Red Devil RX480 8GB
    Sure,
    I just curious
    Call of Duty : WW2 is also not working with radeonpro
    Even I can get modern game like 'Prey' to work with radeonpro just by deleting some dx11 related dll file in the game folder and tweaking some compatibility settings
     
  4. Skinner

    Skinner Master Guru

    Messages:
    427
    Likes Received:
    20
    GPU:
    2x 2080Ti Sli
    This still works with Vega and W10?
     
    Last edited: Dec 20, 2017

  5. OnnA

    OnnA Ancient Guru

    Messages:
    9,701
    Likes Received:
    2,026
    GPU:
    Vega 64 XTX LiQuiD
    Yes, but not in any game.
     
  6. gtg01

    gtg01 Member

    Messages:
    29
    Likes Received:
    1
    After the spring windows 10 update today, I can't get RadeonPro working any longer because the RadeonPro Support Service will absolutely refuses to start due to expired certificate. I have been pulling my hair out for a couple hours. This my "legacy PC" with a lot of old profiles. Don't wart to start over. Any workaround? Thanks.

    C:\Program Files (x86)\RadeonPro>net start "RadeonPro Support Service"
    System error 2148204801 has occurred.

    A required certificate is not within its validity period when verifying against the current system clock or the timestamp in the signed file.
     
    Last edited: May 17, 2018
    OnnA likes this.
  7. yasamoka

    yasamoka Ancient Guru

    Messages:
    4,728
    Likes Received:
    178
    GPU:
    EVGA GTX 1080Ti SC
    Have you tried shifting back your system clock to an earlier date?
     
    OnnA likes this.
  8. OnnA

    OnnA Ancient Guru

    Messages:
    9,701
    Likes Received:
    2,026
    GPU:
    Vega 64 XTX LiQuiD
    yup, we need to Install new one or bypass this one.
    But how?

    Valid to 2014 lol

    We need to Bypass this in gpedit.msc
     
    Last edited: May 17, 2018
  9. gtg01

    gtg01 Member

    Messages:
    29
    Likes Received:
    1
    Six years later and this is still one of the most useful tools for AMD cards, with no substitute. Why doesn't the author make RadeonPro opensource?
     
  10. gtg01

    gtg01 Member

    Messages:
    29
    Likes Received:
    1
    Yes, you can temporarily change the date to 2013 and then the service will start, but I like OnnA's idea better - of a policy bypass.
     

  11. OnnA

    OnnA Ancient Guru

    Messages:
    9,701
    Likes Received:
    2,026
    GPU:
    Vega 64 XTX LiQuiD
    How to enable RadeonPRO on new Windows 10
    Policy baypass for RadeonPRO

    ---- Some usefull stuff for the future----

    https://blogs.technet.microsoft.com/markrussinovich/2005/04/30/circumventing-group-policy-settings

    https://computerstepbystep.com/group_policy_windows_7.html

    https://gpsearch.azurewebsites.net/#1

    ===
    Please navigate to
    HKEY_CURRENT_USER\Software\Policies\Microsoft\MMC
    and make Restrict_Run registry key

    Make Restrict.REG file and paste this:

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Policies\Microsoft\MMC]
    "RestrictToPermittedSnapins"=dword:00000000
    "Restrict_Run"=dword:00000000

    ===
    [​IMG]

    Double click on Restrict_Run and edit the value:

    To Disable Group Policy:

    Change the data value with 1

    To Enable Group Policy:

    Change the data value with 0

    To finish press ok button and close Registry Editor window
    [​IMG]

    YES it is working now, when you finish Gaming w/RP enable restrict again ;) if needed for Forza...
     
    Last edited: May 17, 2018
  12. mtrai

    mtrai Maha Guru

    Messages:
    1,125
    Likes Received:
    332
    GPU:
    PowerColor RD Vega
    YES it is working now, when you finish Gaming w/RP enable restrict again ;) if needed for Forza...[/QUOTE]

    I do not have anything remotely close to this in my Win 10 1803
     
  13. OnnA

    OnnA Ancient Guru

    Messages:
    9,701
    Likes Received:
    2,026
    GPU:
    Vega 64 XTX LiQuiD
    I do not have anything remotely close to this in my Win 10 1803[/QUOTE]

    Create a Key:
    "Restrict_Run"=dword:00000000

    or make Tweak Reg as i sugested ;)
    It's ON/OFF switch.
     
  14. Agonist

    Agonist Ancient Guru

    Messages:
    2,749
    Likes Received:
    172
    GPU:
    2x RX 480 Nitro 4GB
    RP launches just fine for me. Spring Win 10 update, R9 Fury and newest drivers.

    Great way to use SweetFX on PCSX2 and force 16AF as well.
     
  15. gtg01

    gtg01 Member

    Messages:
    29
    Likes Received:
    1
    Thank you OnnA!!!

    Agonist, I have never been able to get SweetFx working with windows 10, except the Boulotaur2024 sweetfx version, which does not seem to work with RadeonPro. How did you do it?
     

  16. gtg01

    gtg01 Member

    Messages:
    29
    Likes Received:
    1
    OnnA, it is not working for me on Windows 10 Home. I even added the Gpedit functionality to Windows 10, which is working, and the registry keys just like you said, which appear properly. Only the date change works.
     
  17. OnnA

    OnnA Ancient Guru

    Messages:
    9,701
    Likes Received:
    2,026
    GPU:
    Vega 64 XTX LiQuiD
    Install over yours (overwrite, it's CeeJays SweetFX 1.5.1 for RP)

    https://mega.nz/#!5MtCxa5J!HJGrcLnw9W933K2kxOsk_eFhX_D72Gep3Pzv-6ev3mk
     
  18. OnnA

    OnnA Ancient Guru

    Messages:
    9,701
    Likes Received:
    2,026
    GPU:
    Vega 64 XTX LiQuiD
    Really don't know why, bratan'
    Maby you have some Win bloatware ON? (like Win defender)
     
  19. OnnA

    OnnA Ancient Guru

    Messages:
    9,701
    Likes Received:
    2,026
    GPU:
    Vega 64 XTX LiQuiD
    I can't make RP 1.1.0 to work
    1.0.4 working OK but it's 32Bit only lol

    UPD.
    I will wait for Windows10 Update then.
    (stoped working after GPU Upgrade)

    [​IMG]
     
    Last edited: Jul 1, 2018
  20. z8373767

    z8373767 Member Guru

    Messages:
    176
    Likes Received:
    51
    GPU:
    Fury Nitro 1070/600
    It works for me. Win 10 1803.
     
Thread Status:
Not open for further replies.

Share This Page