Radeon VII (Vega 7nm) - Owners Thread, Tests, Mods, BIOS & Tweaks !

Discussion in 'Videocards - AMD Radeon' started by OnnA, Jan 20, 2019.

  1. OnnA

    OnnA Ancient Guru

    Messages:
    9,669
    Likes Received:
    2,016
    GPU:
    Vega 64 XTX LiQuiD
  2. Shadowxaero

    Shadowxaero Master Guru

    Messages:
    200
    Likes Received:
    21
    GPU:
    Radeon VII
    Anyone having Radeon VII core overclock issues on 19.8.1?
     
  3. qpens8

    qpens8 Member

    Messages:
    14
    Likes Received:
    0
    GPU:
    8700gt 512
    Is there a way to softmod this graphic to firepro?
     
  4. Skinner

    Skinner Master Guru

    Messages:
    427
    Likes Received:
    20
    GPU:
    2x 2080Ti Sli
    Shadowxaero, does Battlefield 1 works in multi gpu in dx12?
     

  5. OnnA

    OnnA Ancient Guru

    Messages:
    9,669
    Likes Received:
    2,016
    GPU:
    Vega 64 XTX LiQuiD
  6. OnnA

    OnnA Ancient Guru

    Messages:
    9,669
    Likes Received:
    2,016
    GPU:
    Vega 64 XTX LiQuiD
  7. OnnA

    OnnA Ancient Guru

    Messages:
    9,669
    Likes Received:
    2,016
    GPU:
    Vega 64 XTX LiQuiD
  8. OnnA

    OnnA Ancient Guru

    Messages:
    9,669
    Likes Received:
    2,016
    GPU:
    Vega 64 XTX LiQuiD
     
    Embra likes this.
  9. OnnA

    OnnA Ancient Guru

    Messages:
    9,669
    Likes Received:
    2,016
    GPU:
    Vega 64 XTX LiQuiD


     
    Skinner likes this.
  10. Agent_D

    Agent_D Master Guru

    Messages:
    782
    Likes Received:
    1
    GPU:
    AMD Radeon VII
    I've been having issues with the core clock overclock on my VII for quite some time now. If I leave the GPU at stock 1800, it will do 1770-1790 in 3d applications; if I overclock to my normal 2025/1300, the core clock will drop to 1650-1690 unless I tab out and re-set the overclock, then the clock will jump back up to ~1990-2000 until I change the focus back to the 3d app, then it will drop back down to 1650-1690. I've been experiencing this behavior in all drivers since 19.5.2. Last night I was playing with it on 19.9.2 in BL3 and was able to get the clocks to stick if I tabbed over to MSI Afterburner set the clock, click apply and immediately swap back to the BL3 window, but if I took more than a second to swap back to the BL3 window, the clocks would drop back down.

    I've spent a lot of time trying to figure out how to make it work, but the only solid solution I've had work so far is to run the AMD monitor overlay; I can only assume that works because that overlay seems to count as a window that takes focus off the 3d app, but sometimes I have to toggle it a few times for it to actually work. I've done (and am currently running) soft powerplay tables, tried messing with all other settings both in the Radeon control panel and in Registry with no solid solution or luck. I've been running into these issues on Win 10 1903 and am going to be testing it out on a fresh 1809 install later today to see if maybe it's a 1903 issue instead of an AMD driver/setting issue.
     

  11. Shadowxaero

    Shadowxaero Master Guru

    Messages:
    200
    Likes Received:
    21
    GPU:
    Radeon VII
    That is the EXACT issue I am having except it works for me up until driver 19.7.5. Any driver after that I have the same issues you describe.

    Let me know if rolling back to 1809 makes a difference.
     
  12. Agent_D

    Agent_D Master Guru

    Messages:
    782
    Likes Received:
    1
    GPU:
    AMD Radeon VII
    Well, after some preliminary testing with an 1809 fresh install, the overclock is working like it should. I tested before doing any updates, then again after doing all the 1809 available updates, both times it was able to use and maintain my 2025/1200 overclocks in BL3 and 3D Mark stress tests. I'll keep testing for the next week or so to see if it continues working and update again.

    Edit: This is on 19.9.2 drivers.

    Edit 2: After a day, I've seen the clocks do the 1650-1690MHz drop, but it seems to return to the overclock after a short time with no issue or required tabbing/focus changes. Still not perfect, but better than never changing back to the proper clocks.

    Edit 3: 2 days later, things are back to the way they were. Core clocks won't apply the proper frequency when overclocking and now memory clocks are starting to sit in the 500-700MHz range randomly and won't change until a reboot. As much as I hate to do it, looks like I'm going back to nvidia until AMD can get their driver issues sorted out.
     
    Last edited: Sep 23, 2019
  13. Shadowxaero

    Shadowxaero Master Guru

    Messages:
    200
    Likes Received:
    21
    GPU:
    Radeon VII
    PROGRESS

    So I managed to solve the issue with MorePowerTool 1.1.0. If I set you core overclock in the frequency tab (2100Mhz), the card will boost to 2050ish as it is supposed to. Do not set the memory overclock using MorePowerTool as for some reason it will get stuck at 800Mhz but I was still able to set 1200 in wattman and it ran perfectly.

    It seems there is some bug in the driver that takes effect when ever you change the voltage/frequency slider in wattman or any other tool for that matter.
     
    Skinner, OnnA and Agent_D like this.
  14. Agent_D

    Agent_D Master Guru

    Messages:
    782
    Likes Received:
    1
    GPU:
    AMD Radeon VII
    Worth a shot. I'll give it a try; thanks!

    Edit: Though it's only been a day, so far MPT seems like the solution. I did everything I could to try to get the clocks to drop, but they always returned to the proper overclock when going back to the focused window. I think having the SPPT set to have wattman believe that 2025 is the default clock is the reason it will likely continue to work. Thanks so much for that; I'll keep up with MPT and report any issues I run into.

    Worth noting; I had to import a SPPT into the registry before MPT would pick up any settings. Not really an issue if someone was already messing with SPPT.
     
    Last edited: Sep 24, 2019
  15. OnnA

    OnnA Ancient Guru

    Messages:
    9,669
    Likes Received:
    2,016
    GPU:
    Vega 64 XTX LiQuiD
     
    Skinner likes this.

  16. OnnA

    OnnA Ancient Guru

    Messages:
    9,669
    Likes Received:
    2,016
    GPU:
    Vega 64 XTX LiQuiD
  17. Agent_D

    Agent_D Master Guru

    Messages:
    782
    Likes Received:
    1
    GPU:
    AMD Radeon VII
    Happy to follow up again and say that since using this tool that the OC stays in place in every game no matter the circumstance. Hopefully it continues to do so.
     
  18. OnnA

    OnnA Ancient Guru

    Messages:
    9,669
    Likes Received:
    2,016
    GPU:
    Vega 64 XTX LiQuiD
  19. OnnA

    OnnA Ancient Guru

    Messages:
    9,669
    Likes Received:
    2,016
    GPU:
    Vega 64 XTX LiQuiD
  20. GREGIX

    GREGIX Master Guru

    Messages:
    541
    Likes Received:
    46
    GPU:
    MSI 1080 /AMD v7
    19.3.3. Do not see RIS option anywhere.
    Antilag seems do not working either now but had it on 19.8.1 with w7. Now I'm at w10 1607 LTSB
     

Share This Page