Radeon Software Crimson ReLive Edition 17.4.1 Download & Discussion

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Warkratos, Apr 4, 2017.

  1. godknowswhy

    godknowswhy Member Guru

    Messages:
    132
    Likes Received:
    1
    GPU:
    All sorts
    Thanks for the feedback.... Are you controlling the clocks with a 3rd party utilty... Am i further right in understanding that the UVD clock issue with GCN 1.0 can be.... 2D clock values not returning after 3D application..... and/or UVD clock values stuck in 3D, not returning to 2D values when a 3D application is closed..... Please excuse further questions, just trying to get a handle on the issue and find the general accepted method the guys are using to control the issue.... Thanks.
     
  2. Kruse

    Kruse Active Member

    Messages:
    55
    Likes Received:
    0
    GPU:
    XFX R9 290X 4GB
    I always "clean" install it after a DDU removal, but I reinstalled a second time and it launched without incident. Weird.
     
  3. wuest3nfuchs

    wuest3nfuchs Member

    Messages:
    30
    Likes Received:
    9
    GPU:
    R9 Fury Nitro

    Same here do you get THIS message???

    directx function "findclosestmatchingmode" failed with e_fail

    sry cant post pics atm


    btw used ddu
     
  4. Romulus_ut3

    Romulus_ut3 Master Guru

    Messages:
    670
    Likes Received:
    138
    GPU:
    AMD RX 570 4GB
    The easiest way to trigger the UVD bug is to open a game while having a browser running in the background, at least on GCN 1.0 that's how it works.

    Any DXVA video playback while there's an instance of Chrome running also triggers it 90% of the time.

    The best practices to avoid this bug is to make up the habit of not running browsers and games/videos on media players at the same time.
     

  5. Seren

    Seren Master Guru

    Messages:
    297
    Likes Received:
    16
    GPU:
    Asus Strix RX570
    Well I managed to turn off GPU acceleration in the launcher and no crashes running the game but ingame performance also seems wonky. Will be doing a full re-install of Windows with Creators update so will see how things turn out.
     
  6. godknowswhy

    godknowswhy Member Guru

    Messages:
    132
    Likes Received:
    1
    GPU:
    All sorts
    Thanks for the help.... much appreciated.
     
  7. THEAST

    THEAST Master Guru

    Messages:
    211
    Likes Received:
    18
    GPU:
    HD7950 + HD7970 CF
    Edit: I was wrong, read my new reply here.

    On my HD 7950, the 2D clock is 150/300, the UVD clock is 500/900, the 3D clock is 1000/1250. The clocks get stuck on the UVD values and do not go back to 2D clocks when the GPU is idle. If a 3D game or app is launched, the clocks do go up, but to values lower than the 3D clocks (I think to 900/1250 or something). I am using MSI Afterburner to control my clocks, but you CANNOT fix this issue with Afterburner. The easiest way to fix this is to use the "restart" executable provided in the CRU (Custom Resolution Utility) package to restart the driver without needing to reboot your machine.
     
    Last edited: Apr 7, 2017
  8. godknowswhy

    godknowswhy Member Guru

    Messages:
    132
    Likes Received:
    1
    GPU:
    All sorts


    Thanks for the specs, and the help..... I have clarity now. Very much appreciated. Thankyou.
     
  9. Dennisbest

    Dennisbest Member

    Messages:
    26
    Likes Received:
    0
    GPU:
    Sapphire Radeon 7950
    The only "solution" to the issue , is to flash your bios so that the 3d clocks on UVD state are the same as your normal/overclocked state 3d clocks. Of course this partially fixes the issue because your idle clocks will remain higher but, for me at least, the main issue is the 3d clocks.
     
  10. Dekaohtoura

    Dekaohtoura Master Guru

    Messages:
    284
    Likes Received:
    30
    GPU:
    Sapphire V56 Pulse
    For some unknown reason, the ReLive part refuses to install.

    I click on the install option, the installer informs me that everything went fine and I should restart, but there is no ReLive tab when I open Crimson.

    Same thing happened with the 17.3.3s.

    Followed the exact same steps I've been using for the past years when installing a new driver (DDU included).
     

  11. N0bodyOfTheGoat

    N0bodyOfTheGoat Member Guru

    Messages:
    192
    Likes Received:
    0
    GPU:
    Sapphire Nitro R9 390 8GB
    Whatever was causing this jerky mouse movement just after updating to 17.4.1 has stopped, now back to butter smooth, before I felt the need to check DPS latency.

    I've since updated Windows 10 to RS2 (or whatever the new major build is called) and no issues so far.
     
  12. godknowswhy

    godknowswhy Member Guru

    Messages:
    132
    Likes Received:
    1
    GPU:
    All sorts
    Thanks for that... I was on the verge of asking weather a bios mod to the card might sought the issue out..... something to be weighed up by the user i guess, ie risk of bricking card and needs/application of the card. Thankyou.
     
  13. Undying

    Undying Ancient Guru

    Messages:
    12,044
    Likes Received:
    1,637
    GPU:
    Aorus RX580 XTR 8GB
    Basically if you want to fix UVD bug bios must look like this. There is no other way.

    [​IMG]
     
  14. Dennisbest

    Dennisbest Member

    Messages:
    26
    Likes Received:
    0
    GPU:
    Sapphire Radeon 7950
    Yeah this fixed it entirely , but I am not sure if there are issues with video playback after that.
     
  15. jeff69dini

    jeff69dini Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    evga 2gb gtx 750ti
    for some reason, all these latest "non-whql" drivers always show as whql for me, using creators update, go figure

    [​IMG]
     

  16. AHPD

    AHPD Active Member

    Messages:
    76
    Likes Received:
    0
    GPU:
    R9 Fury Tri-X @4096SP
    Because AMD paid for M$ to sign 17.4.1 display drivers so it is WHQL. AMD have a bad history on mislabeling the drivers. They could use BETA instead.
     
  17. ReaperXL2

    ReaperXL2 Member Guru

    Messages:
    137
    Likes Received:
    10
    GPU:
    Asus R9 390 @ 1133/1645
    Dude, for me all latest 17.x.x betas fail with Forza H3 with the exception of 17.3.1. 17.3.1 works flawlessly for me with Forza H3 (works tiptop with all my games, all current AAA titles)... 17.2.1 works great too (whql) but 17.3.1 outperforms it hands down...

    I am running Creators Update 'Gaming mode' on, fully updated...

    Funny thing is, I seem to get better gaming performance with 'Game mode' disabled... MS tech?, focused improvements in gaming? go figure :p

    Just thought I would share my experience so far with this driver...

    Peace peeps :thumbup:
     
    Last edited: Apr 7, 2017
  18. THEAST

    THEAST Master Guru

    Messages:
    211
    Likes Received:
    18
    GPU:
    HD7950 + HD7970 CF
    I didn't get the chance to update my previous reply earlier but I spoke too soon. This driver is completely broken on my system. Trying to reboot/shutdown the machine or closing MSI Afterburner after it has been loaded results in a THREAD_STUCK_IN_DRIVER BSOD right away and is 100% reproducible; this driver certainly has issues with Afterburner on GCN v1.0 and I am pretty sure it is because GCN v1.0 has also been moved to Wattman now. Also every time after reboot due to BSOD, I get the "Default Radeon WattMan settings have been restored due to unexpected system failure" even though I never even enabled or used Wattman.

    After uninstalling the driver I tried to install 17.3.3 but it completely refused to install on my machine. Then I tried to install 17.3.1 which I was using before and it seemed to install but after reboot, the OS gave me the repair screen regardless of how many times I shutdown or rebooted the machine. Eventually I was forced to do a system restore and reinstall 17.3.1 and go back to square one.

    Props to AMD for this nice evening. :bang:
     
  19. jeff69dini

    jeff69dini Member

    Messages:
    31
    Likes Received:
    0
    GPU:
    evga 2gb gtx 750ti
    well the past few non-whql drivers, actually says nonwhql in the filename, have been fully whql for me, just thought it was weird when filename says they are not but in fact they are! 17.3.1, 17.3.2, 17.3.3 all whql here
     
  20. kondziowy

    kondziowy Active Member

    Messages:
    74
    Likes Received:
    34
    GPU:
    RX Vega 64 Nitro LE
    I get those two when I undrevolt my gpu, and blue screen STUCK_IN_DRIVER when undervolted way too much. Maybe "stay calm and raise Vcore" ? :D
    But better don't touch afterburner, it's broken since forever.

    I actually thought they are dropping 2011 GCN 1.0. But no, it gets wattman, and async compute was restored.
     
    Last edited: Apr 7, 2017

Share This Page