Radeon Software Crimson ReLive Edition 17.4.1 Download & Discussion

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Warkratos, Apr 4, 2017.

  1. KissSh0t

    KissSh0t Ancient Guru

    Messages:
    7,108
    Likes Received:
    1,434
    GPU:
    ASUS RX 470 Strix
    They are here for me... it installed without any problems, everything ok so far *crosses fingers*

    [​IMG]

    [​IMG]

    [​IMG]
     
    Last edited: Apr 5, 2017
  2. Warkratos

    Warkratos Active Member

    Messages:
    64
    Likes Received:
    18
    GPU:
    GTX 1060 6Gb
    Anyone tried Overwatch with these drivers? I'm getting frametime spikes making the game unplayable for me.

    Edit: nvm, reinstalled using DDU and now is all good.
     
    Last edited: Apr 5, 2017
  3. wotan

    wotan Member

    Messages:
    33
    Likes Received:
    3
    GPU:
    PowerColor R9 390Pcs+8GB
    I hope this Driver works with Forza H3 ..the Last one not works :-(
     
  4. THEAST

    THEAST Master Guru

    Messages:
    211
    Likes Received:
    18
    GPU:
    HD7950 + HD7970 CF
    Damn, this means that GCN v1.0 cards are also going to be incompatible with Afterburner from now on until AMD fixes their broken API, which is probably not going to happen any time soon. Anybody tried Afterburner with this driver yet?

    Yes, this is the same thing as what has been happening on the 2xx and 3xx cards since they were moved to Wattman.

    Not surprising at all.

    Good thing is, apparently they fixed the EDID override "bug" and CRU works fine now.
     

  5. OnnA

    OnnA Ancient Guru

    Messages:
    9,679
    Likes Received:
    2,019
    GPU:
    Vega 64 XTX LiQuiD
    CRU is working with this one, and Forza 3 takes ~1min to load ! (was 12sec)
    I've deleted Crimson Shader Cache, i will see if this helps.

    Besides that Drivers seems OK, Fast and Stable so far.... time will tell :nerd:

    UPD.1
    DOOM Vulkan = OK
    Xcom 2 = OK
    Forza 3 = OK (but long first load)
    HoMM VII = OK
    ...
     
    Last edited: Apr 5, 2017
  6. Rambo

    Rambo Master Guru

    Messages:
    266
    Likes Received:
    115
    GPU:
    RX 560 w8 4 Vega 56
    DX12 API Overhead still crashes but I got ~20% more in DX11 MT. Retested a few times and boost was still there :banana:
     
  7. wotan

    wotan Member

    Messages:
    33
    Likes Received:
    3
    GPU:
    PowerColor R9 390Pcs+8GB
    Good to know..i will test it later thx for the Info @OnnA
     
  8. Shadowxaero

    Shadowxaero Master Guru

    Messages:
    200
    Likes Received:
    21
    GPU:
    Radeon VII
    Hmmm anyone with Crossfire Fury's crashing in all Dx11 titles?
     
  9. BoMbY

    BoMbY Member Guru

    Messages:
    185
    Likes Received:
    0
    GPU:
    Fury X
    I got almost 20% less with 17.4.1 since the last run, but I guess that may also be the new 3DMark version.
     
  10. mtrai

    mtrai Maha Guru

    Messages:
    1,125
    Likes Received:
    332
    GPU:
    PowerColor RD Vega
    Anyone want me to test anything on this HD 7770 I have flashed to a R7 250X, wile i am in Limbo with yet another RMA.

    RMA was approved yesterday, shipping it off today.
     

  11. N0bodyOfTheGoat

    N0bodyOfTheGoat Member Guru

    Messages:
    192
    Likes Received:
    0
    GPU:
    Sapphire Nitro R9 390 8GB
    Anyone else finding mouse cursor movement very jerky with this driver? I swear it has for me since doing an "express upgrade" this morning.
     
  12. gadmin

    gadmin Active Member

    Messages:
    59
    Likes Received:
    2
    GPU:
    Palit 1080ti GRock
    What about disable...wait...enable display adapter from device manager :)
     
  13. jeff69dini

    jeff69dini Member

    Messages:
    29
    Likes Received:
    0
    GPU:
    evga 2gb gtx 750ti
    can I ask how did you flash the hd7770? as I have an msi 1 gb hd7770
     
  14. mtrai

    mtrai Maha Guru

    Messages:
    1,125
    Likes Received:
    332
    GPU:
    PowerColor RD Vega


    I just did it cause I have 2 of these cards laying around that I had not been using.

    Verify that your card has both an identical version of the HD 7770 and R7 250X

    Get bios. It does have to match vram size and manufacturer. Remember these do not have a dual bios switch, so you can brick it if you mess up. I would not recommend it. Actually no performance gain.

    Flash

    I used ATIwinflash 2.74

    Link to bios : https://www.techpowerup.com/vgabios/169638/169638

    USE AT YOUR OWN RISK. I TAKE NO RESPONSIBILITY.
     
    Last edited: Apr 5, 2017
  15. ReaperXL2

    ReaperXL2 Member Guru

    Messages:
    137
    Likes Received:
    10
    GPU:
    Asus R9 390 @ 1133/1645

    Dudes, for me, Forza H3 takes over 5 minutes to load after optimizing for 17.4.1.

    Once I am at festival front end, the whole background is covered with what looks like permanent camera flashes/giant snowflakes & black dot artifacts...

    Actual driving/racing renders without issue that I can tell/see...

    If I can cope with the slooooooow initial loading & dodgy front end rendering, then game is golden performance wise...

    Thought I would give you a heads-up on possible hardware configurations giving issues with this driver...

    Peace peeps :thumbup:
     

  16. jeff69dini

    jeff69dini Member

    Messages:
    29
    Likes Received:
    0
    GPU:
    evga 2gb gtx 750ti
    thanks! looks like exactly what I have :)

    yeah everything went ok, hmm, guess no difference anyways hmm, still shows as hd 7770 series, but different vbios now, haha
     
    Last edited: Apr 5, 2017
  17. mtrai

    mtrai Maha Guru

    Messages:
    1,125
    Likes Received:
    332
    GPU:
    PowerColor RD Vega
    Odd mine shows R7 200 series in device manager, gou-z and dxdiag lol
     
  18. Shadowxaero

    Shadowxaero Master Guru

    Messages:
    200
    Likes Received:
    21
    GPU:
    Radeon VII
    So just me?
     
  19. Seren

    Seren Master Guru

    Messages:
    293
    Likes Received:
    16
    GPU:
    Asus Strix RX570
    Crap driver, instant blue screen when opening the Warframe launcher.
     
  20. miiksu

    miiksu Member Guru

    Messages:
    136
    Likes Received:
    0
    GPU:
    XFX R9 Nano
    ESO flickering fixed :banana:
     

Share This Page