Radeon Software Crimson ReLive 17.11.1 driver Download & Discussion

Discussion in 'Videocards - AMD Radeon Drivers Section' started by JonasBeckman, Nov 3, 2017.

  1. d0X

    d0X Member Guru

    Messages:
    190
    Likes Received:
    11
    GPU:
    MSI RTX2070S Ventus
    @Grimbarian nope, I'm having the same problem ever since they introduced that switch.
     
    Grimbarian likes this.
  2. Grimbarian

    Grimbarian Ancient Guru

    Messages:
    1,772
    Likes Received:
    383
    GPU:
    AMD RX5700 8gb
    Good to know thanks :) Returning to 17.9.3 was pointless as there's no workload switch now!
     
  3. warlord

    warlord Ancient Guru

    Messages:
    2,761
    Likes Received:
    927
    GPU:
    Null
    Nov 16, 2017

    Sorry, something went wrong.

    Still error in site. Still old drivers masked as new WHQL. We love lying red. OMG. Raja Koduri departed and they are sinking for real. I do not troll. It worries me this situation. Are they alive? Anyway, these baked whqls are not bad but, we need official public links, not magical hotlinks.
     
  4. Evildead666

    Evildead666 Maha Guru

    Messages:
    1,306
    Likes Received:
    275
    GPU:
    Vega64/EKWB/Noctua
    Maybe you should check your side of the problem before blaming AMD ?
    Its fine for me. No problems whatsoever.

    I'm downloading the WHQL from the EN-US site now.
     
    Grimbarian likes this.

  5. warlord

    warlord Ancient Guru

    Messages:
    2,761
    Likes Received:
    927
    GPU:
    Null
    I'm not the only one. Should we change countries or ISPs because they are not professionals? They should get closed if they cannot even maintain a web page! It is pathetic I cannot format because they do not provide drivers for days. OMG.
     
  6. MerolaC

    MerolaC Ancient Guru

    Messages:
    3,599
    Likes Received:
    432
    GPU:
    MSI 5600XT G. MX
    Try doing Control + F5 refresh or clean cache and cookies on your browser.
    The page was loading just fine for me too.
     
    warlord likes this.
  7. warlord

    warlord Ancient Guru

    Messages:
    2,761
    Likes Received:
    927
    GPU:
    Null
    [​IMG]

    I tried everything. Edge, Chrome, Firefox, reset modem, used Ccleaner for everything, for 4 days drivers section is a no go. I am so sad. We are talking about incorporation here, not some local bakery.
     
  8. TheDukeSD

    TheDukeSD Member Guru

    Messages:
    145
    Likes Received:
    11
    GPU:
    MSI GT 1030 2GH OC
    If I search for a driver for win 7 x64 and HD 7750 I also get the nice: Sorry, something went wrong.
    [​IMG]

    In does the same in Vivaldi and Firefox, firefox is set to not keep history and the cache size is set to 0 MB, Vivaldi is always run in incognito mode (clear history/cache does nothing, ctrl + f5 does nothing).

    Even the links for Windows drivers from Latest AMD Drivers and Software give me the same Sorry, something went wrong. The Linux links from the same section work.

    L.E.: Don't get me wrong I don't really care what's happening with AMD site. My main pc is Intel/Nvidia and I doubt the gcn 1.0 uvd bug will be fixed in newer drivers, sapphire support basicaly resent me the uefi bios that I already had from them when I asked for a new one. The hd 7750 is in my old pc that is more or less not used atm...

    L.E. 2: IE 11 (that I never use) show the same nice Sorry, something went wrong.
     
    Last edited: Nov 16, 2017
  9. Evildead666

    Evildead666 Maha Guru

    Messages:
    1,306
    Likes Received:
    275
    GPU:
    Vega64/EKWB/Noctua
    Some other people are having problems, does not automatically make it AMD's page at fault.

    What driver, and for what OS are you looking for, and if in another country than EN-US, which one ? (just so I can test your exact request).

    If it works for some of us, and not you, that means that their webpage is working for us. So its not neccesarily AMD.
    You know, there is this thing called "The Internet" between you and AMD, and there is a shitload of hops.....blame them.
     
  10. MerolaC

    MerolaC Ancient Guru

    Messages:
    3,599
    Likes Received:
    432
    GPU:
    MSI 5600XT G. MX

  11. Evildead666

    Evildead666 Maha Guru

    Messages:
    1,306
    Likes Received:
    275
    GPU:
    Vega64/EKWB/Noctua
    I just searched the AMD EN-US site, and chose Radeon HD 7700 series, then Win 7 x64, and got this page :
    http://support.amd.com/en-us/download/desktop?os=Windows 7 - 64

    Which is the 17.11.1 driver download page. No errors at all.

    edit : its changed the link, it should be : http:// support.amd.com/en-us/download/desktop?os=Windows%207%20-%2064 (delete the space after the http:// )
     
  12. TheDukeSD

    TheDukeSD Member Guru

    Messages:
    145
    Likes Received:
    11
    GPU:
    MSI GT 1030 2GH OC
    I still get the Sorry, something went wrong. message even when using the %20 in place of " ", firefox and vivaldi aparently don't show the %20 and convert it to " ", but ie 11 show the %20 and still give the same error.

    Can you do a ping on support.amd.com and tell me what ip is being reported?

    For me support.amd.com is resolved as 2.17.116.108 .

    4 ms ping on support.amd.com , this is clearly a mirror located in my country.

    L.E.: ISP dns, google dns and opendns all resolve support.amd.com as 2.17.116.108 and I basicaly need 5 hops to get to it.
    Most likely I'm being sent to a mirror that hasn't been syncronized yet or it's just bugged...
     
    Last edited: Nov 16, 2017
  13. Lumaan

    Lumaan Member

    Messages:
    39
    Likes Received:
    0
    GPU:
    Asus R9 290X 4GB OC
    I live in EU and get the "Sorry, something went wrong"
    When I use "StrongVPN" client for US it's working, no error.
     
    Last edited: Nov 16, 2017
  14. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,486
    Likes Received:
    2,878
    GPU:
    MSI 6800 "Vanilla"
    http://support.amd.com/en-us/download/desktop?os=Windows+10+-+64
    (Or depending on how this website displays it Windows[PLUS]10[PLUS_MINUS_PLUS]64 )

    That's what I'm using, alternatively http://support.amd.com/en-us/kb-art...son-ReLive-Edition-17.11.1-Release-Notes.aspx and then just changing the numbers every couple of days to see if something's happening.
    Still nothing for 17.11.2 thus far, keeps alternating between directing to the usual "Not found" page and not loading at all, guessing something might be up with the AMD website since that's been happening since shortly after the 17.11.1 drivers released.
     
  15. TheDukeSD

    TheDukeSD Member Guru

    Messages:
    145
    Likes Received:
    11
    GPU:
    MSI GT 1030 2GH OC
    "Sorry, something went wrong" message looks to be fixed for me. (I did nothing, it just fixed itself.)
    Now it properly shows the available drivers
     

  16. kondziowy

    kondziowy Active Member

    Messages:
    93
    Likes Received:
    48
    GPU:
    RX Vega 64 Nitro LE
    Yesterday it was working and today "Something went wrong" again.

    AMD is shutting Radeon brand down, or new sick yearly update is comming with a new webpage and drivers. Fingers crossed.
     
  17. LocoDiceGR

    LocoDiceGR Ancient Guru

    Messages:
    2,363
    Likes Received:
    820
    GPU:
    Gigabyte 3060 Ti
    ''Glad that it's improving/working for some... There was indeed an outage this weekend that is still causing issues. While they expect it to improve throughout today, it may not be fully resolved until this evening or tomorrow morning.''

    Ok guys you can relax now.
     
  18. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,928
    Likes Received:
    518
    GPU:
    Nitro 5700 XT
    The website looks different now. Fury drivers are now to the left of the webpage instead of the right side.
     
  19. MiMiK

    MiMiK Master Guru

    Messages:
    216
    Likes Received:
    3
    GPU:
    nVidia 7600GT
    i still dont get any drivers showing up [chrome or firefox], im in the US
     
  20. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,486
    Likes Received:
    2,878
    GPU:
    MSI 6800 "Vanilla"
    17.11.2's page now shows as 401: Unauthorized so something's finally happening. :)
    http://support.amd.com/en-us/kb-art...son-ReLive-Edition-17.11.2-Release-Notes.aspx

    A few more hours perhaps, can be hard to tell though for this timezone over in Sweden it tends to be close to or a bit after midnight so installation is usually the day after unless the driver happens to be released a bit early.


    EDIT: Oh that doesn't really say much I guess, GMT+1 being the time zone used here or to take the current time directly it's 21:25 now so it's starting to get a bit late but hopefully the driver will be released sooner rather than later.
    Nothing to do but wait and see. Would be nice with a release that's a little bit earlier than usual though.
     
    Last edited: Nov 16, 2017
    Jackalito, LocoDiceGR and warlord like this.

Share This Page