Radeon Software Crimson ReLive 17.11.1 driver Download & Discussion

Discussion in 'Videocards - AMD Radeon Drivers Section' started by JonasBeckman, Nov 3, 2017.

  1. OnnA

    OnnA Ancient Guru

    Messages:
    13,486
    Likes Received:
    3,435
    GPU:
    3080Ti VISION OC
    17.11.2 should be avaible later upd. this week :D
    With some additional fixes for Fiji/Tonga/Hawaii etc.
    also Fix for FH3/FM7 and more....
     
    Last edited: Nov 7, 2017
  2. LocoDiceGR

    LocoDiceGR Ancient Guru

    Messages:
    2,390
    Likes Received:
    832
    GPU:
    Gigabyte 3060 Ti
    How do you know?:confused:
     
  3. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,502
    Likes Received:
    2,891
    GPU:
    MSI 6800 "Vanilla"
    AMD tends to have their website pop a 500-forbidden error before a new driver comes online, 17.11.2 unless they change the naming of the URL still shows as 404 not found but there's still another six to eight hours before they tend to be released so that doesn't mean much for now.

    http://support.amd.com/en-us/kb-art...son-ReLive-Edition-17.11.2-Release-Notes.aspx

    It's usually Wednesdays though unless it's a critical driver update and tomorrow should be patch Tuesday or no that's next week for Microsoft and general updates for the OS including those monthly cumulative packs, hopefully some good fixes for RS3 comes from that. :)

    Anyways guess we'll see in a few hours of 17.11.2 shows any signs of getting released unless AMD had someone on Twitter or Reddit again ha ha.
     
    LocoDiceGR likes this.
  4. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,981
    Likes Received:
    546
    GPU:
    Nitro 5700 XT
    Can't wait if true!
     
    Last edited: Nov 7, 2017

  5. LocoDiceGR

    LocoDiceGR Ancient Guru

    Messages:
    2,390
    Likes Received:
    832
    GPU:
    Gigabyte 3060 Ti
    Big driver next month.
     
  6. OnnA

    OnnA Ancient Guru

    Messages:
    13,486
    Likes Received:
    3,435
    GPU:
    3080Ti VISION OC
    Finally we will have some fixes for FH3....
    IMO JonasBeckman has some point on when we get this 17.11.2
     
  7. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,502
    Likes Received:
    2,891
    GPU:
    MSI 6800 "Vanilla"
    Well December tends to be the big one for AMD, hopefully there's some good fixes too in addition to whatever they're introducing with 17.12.1 :)

    Getting all the Vega GPU features ready would be nice for one thing but there's other issues too but who knows how much AMD will spend on fixing issues for earlier GPU's though when they force everyone to use Wattman and the new overclock feature they should also ensure it's working reliably regardless of if it's first-gen GCN or fourth-gen GCN.

    CNext is also a bit unstable lately though in comparison it's a fairly minor issue, game wise well Overwatch seems to be a big problem for AMD and newer drivers and something is holding up getting that fixed.
    I don't use ReLive myself but there's probably room for improvement there too, overall gains for DirectX 11 and lower and OpenGL could probably improve as well but AMD is likely forward focused on Vulkan and DX12 even if adaption isn't very high at the moment.


    EDIT: But it's all speculation really, who knows what the next driver will look like whether it's 17.11.2 or 17.12.1 :)
    (Well November is just beginning and with games such as Battlefront 2 and Need for Speed 2017 there's room for a 17.11.2 driver.)
     
    wuest3nfuchs, Jackalito, OnnA and 2 others like this.
  8. mikeysg

    mikeysg Ancient Guru

    Messages:
    2,837
    Likes Received:
    412
    GPU:
    Nitro+ RX 6900 XT
    Weird thing happened when I'd installed 17.11.1 on my i7 2600K + HD7970 rig, I keep getting a message that there was no AMD hardware, scratched my head and uninstalled it. Installed 17.10.3 and everything seemed alright, played Doom with Vulkan and it was gold, then I tried some DX9 games like UT3, HL2, and Dead Space.......all resulted with some error message about DX has stopped working......I was like, 'Huh?!'

    First time in a long while now, I've never had any issue with AMD drivers till now. Decided to install WHQL 17.9.3 and all is right with the world again. Such a weird issue....
     
  9. OnnA

    OnnA Ancient Guru

    Messages:
    13,486
    Likes Received:
    3,435
    GPU:
    3080Ti VISION OC
    ATI/AMD need time to proper Infuse new WDDM 2.3 Features for all of us :D
    For Vega? 17.11.1
    Older GPUs? 17.9.3 WHQL
     
    mikeysg likes this.
  10. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,981
    Likes Received:
    546
    GPU:
    Nitro 5700 XT
    Heads up, if you want to uninstall future drivers DO NOT remove the AMD folder. You know, that AMD folder that is created every time you extract drivers.
    If you have 10 driver version in there make it 11 until you know that you've successfully uninstalled your current drivers and you are seeing 17.7.1 or MS Basic Display.

    Also, if you attempt to install a new driver and at the start of the install process you see a windowed title showing you your old driver to the left and new ones to the right you didn't properly uninstall the old drivers. Unless you intentionally did that.


    Yeah I know.
     

  11. LocoDiceGR

    LocoDiceGR Ancient Guru

    Messages:
    2,390
    Likes Received:
    832
    GPU:
    Gigabyte 3060 Ti

    I use DDU and tick to remove the amd folder...never had problems.
     
  12. Tiko82

    Tiko82 Member

    Messages:
    13
    Likes Received:
    1
    GPU:
    AMD R5 M430 2Gb
    Guys, there is a question, There is a laptop with two video APU AMD_R4 and discrete AMD_R5_M430. On 17.7.2 everything works, and on 17.11.1 beta, Mail and Maps and games off after launch. Googled and through the utilities dxcpl included for these applications and games Force WARP and they earned. What is the trick here? and what is this Force WARP?
     
    Last edited: Nov 7, 2017
  13. LocoDiceGR

    LocoDiceGR Ancient Guru

    Messages:
    2,390
    Likes Received:
    832
    GPU:
    Gigabyte 3060 Ti
    Slow down...firewood? wood? :eek::eek:
     
  14. circeseye

    circeseye Master Guru

    Messages:
    273
    Likes Received:
    10
    GPU:
    Sapphire NITRO+590
    has anyone else had this driver install 6 or more hdmi audio devices? i never install the hdmi dirvers but it did anyway
    it installed 8 on mine. and took me forever to figure out why i was bluescreening and crashing. but was fixed once i found what the driver installed and removed all of them.
    i posted this in the older driver by accident
     
  15. OnnA

    OnnA Ancient Guru

    Messages:
    13,486
    Likes Received:
    3,435
    GPU:
    3080Ti VISION OC
    It installs 16GPUs for me ;) -> Just stick to 17.9.3 WHQL
     

  16. mikeysg

    mikeysg Ancient Guru

    Messages:
    2,837
    Likes Received:
    412
    GPU:
    Nitro+ RX 6900 XT
    That sorta clear things up, gonna stick with 17.9.3 for a while.....
     
  17. Alessio1989

    Alessio1989 Ancient Guru

    Messages:
    2,100
    Likes Received:
    627
    GPU:
    .
    - SM 6.1 format (actually still experimental for all IHVs)
    - Minor D3D12 API changes
    - Minor DXGI 1.6 improvements (like updated support for Rec2020 and rec709 on Gamma 2.4)
     
    OnnA and Krteq like this.
  18. OnnA

    OnnA Ancient Guru

    Messages:
    13,486
    Likes Received:
    3,435
    GPU:
    3080Ti VISION OC
    Im really into SM 6.0 Game :D -> The visual immersion of true DX12/Vulcan can be what we are waiting for ;)
    - (8 Years of SM5 is enough IMO) -
     
    wuest3nfuchs and z8373767 like this.
  19. Dr451

    Dr451 Active Member

    Messages:
    87
    Likes Received:
    4
    GPU:
    Gigabyte AMD R9 270X 2GB
    AMD Mantle work on latest drivers?
     
  20. Meccs

    Meccs Active Member

    Messages:
    72
    Likes Received:
    1
    GPU:
    Radeon RX 480 GAMING X 8G
    Using Youtube with Firefox (Nightly and Beta) gets my GPU usage (RX 480) to 100% and it never comes back again until I sign out or restart. Not sure if this is a YT, Firefox or driver problem but I can replicate it... it alway happens.
     

Share This Page