Radeon Software Crimson Edition 16.8.3 Download & Discussion

Discussion in 'Videocards - AMD Radeon Drivers Section' started by realmadrid, Aug 31, 2016.

  1. realmadrid

    realmadrid Member Guru

    Messages:
    177
    Likes Received:
    0
    GPU:
    GTX 1050 TI MSI OC
    Radeon Software Crimson Edition 16.8.3 Release Notes


    Radeon Software Crimson Edition is AMD's revolutionary new graphics software that delivers redesigned functionality, supercharged graphics performance, remarkable new features, and innovation that redefines the overall user experience. Every Radeon Software release strives to deliver new features, better performance and stability improvements.
    Radeon Software Crimson Edition 16.8.3 Highlights

    New AMD CrossFire profile added for DirectX® 11:
    Deus Ex™: Mankind Divided
    Battlefield™ 1 Beta

    Fixed Issues
    A random blank or colored screen may be experienced intermittently on some Radeon RX 400 series products while gaming.

    Known Issues
    A few game titles may fail to launch or crash if the AMD Gaming Evolved overlay is enabled. A temporary workaround is to disable the AMD Gaming Evolved "In Game Overlay".
    Radeon Software may intermittently fail to install or hang on some AMD CrossFire configurations. If this happens users can reboot and re-install without issue as a workaround.
    Grand Theft Auto V™ may experience an application hang on Radeon RX 400 Series Graphics when playing at 4K resolution in story mode.
    A small number of 144hz non-FreeSync enabled displays may exhibit flickering during gaming or on desktop.
    Ark Survival Evolved™ may experience an error message when trying to launch the game in some configurations.
    DOTA2™ may experience an application hang when using the Vulkan™ API and changing resolution or game/quality settings.
    Corruption may be experienced in Rise of the Tomb Raider using the DirectX®12 API on some Hybrid Graphics configurations when performing a task switch.
    Shader Cache may remain be enabled when set to "off" in Radeon Settings on some Hybrid Graphics configurations.
    Radeon RX 480 graphics may experience intermittent stuttering in The Division™ when high game settings are used and vsync is enabled.
    Battlefield™ 4 may experience intermittent crashes when using Mantle. As a work around users are suggested to switch to DirectX®11.
    Radeon Pro Duo may experience a black screen in Total War™: Warhammer with the games API set to DirectX®12 and V-Sync enabled.
    World of Tanks™ may experience stuttering after performing a task switch in AMD CrossFire mode.
    Rocket League™ may experience flickering when in AMD CrossFire mode.
    Ashes of the Singularity™ may experience an application crash with "crazy" in game settings and Multi-GPU enabled.
    Package Contents
    The Radeon Software Crimson Edition 16.8.3 installation package contains the following:
    Radeon Software Crimson Edition 16.8.3 Driver Version 16.30.2511.1003.

    http://www.guru3d.com/files-details/amd-radeon-software-crimson-16-8-3-driver-download.html
     
    Last edited: Aug 31, 2016
  2. s0x

    s0x Member Guru

    Messages:
    137
    Likes Received:
    1
    GPU:
    MSI RX 480 Gaming X 8G
  3. passenger

    passenger Master Guru

    Messages:
    437
    Likes Received:
    75
    GPU:
    Sapphire RX580 8GB
    Thanks men, will test them tomorrow.
     
  4. AlleyViper

    AlleyViper Master Guru

    Messages:
    482
    Likes Received:
    70
    GPU:
    Strix 2070S A|480 X
    Idle clocks bug on 7970 :\
     

  5. THEAST

    THEAST Master Guru

    Messages:
    217
    Likes Received:
    22
    GPU:
    GTX 1080
    Was anybody actually experiencing this that they have fixed it now? I have seen at least 10 people in this board alone, including myself, who are experiencing the clock bug with 79XX/280 cards and this is not even acknowledged in this driver; yet I don't remember seeing anybody reporting the issue mentioned in the changelog...
     
  6. primetime^

    primetime^ Master Guru

    Messages:
    908
    Likes Received:
    17
    GPU:
    Sapphire RX Vega 64
    the clock bug where it drops to UVD speed (850mhz) all of a sudden for NO ****ING REASON and fps drops to 40 because of it lol. Im so ****ing pissed....up till now the drivers have been great for this card...How they **** up cards this old?:bang:
    I thought UVD for for like playing videos and stuff...Why the GD driver clock down in the middle of a game?

    Im very much interested in if someone has found a work around or something to this issue....games dont play very good at 850mhz:bang: Near as i can tell clock blocker and radeon mod have no effect on correcting this bug either..really sucks!

    I cant speak for others but i have indeed reported it as a driver bug to AMD.
     
    Last edited: Sep 1, 2016
  7. Undying

    Undying Ancient Guru

    Messages:
    16,636
    Likes Received:
    5,547
    GPU:
    Aorus RX580 XTR 8GB
    Idk, primetime i just played BF1 with a new driver, 1165mhz the whole game. I've never seen any drop in core clock. Idle clocks also 150/300 it isnt stuck in 500/1250. Can any other Tahiti owners report their experience?

    I didnt see any flickering in BF1 with this driver, compared to yesterday with 16.8.2. Game also seems smoother, no stuttering on my part.

    One more thing, primetime. When you are flashing your bios, UVD isnt supposed to be set at lower clock (old Pill Monster trick)

    It should look like this (my bios) :

    [​IMG][​IMG]
     
    Last edited: Sep 1, 2016
  8. Garwinski

    Garwinski Member Guru

    Messages:
    185
    Likes Received:
    4
    GPU:
    XFX Fury X
    For some reason with Battlefield 1, with crossfire I have lower than 30 fps with this driver, while when using only 1GPU yesterday with 16.7 or something, I got mostly around 50 fps. Both my gpus have steady 3d clocks and gpu usage on both cards is around 60%, so it would seem that I should be having higher fps as more of my pc is being used, or at least not lower fps, but it is not the case.

    EDIT: From ultra to medium, I have around 25 fps, when I set the preset to Low, I get around 40fps. Strange that that is the only setting that impacts performance noticeably.That 40fps is still lower than the 50fps on preset High which I got yesterday though. Nothing is maxed out in terms of usage(CPU, RAM, GPU, SSD).
     
    Last edited: Sep 1, 2016
  9. realmadrid

    realmadrid Member Guru

    Messages:
    177
    Likes Received:
    0
    GPU:
    GTX 1050 TI MSI OC


    it work thank you no more damn bug clock :banana:

    [​IMG]

    [​IMG]

    [​IMG]
     
  10. edilsonj

    edilsonj Active Member

    Messages:
    53
    Likes Received:
    1
    GPU:
    Gigabyte RTX 2060 S
    Thanks.

    Another round to DX12 crossfire or SLI support.
     

  11. go4brendon

    go4brendon Member Guru

    Messages:
    150
    Likes Received:
    16
    GPU:
    MSI 1080Ti Seahawk X
    Been waiting for this yay ty
     
  12. OnnA

    OnnA Ancient Guru

    Messages:
    13,677
    Likes Received:
    3,518
    GPU:
    3080Ti VISION OC
    New Driver working OK so far :)
     
  13. cod6da

    cod6da Member

    Messages:
    37
    Likes Received:
    0
    GPU:
    powercolor rx 480 8gb
    need new driver for de md
     
  14. The Mac

    The Mac Ancient Guru

    Messages:
    4,404
    Likes Received:
    0
    GPU:
    Sapphire R9-290 Vapor-X
    ?


    New AMD CrossFire profile added for DirectX® 11:
    Deus Ex™: Mankind Divided
    Battlefield™ 1 Beta
     
  15. primetime^

    primetime^ Master Guru

    Messages:
    908
    Likes Received:
    17
    GPU:
    Sapphire RX Vega 64
    Have you tried the dx12 path as well? usually i can tell the clocks are triggering UVD when the fps number turns red lol. I will try modifying the bios...but i already tried it once last night. It sort of worked except the gpu voltage was not jumping up like it normally would...and would ctd every time i would start the game. I flashed it back and it was working fine again until the UVD throttle hit me again.

    Heres the thing. I suspect its the xbox dvr app triggering the power saving. Seems like the clock bug always gets triggered when taking a screenshot or starting video dvr almost every time. The bad thing is i think the clock bug triggers a few times even when i didnt take a screenshot, but i could have accidentally hit windows/G unintentionally.
     

  16. PrMinisterGR

    PrMinisterGR Ancient Guru

    Messages:
    7,889
    Likes Received:
    755
    GPU:
    Inno3D RTX 3090
    Another issue is that the card won't drop clocks UNDER 501/1500 either. For me the card clocks correctly in game (my vbios is like Undying showed), but it will not clock down to 300/150. I have to restart the pc or reset the driver using RadeonMod, for it to behave correctly.

    I wonder if we all get the same bug, just with different manifestations due to different boards/bios revisions.

    I have also created a thread in the official AMD community forums about it. AMD doesn't seem to care about this forum any more, but if all of us post in their community they have to at least take a look.

    https://community.amd.com/message/2745858
     
  17. Yxskaft

    Yxskaft Maha Guru

    Messages:
    1,480
    Likes Received:
    119
    GPU:
    GTX Titan Sli
    Has anyone tried Battlefield 1 with these drivers? Any difference in performance for both DX11 and DX12?
     
  18. primetime^

    primetime^ Master Guru

    Messages:
    908
    Likes Received:
    17
    GPU:
    Sapphire RX Vega 64
    one of the odd issues with modding my bios is it shows 1.2 volts for gpu voltage, but it actually runs around 1.275 even though VB7 shows 1200. What ended up happening after i tried playing with the changed UVD speed (i changed it to 1100mhz instead of 850), i could not even start a game..it would just sorta never fully start. When this was happening i looked at the gpu voltage and it was under 2 volts lol (which explains the issue lol) Its like what VBE7 sees as actual values is not what these xfx cards really actually uses lol.

    Anyways i shouldn't have to modd a perfectly working bios to begin with, when its been perfect up till they gimped my performance with the 16.8 (? i believe when it started)


    I did remove the xbox app to at least see if it was triggering UVD some how...now BF1 is offline again! (so i have to wait to test fully)
     
  19. primetime^

    primetime^ Master Guru

    Messages:
    908
    Likes Received:
    17
    GPU:
    Sapphire RX Vega 64
    Maybe AMD driver team was told to GIMP our drivers so we buy new RX480's lol. They stole a play for nvidias play book lol!:puke2:
     
  20. Maxima

    Maxima New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    550v
    WTF These AMD drivers are just causing hard freezes for me, and I'm not using any Windows insider builds. I then have to go into safe mode to clean out the driver otherwise it won't boot. It's an enduro laptop w/ 8850m, if that matters.
     

Share This Page