Radeon Software Adrenalin 2020 Edition 20.1.2

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Caenyss, Jan 15, 2020.

  1. RooiKreef

    RooiKreef Master Guru

    Messages:
    410
    Likes Received:
    51
    GPU:
    MSI RTX3080 Ventus
    Whatever AMD is doing with their new drivers from December is a total joke. My Vega refuse to work properly with any of these new drivers. My games keep freezing and even my desktop experience is utterly bad. My Chrome browser just display a black screen. I tried it again last night after a DDU with no luck. My games freez with standard clocks and 100% fan speed with the card at 55C. Put the old November 2019 driver on and bam all problems solved. I hate this new drivers so much that I will seriously just throw my card out and go buy a Nvidia card once their Ampere cards come out. How on earth do you break a perfectly working thing and then you don't know how to fix it?
     
  2. Digilator

    Digilator Master Guru

    Messages:
    491
    Likes Received:
    135
    GPU:
    Sapphire 5700XT
    Also got system lock-ups, needing a hard reset - in games and just using a browser(Firefox). Would be nice if AMD concentrated on fixing this before anything else - big issues before small ones. Just noticed Tuning Control switched itself from Automatic to Manual, again. Even though I set it to Manual, I see it again checked for a new driver today. Sloppy.

    For now, I do suggest you turn off hardware acceleration for Chrome...

    Could also just keep using the older driver for now.
     
    Last edited: Jan 16, 2020
  3. Supertribble

    Supertribble Master Guru

    Messages:
    869
    Likes Received:
    118
    GPU:
    1080Ti/RadVII/2070S
    I was getting black screens launching Destiny 2 with 20.1.1 and went back to my 1080ti for the time being. I liked the previous UI from AMD, this new one is quite cluttered imo. Maybe now they can concentrate on sorting out the issues some people are having.

    Also, perf with the Radeon VII is well below the 1080ti in Destiny but only on the moon location for some reason. Please AMD look into that.
     
  4. Cplifj

    Cplifj Active Member

    Messages:
    91
    Likes Received:
    22
    GPU:
    290X
    Try to do factory reset on the amd drivers. I had some amd pci-bus device installed before on an intel system , this changed back to intels pciexpress root complex after resetting the amd driver to factory. And it works better, also all pci devices got reinstalled. This is kind of an important superbug, if i would have to speculate i'd say amd has been trying to take over the entire pc hardware with their PCIBUS driver on an intel system. I hope this bug is finally gone and doesn't come back with their next driver.
     

  5. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,457
    Likes Received:
    2,839
    GPU:
    MSI 6800 "Vanilla"
    Should just be some filter type driver in-between the Microsoft base driver (Both should be in there when looking into it via the device manager.) but yeah it's interesting how that's installed even on non AMD systems since quite some time back.
    Though if you've installed the Intel chipset driver and it somehow decided to update anything (Should be INF files only so nothing critical.) it might also have bumped those off in the process.

    EDIT: From memory the root of it should be the baseline Microsoft Windows driver and then the PCI Express Filter should be a bit like a new device from AMD on top of that.

    No idea what it's really for though or why it's forcibly installed like that.
     
  6. Digilator

    Digilator Master Guru

    Messages:
    491
    Likes Received:
    135
    GPU:
    Sapphire 5700XT
    Not sure if this is what "fixed it", but I also did a Factory Reset during installation - don't have the AMD driver showing now.
     
    JonasBeckman likes this.
  7. UkOldGit

    UkOldGit Member

    Messages:
    37
    Likes Received:
    8
    GPU:
    RX 5700 XT
    Still experiencing exactly the same texture problems with my 5700 xt when playing Modern Warfare the only driver that appears to work correctly is the 19.12.1.
    19.12.2, 19.12.3, 20.1.1 and 20.1.2 all cause the problem of disappearing and reappearing textures.
    I see no mention of this problem by AMD.
     
  8. LocoDiceGR

    LocoDiceGR Ancient Guru

    Messages:
    2,342
    Likes Received:
    811
    GPU:
    Gigabyte 3060 Ti
    All good here.
     
    warlord likes this.
  9. MerolaC

    MerolaC Ancient Guru

    Messages:
    3,530
    Likes Received:
    370
    GPU:
    MSI 5600XT G. MX
    Redo the shader cache.

    Go ingame, configure the game graphics as you want it to be.
    Exit and go to Documents\Call of Duty Modern Warfare\players\
    There, delete ppsod.dat
    Do the same for Documents\Call of Duty Modern Warfare\players2\
    (File might not be there)

    Then, start the game again, and sit on the main menu, let it completely generate the cache.
    Once it says that it's done, exit the game and start it again.
     
    OnnA likes this.
  10. boombastik

    boombastik Master Guru

    Messages:
    342
    Likes Received:
    52
    GPU:
    rx580 Pulse 8Gb
    If this is a bug then it exists for the last 10 years.
    Always the driver install a filter with the Microsoft driver.
     

  11. MSIMAX

    MSIMAX Active Member

    Messages:
    91
    Likes Received:
    41
    GPU:
    3x 290x cfx
    still no fix for the liquid devil issues :(
     
  12. Eastcoasthandle

    Eastcoasthandle Ancient Guru

    Messages:
    2,874
    Likes Received:
    501
    GPU:
    Nitro 5700 XT
    what issue?
     
  13. UkOldGit

    UkOldGit Member

    Messages:
    37
    Likes Received:
    8
    GPU:
    RX 5700 XT
    Thanks for the reply.
    My first thoughts were why would this make a difference when driver 19.12.1 worked ok and all drivers after that don't.
    My second thoughts were to give it a go in case you knew something I didn't.
    My third thought is that it confirmed 19.12.1 worked ok and all drivers after that don't.
    Final thought is that this is definitely a driver problem and not a game problem.

    Just out of interest do you have proof of what you say actually worked for anyone?
     
  14. HK-1

    HK-1 Master Guru

    Messages:
    835
    Likes Received:
    442
    GPU:
    RX580 Power Color
    here never...
     
  15. Krteq

    Krteq Master Guru

    Messages:
    769
    Likes Received:
    323
    GPU:
    RX Vega 56 +64 BIOS
    Hmm, no such issues here on Vega.

    I'm also running Opera with HW accel. enabled an have no blackscreens you guys are talking about.

    Seems that my system is in excellent shape :)
     

  16. MSIMAX

    MSIMAX Active Member

    Messages:
    91
    Likes Received:
    41
    GPU:
    3x 290x cfx
  17. Krteq

    Krteq Master Guru

    Messages:
    769
    Likes Received:
    323
    GPU:
    RX Vega 56 +64 BIOS
    Well, the other user have that fixed by flashing that updated BIOS correctly. So, you have to do the same.
     
  18. MerolaC

    MerolaC Ancient Guru

    Messages:
    3,530
    Likes Received:
    370
    GPU:
    MSI 5600XT G. MX
    Because my game is working just fine after that?
    I had the texture issue and after doing that it's fine.

    I am mainly playing COD right now and with this driver, I don't have such issue once I redo the shader cache.
     
    OnnA likes this.
  19. MaCk0y

    MaCk0y Master Guru

    Messages:
    967
    Likes Received:
    369
    GPU:
    GB 5700XT Gaming OC
    Upgraded from 20.1.1. No restart. So far so good.
     
  20. MSIMAX

    MSIMAX Active Member

    Messages:
    91
    Likes Received:
    41
    GPU:
    3x 290x cfx
    im on the bios its a bandaid to get the correct clocks any changes made in the driver causes system to crash
     

Share This Page