1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Radeon Rx 550 Low FPS (WAS FAST)

Discussion in 'Videocards - AMD Radeon' started by freelancer555, Dec 9, 2018.

  1. freelancer555

    freelancer555 New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Radeon Rx 550 4 GB
    Hello i have an Radeon rx 550 and recently my games started working with lower FPS then it used to games were working fine winthalmost 100 FPS now it's like 5-10 FPS (Euro Truck Simolator 2) for example World of Warcraft works on 80 FPS with no issues but Euro truck Simulator runs at 5-10 FPS as well as old Warcraft III strategy game works on 8 FPS i have no idea why ! I did clean Format of my pc installed OS again and issue remains like i said Euro Truck Simulator 5-10 FPS, World of Warcraft with no issues 80 FPS, Warcraft III 8 FPS i will download and check other games ! Please if you can give me any advice !
     
  2. droopy_ro

    droopy_ro Member

    Messages:
    49
    Likes Received:
    20
    GPU:
    GTX 1070 Ti MSI
    Did you upgrade/downgrade your AMD drivers ?
     
  3. warlord

    warlord Ancient Guru

    Messages:
    1,764
    Likes Received:
    456
    GPU:
    MSI R9 390X GAMING
    We need more info about your rig, so we can help.
     
  4. elaganza

    elaganza Member Guru

    Messages:
    114
    Likes Received:
    9
    GPU:
    Sapphire r9 380
    check your drivers, try any v-sync settings and as for as i get they are dx9 games - try tweaks for dx9 in RadeonMod (there's here on guru) app.What about temps on gpu,cpu,others components? Have u checked your hdd for errors? look at task manager for loading while gaming. My PoV is Amd drivers. Did u change monitor before the issue?
     

  5. freelancer555

    freelancer555 New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Radeon Rx 550 4 GB
    I have tried Adrenalin Edition 18.12.1.1 and Adrenalin Edition 18.9.3 no difference about temps i've got 65 celcius during gameplay
     
  6. elaganza

    elaganza Member Guru

    Messages:
    114
    Likes Received:
    9
    GPU:
    Sapphire r9 380
    Try v-sync modes. Especially v-sync on. What driver on amd you had before the problem? Did u upgraded any other system drivers? What about win10 october update? It is really buggy. What windows vetsion u had before? It looks like software issue. Or maybe ssd. Check health if u have one. Also check all others discs if u have more.
     
  7. elaganza

    elaganza Member Guru

    Messages:
    114
    Likes Received:
    9
    GPU:
    Sapphire r9 380
    Also check adrenalin driver setts. Check operation mode(mining/gaming),power efficiency,wattman. Set it to default
     
  8. freelancer555

    freelancer555 New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Radeon Rx 550 4 GB
    I've got latest version of windows downloaded from the Microsoft webstie, guys like i said few days ago Euro truck Simulator was working on 100 FPs now 10-15 even after formating the pc please give me some ideas
     
  9. ninja750

    ninja750 Member Guru

    Messages:
    119
    Likes Received:
    11
    GPU:
    RX580 Pulse
    maybe you have enabled chill
     
  10. freelancer555

    freelancer555 New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Radeon Rx 550 4 GB
    I've noticed in Euro Truck Simulator 2 when i change resolution to any resolution and then again to 1920:1080 game runs smoothly again, but when it gets to loading frame rate droops to 5 again ! what can cause this?
     

  11. ninja750

    ninja750 Member Guru

    Messages:
    119
    Likes Received:
    11
    GPU:
    RX580 Pulse
    any other vga program that can interfeer with wattman like afterburner?
     
  12. freelancer555

    freelancer555 New Member

    Messages:
    5
    Likes Received:
    0
    GPU:
    Radeon Rx 550 4 GB
    No, I am not having any programs of that type !
     
  13. Caesar

    Caesar Master Guru

    Messages:
    338
    Likes Received:
    84
    GPU:
    GTX 1070Ti Titanium
    Download this benchmark tool: https://benchmark.unigine.com/heaven
    Provide a result (screenshot) of the benchmarking done.
    ----------------------------------
    For the time being,

    Go to:
    1. Control Panel
    2. Power Options
    3. Change to balanced mode, performance mode (one at a time) and check
    ---------------------------------
    Disable Game BAR and Game DVR. (windows Key + I > Gaming > Toggle Gamebar to OFF)
    ---------------------------------
    Reinstall : DirectX and Visual C++ Redistributable Package
    ---------------------------------
     

Share This Page