1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Radeon FX 590 setup problem

Discussion in 'Videocards - AMD Radeon Catalyst Drivers Section' started by Robert Mulligan, Feb 23, 2019.

  1. Robert Mulligan

    Robert Mulligan New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    Radeon FX 590
    I am having a problem getting the Radeon FX 590 Fatboy card to connect. I have a Corsair TX 650M power supply and do not know what cable I need or if the Corsair supply is right. I tried connecting 2 cables to the Radeon and only get one blue light using the 6pin to8pin adapter that came with the card. Any help would be appreciated, thank you
     
  2. Fox2232

    Fox2232 Ancient Guru

    Messages:
    8,812
    Likes Received:
    1,688
    GPU:
    -NDA +AW@240Hz
    According to pictures of your PSU and packed cables. There is cable which has one piece 8-pin on one side and 2x 6+2-pin on other wide having "PCIe" written on them.
    On PSU, it is marked as "6+2 PCIe".
     
    Undying likes this.
  3. Robert Mulligan

    Robert Mulligan New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    Radeon FX 590
    That is correct. Do I just use one of the 6pin+2 in the 8pin on the card? Seems logical so i will try that.
     
  4. Robert Mulligan

    Robert Mulligan New Member

    Messages:
    3
    Likes Received:
    0
    GPU:
    Radeon FX 590
    That worked as both lights are blue, thank you for you help. Now I have to figure out how the monitor can see the card because I am not running windows but Mac OS 10.9
     

  5. Fox2232

    Fox2232 Ancient Guru

    Messages:
    8,812
    Likes Received:
    1,688
    GPU:
    -NDA +AW@240Hz
    I am not a Mac user. But I remember that in past (maybe long gone) Apple was whit listing GPUs, therefore GPU would not work unless in the list.
    (Is there Some Apple device with Polaris?)
    - - - -

    From quick googling:
    - MacOS 10.14/10.14.1 Mojave works
    - "Can't" use File Vault as display shows nothing till login screen. (Not sure how that works... maybe blind-type password?)
    - - - -

    Edit: seems like for older versions there is need for some overrides like RadeonDeInit.
     
    Last edited: Feb 24, 2019

Share This Page