RADEON Adrenalin 2020 - v19.12.2

Discussion in 'Videocards - AMD Radeon Drivers Section' started by LocoDiceGR, Dec 10, 2019.

  1. siyip80533

    siyip80533 New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    RX 570 Nitro+ 8GB
    I am using Windows 10 Enterprise ltsc 2019 (1809) and no problems up to now.

    It should run better with newer WDDM 2.6 drivers on 1903/1909.
     
  2. siyip80533

    siyip80533 New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    RX 570 Nitro+ 8GB
    Do you have the original v-bios of your card usually they can invalidate wrong/false bios data.
     
  3. siyip80533

    siyip80533 New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    RX 570 Nitro+ 8GB
    1-st step:

    I used DDU to delete/ uninstall my old drivers. Made sure to delete the c:/AMD folder and vulkan runtimes.

    2-step:
    When you install as you now have no drivers installed untick the reset driver settings as no settings were made.

    If you still have an issue it could possibly be a driver issue if you have not flashed a bios which is not validated by AMD.
     
  4. siyip80533

    siyip80533 New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    RX 570 Nitro+ 8GB
    I am using furmark, superposition, 3d mark tests to ensure stability and scores at the moment so far so good.


    I run
    1244mhz/890mv (GPU Core)
    1750mhz(7000 eff)/800mv(memory controller & memory speed)

    I don't use the OS bios personally, and managed to get my card stable with a peak gpu chip (core) power use of 82w.

    I can OC okayish for RX 570 to:
    1450mhz core/1150mv
    2100mhz memory (samsung) / 950mv
    Power spikes 160-220w this way and gains are good but not impressive for the performance inefficiency given. No memory errors.
     

  5. bernek

    bernek Ancient Guru

    Messages:
    1,545
    Likes Received:
    57
    GPU:
    2080TI/1080TI/VEGA
    Yes I have the original bios ... same error I will try to DDU now and report back.
     
  6. spectatorx

    spectatorx Master Guru

    Messages:
    858
    Likes Received:
    169
    GPU:
    Radeon RX580 8GB
    Undying likes this.
  7. JonasBeckman

    JonasBeckman Ancient Guru

    Messages:
    17,446
    Likes Received:
    2,814
    GPU:
    MSI 6800 "Vanilla"
    One thing I noticed is that it doesn't quite clean out some of the older files if doing a upgrade install, might apply to registry and such too. Clean install could be the way to go here even against ticking the "Reset driver." in the installer itself which is also a option unless the error applies before that choice comes up under Additional Settings. :)

    A reboot was also required for the driver to initialize fully instead of being optional but strongly recommended.
    (Services and stuff and the Catalyst Settings software itself just wouldn't work without it.)

    EDIT: For some of the uncleaned files that would be the co-installer .dll and the AMDCom and it's 64-bit variant which no longer exist in 19.12.2 at all.
    (Co-installer got updated from 19.30 to 19.50 in this driver release so it's a new .dll file name to match the new version so the old ones can just be deleted.)

    EDIT: Oh and the PCI bus driver files aren't in this driver either compared to the 19.12.1

    EDIT: Start menu appearance is fixed after a reboot and now to see if the PCI filter thing has to be manually removed as well.


    EDIT: Seems the shader cache can't be disabled anymore in this driver though it can be cleared, still caches various OS stuff as well like Explorer and such.

    EDIT: Fan speed control seems like it doesn't apply to idle anymore.
     
    Last edited: Dec 10, 2019
  8. bernek

    bernek Ancient Guru

    Messages:
    1,545
    Likes Received:
    57
    GPU:
    2080TI/1080TI/VEGA
    I can't believe this I even DDU the old driver and still Error 137 AMD hardware not found ... I can't install this driver this is crazy. Sapphire Vega64 Nitro+ LE here.
     
  9. exmodel

    exmodel Member

    Messages:
    32
    Likes Received:
    5
    GPU:
    MSI RX570 8GB
    Just installed and these features are even better than I thought. Looks like integer scaling is now available on my 570 even though it didn't say anything about that.

    Also, individual color profiles for each game!! Previous drivers kinda had this but it was only accessible from the in-game overlay and usually failed to apply your settings. I've wanted this feature for years!
     
    bernek likes this.
  10. PrEzi

    PrEzi Master Guru

    Messages:
    660
    Likes Received:
    529
    GPU:
    AMD 6900XT
    DDU'd rebooted and installed flawlessly. Then I re-applied latest chipset + raid just to be sure all is there I needed...
    The new panel is rocking HARD !! :-D

    Btw @mtrai -- no need to clean up the registry keys mentioned by you --- when you do it properly (in the safe mode) then DDU 1.8.0.2 also removes the AMD keys and replaces with the "Standard VGA Adapter" which is totally fine.
     
    HK-1 likes this.

  11. Undying

    Undying Ancient Guru

    Messages:
    15,488
    Likes Received:
    4,499
    GPU:
    Aorus RX580 XTR 8GB
    Also installed just fine (clean install using DDU). My oc profile works and UI is such an improvement and detailed. I like it.
     
  12. bernek

    bernek Ancient Guru

    Messages:
    1,545
    Likes Received:
    57
    GPU:
    2080TI/1080TI/VEGA
    Can't belive it FIXED it ! I had a PCIE to M2 card in a slot and that was causing the problem. Installing as we speak :D
     
  13. Mpampis

    Mpampis Member Guru

    Messages:
    162
    Likes Received:
    109
    GPU:
    RX 5700 XT 8GB
    One installer bug for me, I had to unmount my network drives in order to get it to install.
    It did warn me that it doesn't install because it can't access the network drives though, so no searching for the problem.
    MSI Afterburner now reports a doubled VRAM frequence (1750 stock on my RX 5700 XT, was 875 before).

    My GPU is watercooled, so I set 2150MHz for GPU and 1840MHz for VRAM, and ran 3DMark. I got a graphics 9904 score, it was around 9450 with the same frequencies using the 19.11.3 driver.
     
  14. spectatorx

    spectatorx Master Guru

    Messages:
    858
    Likes Received:
    169
    GPU:
    Radeon RX580 8GB
    That's really odd compatibility conflict. I think you may want to check bios settings, update motherboard bios and this card's driver and firmware if any available. Also report it in detail to amd.

    I hope it is not your main OS bootdrive as that would be difficult to use such drive with that gpu driver :D
     
  15. Spider-Vice

    Spider-Vice Member

    Messages:
    31
    Likes Received:
    6
    GPU:
    Radeon RX 5700 8G
    Hmmm just had a display driver crash while playing RDR2 with these, full crash to black screen. Had never happened in the previous 19.12.1 driver in any game since I got my RX 5700.
     

  16. bernek

    bernek Ancient Guru

    Messages:
    1,545
    Likes Received:
    57
    GPU:
    2080TI/1080TI/VEGA
    No its not my main OS drive its an hackintosh BCM wifi+bt ... I'm pretty sure I can install it back and it will work no problem. Will test tomorrow with it connected and report back. It was quite strange tho ...

    P.S. installing GTA 5 again just to test Boost :D so happy with the new drivers and features !

    The new CP is great !!!

    P.S.2. RDR2 works really nice !
     
    OnnA likes this.
  17. Jagman

    Jagman Ancient Guru

    Messages:
    2,256
    Likes Received:
    320
    GPU:
    5700XT Pulse
    Use DDU. Tried installing over my old 19.11.3 (at least I think it was them) but that didn't go well. Fired up Hell Let Loose and it would freeze up on the main menu screen after a few seconds. Alt tab to another program would unfreeze it but it would freeze again when you went back.

    Used DDU, restarted and reinstalled and all is OK now. Must admit I do like the new layout :cool:
     
  18. rl66

    rl66 Ancient Guru

    Messages:
    2,862
    Likes Received:
    349
    GPU:
    Sapphire RX 580X SE
    I will wait the final version as boost = instant freeze and all new thing don't work correctely, 19.12.1 is more stable for me.
     
  19. Wagnard

    Wagnard Ancient Guru

    Messages:
    2,660
    Likes Received:
    330
    GPU:
    MSI Geforce GTX 1080
    Huh, where did that came from that DDU cannot delete this anymore ?
    That key is removed for sure if cleaned in safe mode.

    Btw in the next few day, when i'm off work, i'll do some digging to see if there is some new leftovers from this new driver.
     
  20. ektoradsj

    ektoradsj Member

    Messages:
    32
    Likes Received:
    13
    GPU:
    Hd7850 2GB
    Error 1603 only partially installed....(Tried with DDU and with all other drives disconnected still the same).
     
    Last edited: Dec 11, 2019

Share This Page