Radeon 5850, no Morphological AA option

Discussion in 'Videocards - AMD Radeon Drivers Section' started by ivan.winata, Mar 9, 2011.

  1. ivan.winata

    ivan.winata Master Guru

    Messages:
    425
    Likes Received:
    0
    GPU:
    GTX2080Ti Zotak
    I got 5850 (His i-cooler V). Supposedly from driver 11.xx all radeon 5800 owner should have the morphological AA, Tesselation setting, Surface optimization etc... new options in the CCC.
    For some reason, up until now I haven't been able to get all of those options. I tried 11.1 11.2 11.4 preview. I have done waiting, and I think its a matter of my card's BIOS?
    In DA2 and most other games that did hardware check, my card identified as Radeon 4800 series. GPU-Z and CCC confirmed its a 5800 series.

    Anyone has the same problem and maybe solution? Thanks

    EDIT: forgot to mention that I did clean re-instalation. Tried both driver sweeper and TWL's method
     
    Last edited: Mar 9, 2011
  2. ivan.winata

    ivan.winata Master Guru

    Messages:
    425
    Likes Received:
    0
    GPU:
    GTX2080Ti Zotak
    anyone?
     
  3. Rik55

    Rik55 Member Guru

    Messages:
    176
    Likes Received:
    0
    GPU:
    ASUS HD4850 700/1100MHz
    Presuming you are using Vista/Win7. (XP doesn't support those new options)

    It sounds like you have a Ghost/Phantom Device listed and Hidden in the Device Manager from a previous card (HD4800 series).

    This can happen when the graphics card is changed without removing it's driver properly.

    Open RegEdit and at HKEY_CURRENT_USER\Environment\ click Edit - New - String Value. Call the new string 'devmgr_show_nonpresent_devices' and modify it's value to '1'. Now reboot.

    Once rebooted, open Device Manager and under View, click show hidden devices. Now, when you expand Display adapters, it will reveal any hidden devices. If it does show a faded HD4800, rightclick and Uninstall.

    Now uninstall Catalyst driver using Cat Install Manager, Reboot, then re-install the newest Cat driver and MLAA etc should show up on your HD5800.


    alternative method instead of RegEdit is to add new envoironmental variable by Right Click My Computer, Advanced System Settings, Envoironment Variable, then create a New variable under User Variables. Again call the new variable 'devmgr_show_nonpresent_devices' and give it a value of 1. Again, reboot and in Device Manager, click show hidden devices.
     
    Last edited: Mar 9, 2011
  4. ivan.winata

    ivan.winata Master Guru

    Messages:
    425
    Likes Received:
    0
    GPU:
    GTX2080Ti Zotak
    Thanks! Its Windows 7 x64 and my previous gfx was 4890.
    I'll try this once I get home.
     

  5. ivan.winata

    ivan.winata Master Guru

    Messages:
    425
    Likes Received:
    0
    GPU:
    GTX2080Ti Zotak
    It works, problem solved. Thanks!
     
  6. wlw_wl

    wlw_wl Master Guru

    Messages:
    864
    Likes Received:
    0
    GPU:
    Sapphire 6850 non-Toxic
    I had pretty much the same issue, remains of 4850 in the system, which caused all sorts of issues when switched to 6850.
     

Share This Page