Radeon 5770 recognized as 4250

Discussion in 'Videocards - AMD Radeon' started by wtfroy, Nov 17, 2010.

  1. wtfroy

    wtfroy New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    5770
    Specs:
    Asus EAH5770 CuCore Radeon (not overclocked)
    AMD Phenom II x2 555 BE
    BIOSTAR 880G+ AM3 Motherboard
    Mushkin 2x2gb Ram
    WD 500gb HDD
    580w power supply (does not have a 6 pin connector thus using the 6pin - 2 molex adapter)

    [​IMG]

    I know it shows alot of things, but I hope it helps.

    Although the device manager shows "Radeon 5700 series", many applications and games recognize it as the onboard 4250 on my motherboard.
    Since its recognized as a 4250, it won't do any directx 11 features.
    I tried running the Unigine Heaven benchmark but tesselation feature is greyed out. Stone Giant does not even start. Civ 5 on directx 11 crashes when I try to end the first turn (no problems on directx 9 setting).
    Currently I'm using Catalyst version 10.10 (latest stable version)
    GPU-Z Shows that it supports directx11 but Directcompute is checked off

    Here's what i tried:
    -Disabling/Enabling the onboard video
    -updated latest bios of the motherboard
    -reinstalling various versions of catalyst (used driver sweeper in safe mode)
    -video card spoofing with radeonpro (it spoofed it alright, but still directx11 does not work)

    AGAIN
    There is zero performance issues with the video card, but its recognized as a freaking radeon 4250 and disables the 5770's full feature. Any help would be greatly appreciated.
    Thanks
     
  2. deltatux

    deltatux Ancient Guru

    Messages:
    19,051
    Likes Received:
    13
    GPU:
    GIGABYTE Radeon R9 280
    Has that 4250 been thoroughly disabled? I know my M3A78-EM's onboard can't be thoroughly disabled since Windows still sees its existence.

    deltatux
     
  3. wtfroy

    wtfroy New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    5770
    Well to be honest, the BIOS in this motherboard is quite crappy.
    It was very confusing for me at first to configure my setup.

    There isn't really an option called "Disable onboard video"
    This is what i get in the bios for onboard video:
    [​IMG]

    I just disabled the Internal Graphics Mode and Engine Override options.
    Hmm..
    An Asus p4p800 BIOS was much easier to understand which was a 478 socket motherboard.
     
  4. Dan011093

    Dan011093 Member Guru

    Messages:
    170
    Likes Received:
    0
    GPU:
    HD 5870/5850 CF
    are you plugging the cable in the HD 5770 slot? i know it sounds stupid but a friend had a problem like that and he wasnt plugging the monitor cable in the HD 5770 slot, he was plugging it to the motherboards slot....
     

  5. isidore

    isidore Ancient Guru

    Messages:
    6,276
    Likes Received:
    58
    GPU:
    RTX 2080TI GamingOC
    sounds like some software problems, try this:

    disable on-board gpu.
    format and install a fresh copy of windows.
    install the latest catalyst
    test if you have the same problems.
     
  6. Black_ice_Spain

    Black_ice_Spain Ancient Guru

    Messages:
    4,583
    Likes Received:
    17
    GPU:
    5700XT
    internal graphics mode on "disabled" should disable it

    Disabled = no memory for gpu, so theorically disabled? o_O
     
  7. wtfroy

    wtfroy New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    5770
    @dan don't worry I know where my cables are connected.

    @isidore dude did you read my message?? lol
    That's exactly what I did, but formatting is not an option(school work, personal hobbies etc.)

    @black_ice_spain Yes that's what I think too. I have disabled them.

    Thanks for the replies.
    But my problem still exists without a solution.
    Help me out guys.
     
  8. isidore

    isidore Ancient Guru

    Messages:
    6,276
    Likes Received:
    58
    GPU:
    RTX 2080TI GamingOC
    yeah i did..but seems formatting would be the last option for you..
     
  9. teleguy

    teleguy Maha Guru

    Messages:
    1,354
    Likes Received:
    194
    GPU:
    GTX 1070/Vega 56
    If you enable the 4250 and install the drivers can you switch between both cards in GPU-Z and DirectCompute Benchmark?

    What does NorthBridge Configuration>Primary Video Controller say?
     
  10. wtfroy

    wtfroy New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    5770
    @isidore yup.. unless I had some external hard drive.. :)

    @teleguy I tried enabling the onboard and see how it was going to work. When I plug the DVI to the onboard, the screen shows blank. I think it's cause of my graphics card being plugged in?
    The Primary Graphics is at GFX0->GPP->IGFX->PCI
    Maybe If I changed IGFX to primary, it might show display.

    Thanks guys I'll try it out, and see how it goes.
     

  11. Black_ice_Spain

    Black_ice_Spain Ancient Guru

    Messages:
    4,583
    Likes Received:
    17
    GPU:
    5700XT
    Last edited: Nov 18, 2010
  12. Rik55

    Rik55 Member Guru

    Messages:
    176
    Likes Received:
    0
    GPU:
    ASUS HD4850 700/1100MHz
    The 4250 is a Ghost (Phantom) Device in the Device Manager. It must have been enabled at some point leaving it's registry entries behind.

    http://support.microsoft.com/kb/241257 (link for 2 different methods - same procedure for all OS)

    once you have set an Environmental variable - devmgr_show_nonpresent_devices to 1. Start up Device Manager and set to show hidden devices. Then it will show you a faded HD4250 beside your HD5770. You can now right click the HD4250 and uninstall (do not tick with drivers).
     
  13. wtfroy

    wtfroy New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    5770
    SUCCESS!!!!!!!!!!

    Thank you all
    Here's what I have done:
    -Enabled the Onboard Video
    -Changed primary Graphics to IGFX
    -Plugged DVI through my onboard
    -Uninstalled AND Disabled the 4250 in the Device Manager
    -Installed latest catalyst for my 5770

    I think when I first had this computer, I was displaying output via my onboard.
    That could be the reason the drivers are set on 4250.

    DANG IT you guys are pure genius.
    Thank you all!
    Now I can enjoy some eye candy hopefully, and I hope this helps anyone else out there who has the same problem.

    Roy
     
  14. Rik55

    Rik55 Member Guru

    Messages:
    176
    Likes Received:
    0
    GPU:
    ASUS HD4850 700/1100MHz
    Yip, that would also work. It was because the 4250 remained as a Phantom Device, never being uninstalled, just Disabled in BIOS.
     
  15. wtfroy

    wtfroy New Member

    Messages:
    6
    Likes Received:
    0
    GPU:
    5770
    Thank you Rik55 and Black_ice_Spain.

    That would have solved it right away.

    dangggg
     

Share This Page