R9 280x flickering and crashing

Discussion in 'Videocards - AMD Radeon' started by SemtexVa, Dec 1, 2014.

  1. MacT

    MacT Member Guru

    Messages:
    185
    Likes Received:
    0
    GPU:
    2 x Sapphire HD 7970 OC
    SemtexVa, out of curiosity what is the driver version on your cd? And what was your procedure for changing drivers? Did you run a driver cleaner like DDU when upgrading?

    Just seems odd that you can go back to this original driver and the problem goes away. Like, voltage issues should be there for all drivers, should they not? Never heard of Catalyst packages effecting stability . An OC yes. But driver change on a stock card...? Weird.
     
  2. SemtexVa

    SemtexVa Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    xfx R9 280x
    Hey, the version is 13.251W according to the cd, and yes i used DDU, uninstalled the old drivers, booted un safe mode, used DDU, installed new drivers, flickering and crashing still there.I also made fresh windows installation, same results.
     
  3. MacT

    MacT Member Guru

    Messages:
    185
    Likes Received:
    0
    GPU:
    2 x Sapphire HD 7970 OC
    Looks like this issue? : http://forums.amd.com/game/messagev...=168806&STARTPAGE=1&FTVAR_FORUMVIEWTMP=Linear

    According to that thread:

    Seems extent of flickering depends on what card brand you have. Problem introduced in newer drivers from late last year.

    Solutions that have fixed it are Vbios update. Or an increase in 2D clocks to 400/200.

    So, maybe look to see if there is a Vbios update for your card. Failing that, try the 2D clock bump.
     
  4. SemtexVa

    SemtexVa Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    xfx R9 280x
    My flickering also happens in desktop and it also crashes, the crash puts the whole screen in different colours and everything else is useless, i cant Ctrl+Alt+Supr, i cant do anything , the only way to use my computer again is to force a restart with the power button. Also where can i get new vbios? the amd page only has drivers.
    Thanks
     

  5. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,481
    Likes Received:
    1,523
    GPU:
    GTX980 SLI
    When was the last time you reinstalled Windows ?

    Maybe partition your HDD, install a fresh copy of Windows on the new partition and test it there to rule out software
     
  6. SemtexVa

    SemtexVa Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    xfx R9 280x
    I made a fresh windows installation two days ago, also i have an SSD
     
  7. Extraordinary

    Extraordinary Ancient Guru

    Messages:
    19,481
    Likes Received:
    1,523
    GPU:
    GTX980 SLI
    Was it doing it on the previous windows install before you wiped ?
     
  8. SemtexVa

    SemtexVa Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    xfx R9 280x
    yes, i actually re installed windows to try if that would fix the problem
     
  9. MacT

    MacT Member Guru

    Messages:
    185
    Likes Received:
    0
    GPU:
    2 x Sapphire HD 7970 OC
    Should be able to get them from the card manufacturer but I can't seem to find the page at XFX. Try Techpowerup.
    XFX bios list here
    http://www.techpowerup.com/vgabios/...FX&model=R9+280X&interface=&memType=&memSize=
     
  10. SemtexVa

    SemtexVa Member

    Messages:
    16
    Likes Received:
    0
    GPU:
    xfx R9 280x

  11. Warcrysis

    Warcrysis Member

    Messages:
    22
    Likes Received:
    0
    GPU:
    Nvidia GTX 1080 Ti SC2
    try lowering your memory clocks
     

Share This Page