Quadro performance problem:

Discussion in 'RivaTuner Advanced Discussion forum' started by juodvarnis, Mar 19, 2006.

  1. juodvarnis

    juodvarnis Member

    Messages:
    49
    Likes Received:
    0
    GPU:
    mobility radeon hd 5650
    as i have modified gf cards and tested them as quadros, maybe someone familiar with such problem, or may have some thoughts:

    recently i upgraded my system from:

    p4 2.8@3,5GHZ (250mhz fsb)
    i865PE 2gb ram @200mhz (DDR400)
    gf 5900ultra 256mb AGP modified to quadro3000 with rivatuner and 45.28drivers


    to

    a64 x2 4200+ @2,5Ghz (10*250mhz fsb)
    nforce4 ultra 2gb ram @200mhz (DDR400)
    gf 6800gt 256mb PCI-E modified to quadro4000 with rivatuner and 81.98drivers (not complete modification because of PCI-E, pro features unlocked only, nevertheless maxtreme works fine)


    i tested with 3ds max7 and maxtreme7 drivers two scenes (with stopwatch):

    texture2: 6800gt system about 50% faster
    geometry2: 5900u system more than 100% faster than 6800gt!!!

    where is the problem? tested on 64bit and 32bit winxp systems, tested with earlier 66.xx drivers,- no difference! where could be the bottleneck? it seems that system chokes, like it is when you have not enought ram and system swaps memory to hdd :) i see some kind of slideshow...

    i tried direct 3d drivers, it is incredibly faster, BUT only in shaded mode. wireframe mode is much slower than with maxtreme drivers. opengl is slow compared to maxtreme or d3d, as it should be...

    as i often use in my work shaded wireframe mode or only wireframe,- direct 3d doesn't fit me... crazy, but i think about changing mobo to nforce3 and find 6800gt or ultra AGP videocard :) will it help...? could it be of not complete conversion pci-e to quadro?

    thoughts and comments welcome ;)
     
  2. juodvarnis

    juodvarnis Member

    Messages:
    49
    Likes Received:
    0
    GPU:
    mobility radeon hd 5650
    some test on a64 4200+ mashine:
    before quadro mod, 71.84 drivers win xp 32bit, clean system, only nforce4 drivers from cd installed, asus a8n-e mobo

    specviewperf 7.0:

    3dsmax-01 Weighted Geometric Mean = 22.00
    ugs-01 Weighted Geometric Mean = 6.648

    after mod:
    3dsmax-01 Weighted Geometric Mean = 35.28
    ugs-01 Weighted Geometric Mean = 65.71
     
    Last edited: Mar 19, 2006
  3. juodvarnis

    juodvarnis Member

    Messages:
    49
    Likes Received:
    0
    GPU:
    mobility radeon hd 5650
    and here results measured with stopwatch:

    a64 x2 4200+ 6800gt 256mb

    maxtreme7 quality, texture512 noAA ani16 uxga

    txt2 6.8s (58.8fps)
    txt2ef 12.05s (33.2fps)
    txt2wf 6.38s (62.7fps)
    geom2 16.97
    geom2wf 34.35
    geom2ef 43.85

    d3d9 no triangle edges

    txt2 4.64s
    txt2ef 13.79s
    txt2wf 9.29s
    geom2 2.01s
    geom2wf 40.96s
    geom2ef 41.46s


    p4 2.8@3.5 5900ultra

    maxtreme7 quality texture512 noAA ani8 uxga

    txt2 10.77s (37.1fps)
    txt2ef 13.30s (30.1fps)
    txt2wf 5.6s (71.4fps)
    geom2 8.94 (33.5fps)
    geom2ef 30.72 (9.8fps)
    geom2wf 23.43 (12.8fps)

    and here with AGP 6800gt 128mb (asus gamers edition) i've tested some time before on this p4 mashine:

    quality (no aa) texture256 ani-16

    geom2 -37.5 (8.0s)
    geom2ef -12.4 (24.1s)
    geom2wf -18.5 (16.2s)
    txt2 -58.0 (6.9s)
    txt2ef -38.1 (10.5s)

    * wf=wireframe mode
    * ef= edged faces on

    i even tried removing one pair of 512mb modules from mobo...
    no chipset compatibility modes enabled in RT, memory works in dualchannel mode... i have no clue what could it be, stopping my mashine...?
     
  4. juodvarnis

    juodvarnis Member

    Messages:
    49
    Likes Received:
    0
    GPU:
    mobility radeon hd 5650
    maybe it has something to do with driver profiles? the dropdown menu is empty in display properties! (where should be games or application presets depending on geForce or quadro is currently installed)

    here is detailed test made with agp gf6800gt@quadro4000 on p4@3.1ghz

    3dsmax-02 Viewset
    -------------------------------------------------------------------------------
    Test Weight Frames DLB Visual Double Frame Buffer Depth
    # Per Sec Sec ID Buffer Red Green Blue Alpha Buffer Buffer
    -------------------------------------------------------------------------------
    1 5.50 24.7 N/A 7 True 8 8 8 0 24
    2 5.50 24.6 N/A 7 True 8 8 8 0 24
    3 5.50 17.3 N/A 7 True 8 8 8 0 24
    4 5.50 14.9 N/A 7 True 8 8 8 0 24
    5 17.00 58.1 N/A 7 True 8 8 8 0 24
    6 5.50 48.0 N/A 7 True 8 8 8 0 24
    7 5.50 34.2 N/A 7 True 8 8 8 0 24
    8 5.50 23.7 N/A 7 True 8 8 8 0 24
    9 5.50 12.5 N/A 7 True 8 8 8 0 24
    10 17.00 64.8 N/A 7 True 8 8 8 0 24
    11 5.50 22.9 N/A 7 True 8 8 8 0 24
    12 5.50 23.0 N/A 7 True 8 8 8 0 24
    13 5.50 16.5 N/A 7 True 8 8 8 0 24
    14 5.50 16.5 N/A 7 True 8 8 8 0 24
    -------------------------------------------------------------------------------
    3dsmax-02 Weighted Geometric Mean = 30.90

    and here is mine, made on that problem mashine:

    3dsmax-02 Viewset
    -------------------------------------------------------------------------------
    Test Weight Frames DLB Visual Double Frame Buffer Depth Stencil
    # Per Sec Sec ID Buffer Red Green Blue Alpha Buffer Buffer
    -------------------------------------------------------------------------------
    1 5.50 34.5 N/A 7 True 8 8 8 0 24 0
    2 5.50 34.2 N/A 7 True 8 8 8 0 24 0
    3 5.50 22.1 N/A 7 True 8 8 8 0 24 0
    4 5.50 18.1 N/A 7 True 8 8 8 0 24 0
    5 17.00 79.2 N/A 7 True 8 8 8 0 24 0
    6 5.50 48.0 N/A 7 True 8 8 8 0 24 0
    7 5.50 42.8 N/A 7 True 8 8 8 0 24 0
    8 5.50 29.1 N/A 7 True 8 8 8 0 24 0
    9 5.50 21.3 N/A 7 True 8 8 8 0 24 0
    10 17.00 84.4 N/A 7 True 8 8 8 0 24 0
    11 5.50 20.3 N/A 7 True 8 8 8 0 24 0
    12 5.50 20.3 N/A 7 True 8 8 8 0 24 0
    13 5.50 14.3 N/A 7 True 8 8 8 0 24 0
    14 5.50 14.3 N/A 7 True 8 8 8 0 24 0
    -------------------------------------------------------------------------------
    3dsmax-02 Weighted Geometric Mean = 37.07

    as you can see tests from 1 to 10 my mashine is faster (well thats normal) BUT tests 11 to 14 is slower!!!
    what are these test about? maybe i need something to enable in registers (via RT)?

    opengl extentions viewer shows that all 136 extentions are available and working...

    should ir be so? (taken from RT)
    $ffffffffff ----------------------------------------------------------------
    $ffffffffff OpenGL driver information
    $ffffffffff ----------------------------------------------------------------
    $0f00000000 Vendor : NVIDIA Corporation
    $0f00000001 Renderer : GeForce 6800 Series GPU/PCI/SSE2
    $0f00000002 Version : 2.0.1
    $ffffffffff ----------------------------------------------------------------

    maybe because of gforce opengl renderer something don't work? shouldn't it be quadro renderer?
     
    Last edited: Mar 20, 2006

  5. juodvarnis

    juodvarnis Member

    Messages:
    49
    Likes Received:
    0
    GPU:
    mobility radeon hd 5650
    solution:

    61.82 drivers put things to normal,- now 6800gt system works fine like it should to, but why can't i use later drivers?!?
     
  6. pedrolito

    pedrolito Member

    Messages:
    39
    Likes Received:
    0
    GPU:
    POV 6800GT @Ultra+ @Quadro FX4000
    I am having the same problems here:
    Here are the benchmark results of Specvieweperf 6.1.8

    6800GT@Quadro:
    ---------- SUM_RESULTS\AWADVS\SUMMARY.TXT
    AWadvs-04 Weighted Geometric Mean = 60.20

    ---------- SUM_RESULTS\DRV\SUMMARY.TXT
    DRV-07 Weighted Geometric Mean = 59.91

    ---------- SUM_RESULTS\DX\SUMMARY.TXT
    DX-06 Weighted Geometric Mean = 60.20

    ---------- SUM_RESULTS\LIGHT\SUMMARY.TXT
    Light-04 Weighted Geometric Mean = 41.13

    ---------- SUM_RESULTS\MEDMCAD\SUMMARY.TXT
    MedMCAD-01 Weighted Geometric Mean = 60.31

    ---------- SUM_RESULTS\PROCDRS\SUMMARY.TXT
    ProCDRS-03 Weighted Geometric Mean = 60.20



    And my genuine Quadro4 XGL900:
    AWadvs-04 Weighted Geometric Mean = 59.47
    MedMCAD-01 Weighted Geometric Mean = 55.92


    Once I managed to hit the 109fps under the MemCAD bench with my XGL900. I am having some big drivers issue here and I don't understand where it comes from!!!
     
  7. juodvarnis

    juodvarnis Member

    Messages:
    49
    Likes Received:
    0
    GPU:
    mobility radeon hd 5650
    i've find out that drivers don't have impact on specview performance, this performance issue is only noticeable at 3ds max with maxtreme drivers
     
  8. pedrolito

    pedrolito Member

    Messages:
    39
    Likes Received:
    0
    GPU:
    POV 6800GT @Ultra+ @Quadro FX4000
    So what do you think is the problem?

    I remember playing around with drivers for my chipset and the graphic card, and now my performance has decreased.
     
  9. juodvarnis

    juodvarnis Member

    Messages:
    49
    Likes Received:
    0
    GPU:
    mobility radeon hd 5650
    i remember i used 41.09 drivers for gf4 4200@quadro and that was the best ones. try different drivers and test which ones fits you best (have best performance)
     
  10. juodvarnis

    juodvarnis Member

    Messages:
    49
    Likes Received:
    0
    GPU:
    mobility radeon hd 5650
    UPDATE:

    i had some time to test some drivers,- 67.22 drivers are the last that works fine in 3ds max 8 with latest maxtreme drivers
     

Share This Page