Problems with RX radeon. No video signal

Discussion in 'Videocards - AMD Radeon' started by elpollodiablo31, Nov 24, 2017.

  1. elpollodiablo31

    elpollodiablo31 Member

    Messages:
    34
    Likes Received:
    0
    GPU:
    None
    Good morning everyone. I currently use a fx-8320 and a ga990xa-ud3 motherboard

    It is updated to the latest version of bios to avoid the famous bug of the gigabyte boards when doing overclock

    The problem is the following:

    I have placed at the time a rx 460 and then a rx 550. None works correctly. The first gave problems when installing the drivers and the second directly does not give video. I know the problem is with the motherboard, because the store found that the rx 460 worked

    However, nvidia pascal works without problem. How can i fix this?. I'm surprised that a not so old socket is giving compatibility problems. Without being able to use any modern radeon I have limited to choose graphics card.
     
  2. Agent-A01

    Agent-A01 Ancient Guru

    Messages:
    10,372
    Likes Received:
    260
    GPU:
    1080Ti H20
    Those newer AMD GPUs do not have legacy support, aka old bios.

    They will only work with UEFI computers.

    NV has hybrid bios which support both uefi and bios.
     
  3. elpollodiablo31

    elpollodiablo31 Member

    Messages:
    34
    Likes Received:
    0
    GPU:
    None
    Thanks for the advice. That has helped me find possible culprits for the future. But this board is rev3 and supports uefi as standard. I have tested the rx 550 on 2 computers 1155 h61, both with active uefi and the same. It does not give video image.

    The gpu was purchased in 20% of reconditioned amazon. Surely it is defective. I do not buy anything used to amazon again.
     
  4. Agonist

    Agonist Ancient Guru

    Messages:
    2,390
    Likes Received:
    31
    GPU:
    R9 Fury Nitro OC
    You can have the same issue with new, FYI.

    I purchased my fury because it has a bios switch for legacy and UEFI because at first I was gonna be using it on a X58 board while saving up for my old X79 setup I had before this ryzen setup, and to test it for the fun in my dual xeon X58 server.
     

  5. elpollodiablo31

    elpollodiablo31 Member

    Messages:
    34
    Likes Received:
    0
    GPU:
    None
    I dont think so. The 3 pc that I used support uefi. The x58 chipset does not support it. Use bios award. The motherboards that I have nominated were revisions of 2012, not 2008 like the chipset x58
     

Share This Page