Problem with ShadowPlay

Discussion in 'Videocards vs General Purpose - NVIDIA Ageia PhysX' started by Aleksandarbg, Jan 20, 2015.

  1. Aleksandarbg

    Aleksandarbg New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Inno3D iChill GTX 970 4GB
    Good day, today arrived my new card (GTX 970) and I thought the problem would be fine but ... As I decide to record with ShadowPlay, run it and the green circle goes red diagonal. A friend has almost the same configuration as me (I have 4670, he 4690; I have 120gb SSD and 1TB WD, and he 1TB Seagate), even our video cards were the same (gtx 770), but I changed and I have mine. Taking try to record it makes me folder and nothing more, while it is trying it is normal everything ...I think this is something software... Do you have any ideas?
    My sistem is:
    Intel Core i5-4670
    AsRock B85 Killer
    Inno3D iChill GTX 970 HerculeZ X4 AirBoss 4GB
    KingSton 120GB SSD
    KingSton 1x8GB RAM
    1TB WD
    Thanks in advance!
     
  2. Enmity

    Enmity Maha Guru

    Messages:
    1,309
    Likes Received:
    0
    GPU:
    EVGA 1080ti FE SLI
    id reinstall geforce experience man. Or, before you do that open up geforce experience click on shadowplay and then the little settings icon. under recordings you can select where you want your recordings to be saved - make sure this is set to a drive which has a lot of storage. Maybe save to a different location just for testing purposes. If this still doesn't work id imagine reinstalling geforce experience should sort it.

    I'm new to nvidia though, just got my 970's barely a week ago so I may be missing something.
     
  3. Aleksandarbg

    Aleksandarbg New Member

    Messages:
    2
    Likes Received:
    0
    GPU:
    Inno3D iChill GTX 970 4GB
    EU windows users who have Windows 7/8/8.1 N version should check for Media Foundation update that is needed for shadowplay to work. One good way to check is running the installer once, so every file is unzipped to C:\Nvidia, You should then navigate to C:\NVIDIA\DisplayDriver\331.65\Win8_WinVista_Win7_64\English\ShadowPlay and try to launch one of the nvspcaps or nvspcaps64, if it whines about MF.dll missing you've got this problem. I encountered a problem with shadowplay not installing with the installer and after hours of debugging I found out that as I live in europe I have the windows N version which does not include Windows Media Player (and related files) which is needed for shadow play. Installing the packet fixed my issues with shadowplay and now everything works perfectly.

    NOTE: I had these files installed on my Win 8 and upgrading to Win 8.1 removed these files and I needed to reinstall them.

    LINK TO Win 8.1 media player files:

    www microsoft com/en-us/download/details aspx?id=40744


    I Found this and shadowpay start working :)
     

Share This Page