Prevent GPU encoder from being deprioritized with high GPU load?

Discussion in 'Videocards - AMD Radeon Drivers Section' started by Espionage724, Nov 17, 2021.

  1. Espionage724

    Espionage724 Master Guru

    Messages:
    311
    Likes Received:
    151
    GPU:
    RTX 3060 XC BLACK
    If I'm using my GPU's encoder, I would like it to retain it's performance regardless of GPU load, and worst-case, I'd like the GPU to lower 3D performance in order to keep the encoder usage open.

    I have a RX 580 and do VR with a Quest 2. If GPU usage gets near-max, the encoder starts dropping frames, making everything appear laggy from within VR, even if it's rendering at high FPS still. I want the encoder prioritized above all else.

    Is there some setting to control encoder priority or performance ratio from AMD's drivers, possibly in the registry?
     
  2. Caesar

    Caesar Maha Guru

    Messages:
    1,409
    Likes Received:
    563
    GPU:
    GTX 1070Ti Titanium
    the cores for encoding and 3D works independently i think

    NVIDIA-decode-and-encode-matrix.png
     
  3. Astyanax

    Astyanax Ancient Guru

    Messages:
    12,432
    Likes Received:
    4,753
    GPU:
    GTX 1080ti
    totally seperate fixed function components, but they operate at same clocks.
     
  4. justdoge

    justdoge Member Guru

    Messages:
    109
    Likes Received:
    23
    GPU:
    MSI RX580 Gaming X
    actually not so separate in amd hardware, im talking polaris. encoding process is tied to 3d and uses some of its power, thats why op has this issue. no idea if they improved it in rdna, tests would be needed by some1 who know what he is doing

    most probably no, your best bet is to use relive from amd driver, second best option for performance is streamfx plugin for obs which has amf via ffmpeg with working zero-copy when using gpu number -1 (minus 1) in obs settings
     
    Espionage724 likes this.

Share This Page