Power Supply Making Buzzing Noise under load

Discussion in 'General Hardware' started by BenTTwiG, Jun 8, 2008.

  1. BenTTwiG

    BenTTwiG Member Guru

    Messages:
    174
    Likes Received:
    0
    GPU:
    Asus Strix GTX 970
    Ok I have an Ultra X-connect 500watt Modular PSU.

    <--- Rest of components.

    I also had this issue with my old comp that died.

    Anyway, under full load it seems (Happens fastest when I start to play WoW, but can play Age of Conan for a long period and it doesn't happen.) the power supply will start to intermittently emit a buzzing electrical sound.

    It will kinda go on/off for a while withing seconds of it starting. Then after a bit if I don't exit out of the game I'm playing it will turn into a constant buzz.

    Once I exit the game and let my computer sit idle for about 10-15 minutes it stops making the noise. But once I put it under load it will happen again.

    As I stated above it did this when I first got it also. Although I didn't put it under full load for over a month as I was working doubles and only used the computer to check email ect for quit awhile.

    is there no easy way to fix this issue? What can be causing it?

    The PSU is still under warranty with Ultra it's a 3 year warranty (Forgot to register it within 30days of buying it or it would have been lifetime.). There tech lines are closed on the weekends so I have to wait till monday to even call them.

    There site also doesn't even list my model anymore ULT33152.
    So what do you think they will do? Anyone ever try to RMA something to Ultra?

    I had to RMA a harddrive back to Western Digital a few months back and they sent me the new drive first and basically put a hold on my CC for the amount of the HD. Ultra's site says they do something similar so was thinking of trying to go that route.


    Any tips ideas ect?
     
  2. Makalu

    Makalu Ancient Guru

    Messages:
    4,197
    Likes Received:
    0
    GPU:
    EVGA 8800 Ultra
    Since you had this issue with your last computer it's possible that you have better hearing than normal...some people hear buzzing from all power supplies that most of us don't hear. Just thought I'd mention that. Some things to try are if it's plugged into a UPS or a surge suppressor/power strip then try plugging it directly into the wall. Also can try plugging it into a wall socket that is on a different circuit.

    If that doesn't change it then try increasing the 5V load by plugging an old hard or optical drive if you have one that still powers on (no need to connect a data cable to it).

    If none of that changes anything then you can try to fix it by opening the PSU and pumping more hot glue around the coils to see if it's being caused by harmonic vibrations there...but of course that will violate the warranty and I'd be more willing to just RMA it and try another unit first. Sorry, nope I have no experience with Ultra RMA but I don't recall hearing any horror stories with them either.
     
  3. BenTTwiG

    BenTTwiG Member Guru

    Messages:
    174
    Likes Received:
    0
    GPU:
    Asus Strix GTX 970
    Thanks I'll try hitting up another outlet in the office luckily theres one not too far away but I'll still have to move my case and monitor ect to try :p but if it works it will be worth it.
     
  4. BenTTwiG

    BenTTwiG Member Guru

    Messages:
    174
    Likes Received:
    0
    GPU:
    Asus Strix GTX 970
    Tried different plug on power strip same thing, tried different plug on the outlet the power strip is on same thing, tried an outlet on the other side of the house still same thing.

    Put computer in my old case with a 480w Thermaltake PSU no noises yet...
     

  5. BenTTwiG

    BenTTwiG Member Guru

    Messages:
    174
    Likes Received:
    0
    GPU:
    Asus Strix GTX 970
    Called Ultra this morning. Gonna do an RMA/Swap for my PSU.

    Doing an Advanced swap so had to give them my CC info.

    They don't have this model of PSU anymore so getting me the V-Series 500w PSU as a replacement.
     
  6. Makalu

    Makalu Ancient Guru

    Messages:
    4,197
    Likes Received:
    0
    GPU:
    EVGA 8800 Ultra
    ah well it was worth a shot...going from a UPS to the wall is more likely to solve a buzzing issue though. I hope the RMA process goes smoothly for you and the new one is trouble free.
     
  7. BenTTwiG

    BenTTwiG Member Guru

    Messages:
    174
    Likes Received:
    0
    GPU:
    Asus Strix GTX 970
    yeah it looks like it should. Already have tracking number for the new one. Being shipped UPS ground usually takes 2-3 business days for that. Then I just toss the other one in the box put the label on it and drop it off at the UPS place near me.
     
  8. theworldisover

    theworldisover Maha Guru

    Messages:
    1,272
    Likes Received:
    0
    GPU:
    Msi 960 gamer 2gb
    did u get a new psu? and did it help?
     
  9. BenTTwiG

    BenTTwiG Member Guru

    Messages:
    174
    Likes Received:
    0
    GPU:
    Asus Strix GTX 970
    Got new PSU earlier this week. No buzzing from it and I stressed it pretty good I think. Added 2 more fans, and another HD to what was on it with the old PSU. Was running WoW, BF2, and Burning a DVD at the same time and no issues.

    Sent out the old/bad PSU on friday after work. It should arrive to Ultra on the 17th. I'll have to wait and see how long it takes them to refund my 50$ for the advanced RMA.

    (note they paid shipping for both the new one coming to me and the bad one going to them. So far there RMA service has been great.)
     

Share This Page