Possible to improve my NVIDIA card OpenGL performance on XBMC?

Discussion in 'The HTPC, HDTV & Ultra High Definition section' started by Nazgulled, Apr 7, 2009.

  1. Nazgulled

    Nazgulled Active Member

    Messages:
    60
    Likes Received:
    0
    GPU:
    Gigabyte GTX780 OC 3GB
    For the ones who don't know, XBMC is an open-source software much like Windows Media Center, but in my opinion, much better. It uses OpenGL to render it's user interface.

    Recently an awesome skin was released to the public, Aeon. This skin has lots of graphics and effects like gloss, transparency, reflections, etc... And it's rather jerky on my system.

    I run XBMC at 1920x1080 @ 50Hz and in the main menu (in Aeon of course) where's there are not many graphic elements, the skin is smooth and is constantly around 50fps. In all other places the framerate drops considerable to half (due to v-sync, cause it can't keep up with the 50Hz refresh rate; I need v-sync on or I'll have tearing issues). In the showcase view (something like coverflow in iTunes) it gets worse, it drops below 20fps.

    I understand that his can be rather intensive to the system, running at 1920x1080 and with lots of graphic effects, maybe the graphics card doesn't have power enough, or does it? That's what I want to know, from your opinions and/or suggestions to try and improve the rendering.

    The processor usage using this skin is normally between 20% to 35%, sometimes it goes higher depending on the graphic elements on the screen. Bear in mind though that I have a couple of background tasks (already tried to disable them all but this has no impact in rendering). All this to say that the problem probably lies in the GPU and not the CPU since it ever gets fully loaded.

    The system where I run XBMC like this is the following:
    OS: Windows Vista SP1 (32bits)
    CPU: AMD Athlon X2 4850e
    RAM: Kingston 2GB DDR2
    MOBO: Asus M3N78-EM (mGPU, GeForce 8300)

    The screenshot attached is one of the places where the framerate drops considerable making the user experience very slow. All the music artwork has a resolution of 512x512. Changing this resolution to 256x256 (via XBMC setting, no actually resizing all artwork), makes the skin smoother but the artwork quality drops quite a bit.

    [​IMG]

    To finish, another user on the XBMC's forums said he was running the same OS version, with the same CPU and RAM but with different graphics card. Don't know which motherboard it is, but it's running the integrated 780G. Which is similar to my GeForce 8300. He gave no additional details than this info (already tried to reach me but still don't have an answer) but said that Aeon was running "smooth like butter" on his system and I'm wondering why can't I run it like that too...

    Isn't my system powerful enough? Aren't NVIDIA's good for OpenGL? Any suggestions to try and improve the performance of my IGPU? Any suggestions at all? Something in the BIOS or something in the graphics settings? Anything?

    I'm running 182.50 of the ForceWare drivers by the way...
     
    Last edited: Apr 7, 2009
  2. SnooSnoo

    SnooSnoo Maha Guru

    Messages:
    1,178
    Likes Received:
    0
    GPU:
    Intel HD510
    Maybe try different sets of drivers. Here in the forum under "nVidia modified drivers" there are sidebands modified drivers. Try those... and others.

    Thats said, Ill try it too and report back as soon as I got time. I run xp sp3 on my htpc tho.
    <-- And those are the specs
     
  3. Nazgulled

    Nazgulled Active Member

    Messages:
    60
    Likes Received:
    0
    GPU:
    Gigabyte GTX780 OC 3GB
    Can't find any for download :/
     
  4. SnooSnoo

    SnooSnoo Maha Guru

    Messages:
    1,178
    Likes Received:
    0
    GPU:
    Intel HD510
    Aww, thats a shame... you can still try and google for, idk ngo drivers or whatnot :/

    Also, try some older official, or mby even a new beta... a lot of work I know.
     

  5. Nazgulled

    Nazgulled Active Member

    Messages:
    60
    Likes Received:
    0
    GPU:
    Gigabyte GTX780 OC 3GB
    Older drivers didn't solve anything, don't like to install betas, I'll wait for final.

    Have you tested XBMC with Aeon on your system? How does it run in Showcase with flow mode turned on?
     
  6. SnooSnoo

    SnooSnoo Maha Guru

    Messages:
    1,178
    Likes Received:
    0
    GPU:
    Intel HD510
    Just tried it, its awesome! Great looking piece of software. Got the aeon skin going and it seems to roll nicely. Showcase dint show anything till now, the media center doesent work with my sattelite card it would seem. Ill check showcase with my movies with flow enabled to see the results, for now it works perfectly.
     
  7. SnooSnoo

    SnooSnoo Maha Guru

    Messages:
    1,178
    Likes Received:
    0
    GPU:
    Intel HD510
    It's also quite sluggish here, seems to need quite a bit of GPU/CPU powwah, this mofo.. I guess I'll stick to not using any media centre coz none available will work with my sat card (except MythTV on ubuntu).
     

Share This Page