Possible Mafia II stutter fix... need testers.

Discussion in 'Games, Gaming & Game-demos' started by CPC_RedDawn, Aug 30, 2010.

  1. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    8,886
    Likes Received:
    1,149
    GPU:
    6800XT Nitro+ SE
    Right this may very well be placebo. However, I still have stutter but not as much as I did.

    Running the game maxed out @ 1680x1050 PhysX OFF (258.96 WHQL)

    This is what I did.

    I realised I had more than 1 version of C++ 2008 x64 installed so I uninstalled them, leaving the latest version installed.

    Ran CCleaner to check for any left overs.

    I then realised I did not have C++ 2010 installed. So I installed both x86 and x64 versions. Checked Microsoft Update for anything newer, nothing found.

    I defragged and did a check disk (CHKDSK).

    I do get stutter, but it has gone down dramatically by the looks of things.

    Hopefully someone else here can test this, to confirm it.
     
  2. Pvfc-Epic

    Pvfc-Epic Maha Guru

    Messages:
    1,188
    Likes Received:
    0
    GPU:
    ASUS GTX560Ti DirectCU II
    is this stutter only on gtx4xx series cards ? cuz no stutter here at all running 1680x1050 and 1920x1080 on my tv all high. apex physx medium (with tweak) and get avg 42fps with a rank of C on the benchmark
     
  3. CPC_RedDawn

    CPC_RedDawn Ancient Guru

    Messages:
    8,886
    Likes Received:
    1,149
    GPU:
    6800XT Nitro+ SE
    When I say stutter, I mean the known issue the game has with streaming/loading data. I am getting 60fps 90% of the time. However, when entering building the fps jumps up and down and stutters. When its night time the game stutters more than in the day. And when driving into new areas the game will stutter to load the next area up. This should not happen.

    Also setting "Max pre rendered frames" in Nvidia control panel to 0 helps out a lot too. I had mine set to default of 3.

    EDIT:

    Setting "Mac pre rendered frames" to 0 really really helps for me as well. Stutter is practically gone now, apart from when loading new areas which used to stutter about 4 times now its once and then back to 60fps again. Have not check in doors yet, only got the foundry mission.
     
    Last edited: Aug 30, 2010
  4. Finchwizard

    Finchwizard Don Apple

    Messages:
    16,440
    Likes Received:
    7
    GPU:
    -
    No stutter here.

    And I have PhysX on high. (After tweak)

    The only time I get drops is through one of the tunnels, and it only go's from 60.1fps to 59.2fps.

    The rest of the time it's rock solid no stuttering.
     

  5. Jeremy

    Jeremy Ancient Guru

    Messages:
    4,070
    Likes Received:
    0
    GPU:
    -
    Haha do you even notice a 0.9 change in fps when it is already that high?
     
  6. Finchwizard

    Finchwizard Don Apple

    Messages:
    16,440
    Likes Received:
    7
    GPU:
    -
    There's a slightest pause for the most fraction of a second.
    I only notice because I have fps showing.

    Sure it would be higher if VSycn was off. Was about 120fps in the demo.
     
  7. Kill4L

    Kill4L Master Guru

    Messages:
    382
    Likes Received:
    1
    GPU:
    GTX 1070 Laptop
    sorry for the offtopic can u please share the link how to tweak physx?
     
  8. shimyns

    shimyns Ancient Guru

    Messages:
    1,657
    Likes Received:
    0
    GPU:
    SAPPHIRE r9 290x Tri-X OC
    Game started stuttering very badly when I played it yesterday, especially at night. I play it at maximum settings at 1920x1200 (no physX) and my FPS is usually between 40-60 (with v-sync). The game just streams really choppy on my rig and it is a big turn off for me.


    Edit: LOL! "especially at night" meaning in game; not when I play it at night. Pfffff :3eyes:
     
  9. Finchwizard

    Finchwizard Don Apple

    Messages:
    16,440
    Likes Received:
    7
    GPU:
    -
  10. heltonxl

    heltonxl Banned

    Messages:
    13
    Likes Received:
    0
    GPU:
    HD 5850
    fix for stutters, frame drops

    to fix the stutters and frame drops in mafia 2 , download fps limiter 0.2, and
    use a setting like 50, 45 to cap the fps , the game will run perfect, smooth.
     

  11. shimyns

    shimyns Ancient Guru

    Messages:
    1,657
    Likes Received:
    0
    GPU:
    SAPPHIRE r9 290x Tri-X OC
    Any tweaks for non-Nvidia users? It's like the loading time is all crap. I have 4 Gb RAM and ample virtual RAM as well. I had no stuttering in JC2, for example...


    I heard that there is a memory leak problem. IDK, maybe it's my HD's :

    http://www.newegg.com/Product/Product.aspx?Item=N82E16822144701
    http://www.newegg.com/Product/Product.aspx?Item=N82E16822136055


    I have the game installed on a second partition of one of teh harddrives with the OS installed on the first partition...

    I've never really found a consensus on the best configeration for partitions and virtual memory.

    Whatever, a bit off topic, anyway if anyone has any tweaks for ATI, let me know. I'll try turning off ambient occlusion; maybe that will help...
     
    Last edited: Aug 30, 2010
  12. Outrance

    Outrance Ancient Guru

    Messages:
    1,701
    Likes Received:
    0
    GPU:
    2x HD6950 950Mhz/1350Mhz
    Mine stutters after alt-tabbing out, having a break for a bit, then alt-tabbing back in. The stutter is small at first then gets progressively worse the longer I play, until the point where it's unplayable. The streaming is borked somehow. If I don't alt-tab out at all, then I can play as long as I want with only minor stuttering (to be expected on my rig). I have Physx and AA off, everything else maxed.
     
  13. TirolokoRD

    TirolokoRD Ancient Guru

    Messages:
    1,934
    Likes Received:
    0
    GPU:
    EVGA 980TI ACX 2
    I am having very bad performance in this game, using latest drivers but seems like there is something else.

    Will double check that.
     
  14. Gembel

    Gembel Master Guru

    Messages:
    780
    Likes Received:
    0
    GPU:
    Asus GTX660 DirectCU 2
    Same here... I just defragged my HDD and set max pre rendered frames to 0 and all stutters gone even at night :banana:
    Yeah :)
     
  15. DM_777

    DM_777 Master Guru

    Messages:
    210
    Likes Received:
    0
    GPU:
    Winfast 9600GT & HD3870
    well mine stutter when suddenly my GPU usage went down to 0%, and i have to pause and wait till it went back to normal usage, but during normal GPU usage i had 40+ FPS, with shadow on low and Physx Off (obviously), and resolution at max (1680x1050), already tried changing using various setup, but still had that abnormality.

    and it happened at random.
     

Share This Page